File check.spec of Package check

#
# spec file for package check
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           check
Version:        0.9.10
Release:        0
Summary:        Unit Test Framework for C
License:        LGPL-2.1+
Group:          Development/Libraries/C and C++
Url:            http://check.sourceforge.net/
Source:         http://downloads.sourceforge.net/project/check/check/0.9.10/%{name}-%{version}.tar.gz
Source99:       baselibs.conf
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  pkg-config

%description
Check is a unit test framework for C. It features a simple interfacefor
defining unit tests, limitating the developer the less possible. Tests
are run in a separate address space, so Check cancatch both, assertion
failures and code errors that cause segmentationfaults or other
signals. The output of unit tests can be used within source code
editors and IDEs.

%package devel
Summary:        Unit Test Framework for C
Group:          Development/Libraries/C and C++
Requires:       %{name} = %{version}
Requires:       glibc-devel
Recommends:     pgk-config

%description devel
Check is a unit test framework for C. It features a simple interface
for defining unit tests, putting little in the way of the developer.
Tests are run in a separate address space, so Check can catch both
assertion failures and code errors that cause segmentation faults or
other signals. The output from unit tests can be used within source
code editors and IDEs.

%prep
%setup -q

%build
export CFLAGS="%{optflags} -std=gnu99"
export CXXFLAGS="%{optflags} -std=gnu99"
export FFLAGS="%{optflags} -std=gnu99"
%configure --disable-static --with-pic
make %{?_smp_mflags} docdir=%{_docdir}/%{name}

%install
%makeinstall docdir=%{_docdir}/%{name}
%{__cp} -a AUTHORS COPYING.LESSER THANKS TODO %{buildroot}%{_docdir}/%{name}
%{__rm} -f %{buildroot}%{_libdir}/*.la

%post -p /sbin/ldconfig

%post devel
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz

%postun -p /sbin/ldconfig

%postun devel
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz

%files
%defattr (-, root, root)
%doc %dir %{_docdir}/%{name}
%doc %{_docdir}/%{name}/[ACNRST]*
%{_libdir}/*.so.*

%files devel
%defattr (-, root, root)
%dir %{_datadir}/aclocal
%{_datadir}/aclocal/*.m4
%{_includedir}/*.h
%doc %{_infodir}/%{name}.info*
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%doc %{_docdir}/%{name}/example
%{_bindir}/checkmk
%{_mandir}/man1/checkmk.1%{?ext_man}

%changelog
openSUSE Build Service is sponsored by