File lmdb.spec of Package lmdb

#
# spec file for package lmdb
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           lmdb
Summary:        Lightning Memory-Mapped Database Manager
License:        OLDAP-2.8
Group:          Productivity/Databases/Tools
%define lname	liblmdb-0_9_17
Version:        0.9.17
Release:        0
Url:            http://symas.com/mdb/

#Git-Clone:	git://git.openldap.org/openldap mdb.master
Source:         https://github.com/LMDB/lmdb/archive/LMDB_%version.tar.gz
Source99:       baselibs.conf

# PATCH-FIX-UPSTREAM - debugging tools (https://github.com/kacfengine/lmdb)
Patch1:         0001-Add-extra-tools-and-CFEngine-modifications-for-LMDB.patch
# PATCH-FIX-UPSTREAM - configure.ac, Makefile.am, etc.
Patch2:         0002-Autoconf-files.patch
# PATCH-FIX-OPENSUSE - Implicit declaration of atol()
Patch3:         liblmdb-implicit-decl.patch

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  autoconf
BuildRequires:  automake >= 1.10
BuildRequires:  libtool >= 2

%description
LMDB is a Btree-based database management library with an API similar
to BerkeleyDB. The library is thread-aware and supports concurrent
read/write access from multiple processes and threads. The DB
structure is multi-versioned, and data pages use a copy-on-write
strategy, which also provides resistance to corruption and eliminates
the need for any recovery procedures. The database is exposed in a
memory map, requiring no page cache layer of its own.

%package -n %lname
Summary:        Shared library for Lightning Memory-Mapped Database (LMDB)
Group:          System/Libraries

%description -n %lname
LMDB is a Btree-based database management library with an API similar
to BerkeleyDB. The library is thread-aware and supports concurrent
read/write access from multiple processes and threads. The DB
structure is multi-versioned, and data pages use a copy-on-write
strategy, which also provides resistance to corruption and eliminates
the need for any recovery procedures. The database is exposed in a
memory map, requiring no page cache layer of its own.

This package contains the shared library.

%package devel
Summary:        Development package for lmdb
Group:          Development/Libraries/C and C++
Requires:       %lname = %version

%description devel
LMDB is a Btree-based database management library with an API similar
to BerkeleyDB. The library is thread-aware and supports concurrent
read/write access from multiple processes and threads. The DB
structure is multi-versioned, and data pages use a copy-on-write
strategy, which also provides resistance to corruption and eliminates
the need for any recovery procedures. The database is exposed in a
memory map, requiring no page cache layer of its own.
 
This package contains the files needed to compile programs that use
the liblmdb library.

%prep
%setup -qn lmdb-LMDB_%version
%patch1 -p1
%patch2 -p1
%patch3 -p1

%build
cd libraries/liblmdb
mkdir -p m4
autoreconf -fi
%configure --disable-static
make %{?_smp_mflags} V=1

%install
cd libraries/liblmdb
make install DESTDIR="%buildroot"
rm -f "%buildroot/%_libdir"/*.la
(cd %buildroot/%_libdir; mv liblmdb.so liblmdb-%version.so; ln -s liblmdb-%version.so liblmdb.so)

%post   -n %lname -p /sbin/ldconfig
%postun -n %lname -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc libraries/liblmdb/CHANGES
%doc libraries/liblmdb/COPYRIGHT
%doc libraries/liblmdb/LICENSE
%{_bindir}/*

%files -n %lname
%defattr(-,root,root)
%_libdir/liblmdb-%version.so

%files devel
%defattr(-,root,root)
%_includedir/*
%_libdir/liblmdb.so

%changelog
openSUSE Build Service is sponsored by