File gnome-software.spec of Package gnome-software

#
# spec file for package gnome-software
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define gs_plugin_api 11
Name:           gnome-software
Version:        3.26.7
Release:        0
Summary:        GNOME Software Store
License:        GPL-2.0-or-later
Group:          System/GUI/GNOME
URL:            https://wiki.gnome.org/Design/Apps/Software
Source0:        http://download.gnome.org/sources/gnome-software/3.26/%{name}-%{version}.tar.xz

BuildRequires:  gtk-doc
BuildRequires:  intltool >= 0.35.0
BuildRequires:  meson
BuildRequires:  pkgconfig
BuildRequires:  suse-xsl-stylesheets
BuildRequires:  pkgconfig(appstream-glib) >= 0.7.0
BuildRequires:  pkgconfig(flatpak) >= 0.8.0
BuildRequires:  pkgconfig(fwupd) >= 0.9.7
BuildRequires:  pkgconfig(gdk-pixbuf-2.0) >= 2.31.5
BuildRequires:  pkgconfig(gio-unix-2.0) >= 2.46.0
BuildRequires:  pkgconfig(gnome-desktop-3.0) >= 3.17.92
BuildRequires:  pkgconfig(gsettings-desktop-schemas) >= 3.11.5
BuildRequires:  pkgconfig(gtk+-3.0) >= 3.18.2
BuildRequires:  pkgconfig(gtkspell3-3.0)
BuildRequires:  pkgconfig(gudev-1.0)
BuildRequires:  pkgconfig(json-glib-1.0) >= 1.1.1
BuildRequires:  pkgconfig(libsecret-1)
BuildRequires:  pkgconfig(libsoup-2.4) >= 2.51.92
BuildRequires:  pkgconfig(libxslt)
BuildRequires:  pkgconfig(packagekit-glib2) >= 1.1.0
BuildRequires:  pkgconfig(polkit-gobject-1)
BuildRequires:  pkgconfig(rpm)
BuildRequires:  pkgconfig(sqlite3)
BuildRequires:  pkgconfig(valgrind)
Requires:       iso-codes
Requires:       libzypp-plugin-appdata
Recommends:     %{name}-lang

%description
AppStore like management of Applications for your GNOME Desktop.

%package devel
Summary:        Development files for the GNOME software store
Group:          Development/Libraries/GNOME
Requires:       %{name} = %{version}

%description devel
This subpackage contains the header files for developing
GNOME software store plugins.

%lang_package

%prep
%autosetup -p1

%build
%meson \
	-D enable-ubuntu-reviews=false \
	-D enable-ubuntuone=false \
	-D enable-tests=false \
	-D enable-fwupd=true \
	-D enable-gtkspell=true \
	%{nil}
%meson_build

%install
%meson_install

# Test shipping gnome-software-local-file in GN
# Currently not shipped, as this is not yet functional (boo#941862)
rm %{buildroot}%{_datadir}/applications/gnome-software-local-file.desktop
%find_lang %{name}

%files
%license COPYING
%{_bindir}/%{name}
%{_bindir}/%{name}-editor
%{_datadir}/%{name}/
%dir %{_datadir}/app-info
%dir %{_datadir}/app-info/xmls
%{_datadir}/app-info/xmls/org.gnome.Software.Featured.xml
%dir %{_datadir}/metainfo
%{_datadir}/metainfo/org.gnome.Software.appdata.xml
%{_datadir}/metainfo/org.gnome.Software.Plugin.Epiphany.metainfo.xml
%{_datadir}/metainfo/org.gnome.Software.Plugin.Flatpak.metainfo.xml
%{_datadir}/metainfo/org.gnome.Software.Plugin.Fwupd.metainfo.xml
%{_datadir}/metainfo/org.gnome.Software.Plugin.Odrs.metainfo.xml
%{_datadir}/metainfo/org.gnome.Software.Plugin.Steam.metainfo.xml
# Test shipping gnome-software-local-file in GN
# Currently not shipped, as this is not yet functional (boo#941862)
#{_datadir}/applications/gnome-software-local-file.desktop
%{_datadir}/applications/org.gnome.Software.desktop
%{_datadir}/dbus-1/services/org.gnome.Software.service
%{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
%{_datadir}/glib-2.0/schemas/org.gnome.software.gschema.xml
%dir %{_datadir}/gnome-shell
%dir %{_datadir}/gnome-shell/search-providers
%{_datadir}/gnome-shell/search-providers/org.gnome.Software-search-provider.ini
%{_datadir}/icons/hicolor/*/apps/org.gnome.Software*
%{_datadir}/icons/hicolor/scalable/apps/software-installed-symbolic.svg
%dir %{_libdir}/gs-plugins-%{gs_plugin_api}
%{_libdir}/gs-plugins-%{gs_plugin_api}/*.so
#{_libexecdir}/gnome-software-service
%{_libexecdir}/gnome-software-cmd
%{_libexecdir}/gnome-software-restarter
%{_mandir}/man1/%{name}.1%{?ext_man}
%{_mandir}/man1/%{name}-editor.1%{?ext_man}
%{_sysconfdir}/xdg/autostart/gnome-software-service.desktop
%{_datadir}/applications/org.gnome.Software.Editor.desktop

%files devel
%dir %{_includedir}/%{name}
%{_datadir}/gtk-doc/html/%{name}/
%dir %{_datadir}/doc/gnome-software
%{_datadir}/doc/gnome-software/README
%{_includedir}/%{name}/gnome-software.h
%{_includedir}/%{name}/gs-app-list.h
%{_includedir}/%{name}/gs-app.h
%{_includedir}/%{name}/gs-auth.h
%{_includedir}/%{name}/gs-category.h
%{_includedir}/%{name}/gs-os-release.h
%{_includedir}/%{name}/gs-plugin-vfuncs.h
%{_includedir}/%{name}/gs-plugin.h
%{_includedir}/%{name}/gs-plugin-event.h
%{_includedir}/%{name}/gs-plugin-types.h
%{_includedir}/%{name}/gs-price.h
%{_includedir}/%{name}/gs-utils.h
%{_libdir}/pkgconfig/gnome-software.pc

%files lang -f %{name}.lang

%changelog
openSUSE Build Service is sponsored by