File javapackages-tools.spec of Package javapackages-tools

#
# spec file for package javapackages-tools
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           javapackages-tools
Version:        4.4.0
Release:        0
Summary:        Macros and scripts for Java packaging support
License:        BSD-3-Clause
Group:          Development/Languages/Java
Url:            https://fedorahosted.org/released/javapackages/doc/
Source:         https://fedorahosted.org/released/javapackages/javapackages-%{version}.tar.xz
#PATCH-FIX-SUSE: SUSE does store jvm related things in libdir - ie /usr/lib64 on 64bits
#                where Fedora use jpackage convention - usr/lib everywhere
Patch0:         suse-use-libdir.patch
#PATCH-FIX-SUSE: We put macros to /etc/rpm directly so make it reflected by
#                the install script
Patch1:         suse-macros-install-location.patch
BuildRequires:  asciidoc
BuildRequires:  dia
BuildRequires:  fdupes
BuildRequires:  python-devel
BuildRequires:  python-lxml
BuildRequires:  python-nose
BuildRequires:  python-pyxb
BuildRequires:  python-setuptools
BuildRequires:  python-six
BuildRequires:  rpm
BuildRequires:  xmlto
BuildRequires:  xz
Requires:       coreutils
Requires:       lua
Requires:       python
# Well even tho python is split it is required for most of the operations
Requires:       python-javapackages = %{version}
# for the xb pom conversions
Requires:       python-pyxb
Requires:       python-six
# for xml.dom.minidom
Requires:       python-xml
Provides:       jpackage-utils = %{version}
Provides:       jpackage-utils-java9 = %{version}
Obsoletes:      jpackage-utils <= 1.7.5
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
# for xsltproc
%if 0%{?suse_version} == 1110
# disable pbc on sle11 as there is clash in directories we don't care about
BuildRequires:  -post-build-checks
Requires:       libxslt
%else
Requires:       libxslt-tools
%endif

%description
This package provides macros and scripts to support Java packaging.

%package -n maven-local
Summary:        Macros and scripts for Maven packaging support
Group:          Development/Languages/Java
Requires:       %{name} = %{version}
Requires:       javapackages-local = %{version}

%description -n maven-local
This package provides macros and scripts to support packaging Maven artifacts.

%package -n ivy-local
Summary:        Local mode for Apache Ivy
Group:          Development/Languages/Java
Requires:       %{name} = %{version}
Requires:       ant
Requires:       javapackages-local = %{version}

%description -n ivy-local
This package implements local mode fow Apache Ivy, which allows
artifact resolution using XMvn resolver.

%package -n python-javapackages
Summary:        Module for handling various files for Java packaging
Group:          Development/Languages/Java
Requires:       python-lxml

%description -n python-javapackages
Module for handling, querying and manipulating of various files for Java
packaging in Linux distributions

%package doc
Summary:        Guide for Java packaging
Group:          Development/Languages/Java

%description doc
User guide for Java packaging and using utilities from javapackages-tools

%package -n javapackages-local
Summary:        Non-essential macros and scripts for Java packaging support
Group:          Development/Languages/Java
Requires:       %{name} = %{version}

%description -n javapackages-local
This package provides non-essential macros and scripts to support Java packaging.

%prep
%setup -q -n javapackages-%{version}
%patch0 -p1
%patch1 -p1

%build
%configure --rpmconfigdir=%{_sysconfdir}/rpm/
./build

%install
./install
sed -e 's/.[17]$/&.gz/' -e 's/.py$/&*/' -i files-*

rm -rf %{buildroot}%{_datadir}/fedora-review/

%fdupes %{buildroot}/%{_prefix}

%check
%if 0%{?suse_version} >= 1210
./check
%endif

%files -f files-common
%defattr(-,root,root,-)
%doc LICENSE

%files -n javapackages-local -f files-local
%defattr(-,root,root,-)

%files -n maven-local -f files-maven
%defattr(-,root,root,-)

%files -n ivy-local -f files-ivy
%defattr(-,root,root,-)
%dir %{_sysconfdir}/ant.d

%files -n python-javapackages
%defattr(-,root,root,-)
%doc LICENSE
%{python_sitelib}/javapackages*

%files doc -f files-doc
%defattr(-,root,root,-)
%doc LICENSE

%changelog
openSUSE Build Service is sponsored by