File perl-Text-Diff.spec of Package perl-Text-Diff

# vim: set ts=4 sw=4 et:
#
# spec file for package perl-Text-Diff (Version 1.40)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           perl-Text-Diff
%define cpan_name %( echo %{name} | %{__sed} -e 's,perl-,,' )
Summary:        Perform Diffs on Files and Record Sets
Version:        1.41
Release:        1
License:        GPL/Artistic
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/dist/Text-Diff
Source:         http://search.cpan.org/CPAN/authors/id/O/OV/OVID/Text-Diff-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Algorithm::Diff)
BuildRequires:  perl(Data::Dumper)
Requires:       perl(Algorithm::Diff)
Provides:       %{cpan_name}

%description
"diff()" provides a basic set of services akin to the GNU "diff"
utility. It is not anywhere near as feature complete as GNU "diff", but
it is better integrated with Perl and available on all platforms. It is
often faster than shelling out to a system's "diff" executable for small
files, and generally slower on larger files.

Relies on Algorithm::Diff for, well, the algorithm. This may not produce
the same exact diff as a system's local "diff" executable, but it will
be a valid diff and comprehensible by "patch". We haven't seen any
differences between Algorithm::Diff's logic and GNU diff's, but we have
not examined them to make sure they are indeed identical.




Authors:
--------
    Adam Kennedy <adamk@cpan.org>
    Barrie Slaymaker <barries@slaysys.com>

%prep
%setup -q -n %{cpan_name}-%{version}

%build
perl Makefile.PL OPTIMIZE="$RPM_OPT_FLAGS -Wall"
%{__make}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{?buildroot:%__rm -rf "%{buildroot}"}

%files -f %{name}.files
# normally you only need to check for doc files
%defattr(-, root, root)
%doc Changes LICENSE README

%changelog
openSUSE Build Service is sponsored by