File python-django-reversion.spec of Package python-django-reversion
#
# spec file for package python-django-reversion
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-django-reversion
Version: 1.8.6
Release: 0
Url: http://github.com/etianen/django-reversion
Summary: An app that provides comprehensive version control facilities for Django
License: BSD-3-Clause
Group: Development/Languages/Python
Source: https://pypi.python.org/packages/source/d/django-reversion/django-reversion-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-devel
Requires: python-django
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
django-reversion is an extension to the Django web framework that provides
comprehensive version control facilities.
* Roll back to any point in a model's history - an unlimited undo facility!
* Recover deleted models - never lose data again!
* Admin integration for maximum usability.
* Group related changes into revisions that can be rolled back in a single transaction.
* Automatically save a new version whenever your model changes using Django's flexible signalling framework.
* Automate your revision management with easy-to-use middleware.
%prep
%setup -q -n django-reversion-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%files
%defattr(-,root,root,-)
%doc CHANGELOG.rst LICENSE README.rst
%{python_sitelib}/*
%changelog