File anjuta.spec of Package anjuta

#
# spec file for package anjuta
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           anjuta
Version:        3.3.3
Release:        0
Summary:        Versatile Integrated Development Environment for GNOME
License:        GPL-2.0+
Group:          Development/Tools/IDE
Url:            http://anjuta.sourceforge.net/
Source:         http://download.gnome.org/sources/anjuta/3.3/%{name}-%{version}.tar.xz
Source99:       %{name}-rpmlintrc
BuildRequires:  autogen
BuildRequires:  binutils-devel
BuildRequires:  bison
BuildRequires:  fdupes
BuildRequires:  flex
BuildRequires:  gcc-c++
BuildRequires:  gnome-doc-utils-devel
BuildRequires:  gnome-icon-theme
BuildRequires:  gobject-introspection-devel
BuildRequires:  intltool
BuildRequires:  libapr-util1-devel
BuildRequires:  libapr1-devel
BuildRequires:  libxslt-devel
BuildRequires:  perl-gettext
BuildRequires:  shared-mime-info
BuildRequires:  sqlite3-devel
BuildRequires:  subversion-devel
BuildRequires:  translation-update-upstream
BuildRequires:  update-desktop-files
%ifnarch ia64 s390 s390x
BuildRequires:  valgrind-devel
%endif
# Only needed because we don't (and won't) support building xz tarballs by default... See bnc#697467
BuildRequires:  xz
BuildRequires:  pkgconfig(gdk-pixbuf-2.0)
BuildRequires:  pkgconfig(gdl-3.0)
BuildRequires:  pkgconfig(gladeui-2.0)
BuildRequires:  pkgconfig(glib-2.0)
BuildRequires:  pkgconfig(gtk+-3.0)
BuildRequires:  pkgconfig(gtksourceview-3.0)
BuildRequires:  pkgconfig(libdevhelp-3.0)
BuildRequires:  pkgconfig(libgda-5.0) >= 4.99.0
BuildRequires:  pkgconfig(libgraph)
BuildRequires:  pkgconfig(libgvc)
BuildRequires:  pkgconfig(libvala-0.14) >= 0.13.3
BuildRequires:  pkgconfig(libxml-2.0)
BuildRequires:  pkgconfig(neon)
BuildRequires:  pkgconfig(vte-2.90)
# Directly required by anjuta:
Requires:       autoconf
Requires:       autogen
Requires:       automake
Requires:       gettext
Requires:       libtool
# libgda-sqlite is needed by the symbol-db plugin. See bnc#624924.
Requires:       libgda-sqlite
Recommends:     %{name}-lang
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%glib2_gsettings_schema_requires

%description
Anjuta is a versatile Integrated Development Environment (IDE) for the
GNOME desktop. It features a number of advanced programming facilities
includes project management, application wizards, an interactive
debugger, an integrated Glade UI designer, integrated Devhelp API help,
an integrated Valgrind memory profiler, an integrated gprof performance
profiler, a class generator, a powerful source editor, source browsing,
and more.

%package -n libanjuta-3-0
Summary:        Libraries for developing Anjuta plugins
Group:          System/Libraries

%description -n libanjuta-3-0
Anjuta is a versatile Integrated Development Environment (IDE) for the
GNOME desktop. It features a number of advanced programming facilities
includes project management, application wizards, an interactive
debugger, an integrated Glade UI designer, integrated Devhelp API help,
an integrated Valgrind memory profiler, an integrated gprof performance
profiler, a class generator, a powerful source editor, source browsing,
and more.

%package -n typelib-1_0-Anjuta-3_0
Summary:        Libraries for developing Anjuta plugins -- Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-Anjuta-3_0
Anjuta is a versatile Integrated Development Environment (IDE) for the
GNOME desktop. It features a number of advanced programming facilities
includes project management, application wizards, an interactive
debugger, an integrated Glade UI designer, integrated Devhelp API help,
an integrated Valgrind memory profiler, an integrated gprof performance
profiler, a class generator, a powerful source editor, source browsing,
and more.

This package provides the GObject Introspection bindings for the Anjuta
library to develop plugins.

%package -n glade-catalog-anjuta
Summary:        Versatile Integrated Development Environment for GNOME -- Catalog for Glade
Group:          Development/Tools/GUI Builders
Requires:       %{name} = %{version}
Requires:       glade
Supplements:    packageand(glade:%{name}-devel)

%description -n glade-catalog-anjuta
Anjuta is a versatile Integrated Development Environment (IDE) for the
GNOME desktop. It features a number of advanced programming facilities
includes project management, application wizards, an interactive
debugger, an integrated Glade UI designer, integrated Devhelp API help,
an integrated Valgrind memory profiler, an integrated gprof performance
profiler, a class generator, a powerful source editor, source browsing,
and more.

This package provides a catalog for Glade, to allow the use the Anjuta
widgets in Glade.

%package devel
Summary:        Libraries for developing Anjuta plugins -- Development Files
Group:          Development/Tools/IDE
Requires:       libanjuta-3-0 = %{version}
Requires:       typelib-1_0-Anjuta-3_0 = %{version}
Provides:       %{name}-doc = %{version}
Obsoletes:      %{name}-doc < %{version}

%description devel
Anjuta is a versatile Integrated Development Environment (IDE) for the
GNOME desktop. It features a number of advanced programming facilities
includes project management, application wizards, an interactive
debugger, an integrated Glade UI designer, integrated Devhelp API help,
an integrated Valgrind memory profiler, an integrated gprof performance
profiler, a class generator, a powerful source editor, source browsing,
and more.

%lang_package
%prep
%setup -q
translation-update-upstream

%build
%configure\
        --disable-static \
        --disable-scrollkeeper
make %{?_smp_mflags} V=1

%install
%makeinstall
%if 0%{?suse_version} <= 1120
%{__rm} %{buildroot}%{_datadir}/locale/en@shaw/LC_MESSAGES/*
%endif
# These should go to defaultdocdir.
rm -r %{buildroot}%{_datadir}/doc
%suse_update_desktop_file anjuta
%find_lang anjuta %{?no_lang_C}
# There's no translation for those yet. If build fails because of non-packaged
# translations, uncomment those lines.
#%%find_lang anjuta-build-tutorial %{?no_lang_C} anjuta.lang
#%%find_lang anjuta-faqs %{?no_lang_C} anjuta.lang
%find_lang anjuta-manual %{?no_lang_C} anjuta.lang
find %{buildroot} -type f -name "*.la" -delete -print
%fdupes %{buildroot}

%post
%glib2_gsettings_schema_post
%desktop_database_post
%icon_theme_cache_post
%icon_theme_cache_post gnome
%mime_database_post

%postun
%glib2_gsettings_schema_postun
%desktop_database_postun
%icon_theme_cache_postun
%icon_theme_cache_postun gnome
%mime_database_postun

%post -n libanjuta-3-0
/sbin/ldconfig

%postun -n libanjuta-3-0
/sbin/ldconfig

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog FUTURE NEWS README doc/ScintillaDoc.html TODO
%dir %{_datadir}/gnome/
%dir %{_datadir}/gnome/help/
%dir %{_datadir}/gnome/help/anjuta-build-tutorial/
%doc %{_datadir}/gnome/help/anjuta-build-tutorial/C/
%dir %{_datadir}/gnome/help/anjuta-faqs/
%doc %{_datadir}/gnome/help/anjuta-faqs/C/
%dir %{_datadir}/gnome/help/anjuta-manual/
%doc %{_datadir}/gnome/help/anjuta-manual/C/
%{_bindir}/anjuta
%{_bindir}/anjuta-launcher
%{_bindir}/anjuta-tags
%{_libdir}/anjuta/
%{_datadir}/anjuta/
%{_datadir}/applications/*.desktop
%{_datadir}/mime/packages/*.xml
%{_datadir}/pixmaps/anjuta/
%{_datadir}/glib-2.0/schemas/*.gschema.xml
# When removing the gnome icon theme icons, don't forget to remove the %%icon_theme_cache_post(un) call for them
# Somehow I think that this is wrong:
%dir %{_datadir}/icons/gnome/*/mimetypes/
%{_datadir}/icons/gnome/*/mimetypes/*.png
%{_datadir}/icons/gnome/scalable/mimetypes/*.svg
%{_datadir}/icons/hicolor/*/apps/*.png
%{_datadir}/icons/hicolor/scalable/apps/*.svg
%doc %{_mandir}/man?/*.*

%files -n libanjuta-3-0
%defattr(-, root, root)
%{_libdir}/libanjuta-3.so.*

%files -n typelib-1_0-Anjuta-3_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/Anjuta-3.0.typelib
%{_libdir}/girepository-1.0/IAnjuta-3.0.typelib

%files -n glade-catalog-anjuta
%defattr(-, root, root)
%{_libdir}/glade/modules/libgladeanjuta.so
%{_datadir}/glade/catalogs/anjuta-glade.xml

%files devel
%defattr(-, root, root)
%doc %{_datadir}/gtk-doc/html/libanjuta/
%{_includedir}/libanjuta-3.0/
%{_libdir}/libanjuta-3.so
%{_libdir}/pkgconfig/libanjuta-3.0.pc
%{_datadir}/gir-1.0/*.gir

%files lang -f %name.lang

%changelog
openSUSE Build Service is sponsored by