File perl-Class-XSAccessor.spec of Package perl-Class-XSAccessor

#
# spec file for package perl-Class-XSAccessor
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           perl-Class-XSAccessor
Version:        1.11
Release:        1
Summary:        Generate fast XS accessors without runtime compilation
Source:         http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/Class-XSAccessor-%{version}.tar.gz
Url:            http://search.cpan.org/dist/Class-XSAccessor
Group:          Development/Libraries/Perl
License:        GPL+ or Artistic
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       perl = %{perl_version}
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  make
BuildRequires:  gcc
BuildRequires:  perl(Test::More)
BuildRequires:  perl(ExtUtils::MakeMaker)
BuildRequires:  perl(XSLoader)
Requires:       perl(XSLoader)

%description
Class::XSAccessor implements fast read, write and read/write accessors in
XS. Additionally, it can provide predicates such as "has_foo()" for
testing whether the attribute "foo" is defined in the object. It only
works with objects that are implemented as ordinary hashes.
Class::XSAccessor::Array implements the same interface for objects that
use arrays for their internal representation.

%prep
%setup -q -n "Class-XSAccessor-%{version}"
%__sed -i '/^auto_install/d' Makefile.PL

%build
%__perl Makefile.PL PREFIX="%{_prefix}"
%__make %{?jobs:-j%{jobs}} OPTIMIZE="%{optflags} -Wall"

%install
%perl_make_install
%perl_process_packlist

%check
%__make test

%clean
%{?buildroot:%__rm -rf "%{buildroot}"}

%files
%defattr(-,root,root)
%doc Changes README
%dir %{perl_vendorarch}/Class
%{perl_vendorarch}/Class/XSAccessor.pm
%{perl_vendorarch}/Class/XSAccessor
%dir %{perl_vendorarch}/auto/Class
%{perl_vendorarch}/auto/Class/XSAccessor
%doc %{perl_man3dir}/Class::XSAccessor.%{perl_man3ext}%{ext_man}
%doc %{perl_man3dir}/Class::XSAccessor::*.%{perl_man3ext}%{ext_man}

%changelog
openSUSE Build Service is sponsored by