File bugzilla.spec of Package bugzilla

#
# spec file for package bugzilla
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%if 0%{?suse_version} >= 1210
%define has_systemd 1
%endif
Name:           bugzilla
Version:        5.0.3
Release:        0
Summary:        Bug tracker for software development
License:        MPL-2.0
Group:          Development/Tools/Other
Url:            http://bugzilla.org/
Source:         http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
Source2:        http://downloads.sourceforge.net/project/bugzilla-de/5.0/5.0.3/%{name}-de-5.0.3-1.utf-8.tar.gz
Source3:        MPL-2.0.html
Source4:        %{name}.conf
Source5:        %{name}-rpmlintrc
Patch1:			fix_whine_error.patch
BuildRequires:  apache
BuildRequires:  fdupes
Requires:       apache
Requires:       apache2-mod_perl >= 1.999022
#Recommonds:	Apache-SizeLimit
Requires:       patchutils
Requires:       perl(CGI) >= 5.8.1
Requires:       perl-Authen-SASL
Requires:       perl-Chart >= 2.4.1
Requires:       perl-DBD-Pg >= 2.7.0
Requires:       perl-DBD-SQLite >= 1.29
Requires:       perl-DBD-mysql >= 4.001
Requires:       perl-DBI >= 1.614
#Recommends:		RadiusPerl
Requires:       perl-Daemon-Generic
Requires:       perl-DateTime >= 0.75
Requires:       perl-DateTime-TimeZone >= 1.64
Requires:       perl-Digest-SHA1
Requires:       perl-Email-MIME >= 1.904
Requires:       perl-Email-Reply
Requires:       perl-Email-Send >= 2.02
Requires:       perl-Email-Sender >= v1.300011
Requires:       perl-Encode >= 2.21
Requires:       perl-Encode-Detect
Requires:       perl-File-MimeInfo
Requires:       perl-File-Slurp >= 9999.13
Requires:       perl-GD >= 1.20
Requires:       perl-GDGraph
Requires:       perl-GDTextUtil
Requires:       perl-HTML-FormatText-WithLinks >= 0.13
Requires:       perl-HTML-Parser >= 3.67
Requires:       perl-HTML-Scrubber
Requires:       perl-IO-stringy
Requires:       perl-JSON-RPC
Requires:       perl-JSON-XS >= 2.01
Requires:       perl-List-MoreUtils >= 0.32
Requires:       perl-MIME-tools >= 5.406
Requires:       perl-Math-Random-ISAAC >= 1.0.1
Requires:       perl-Net-SMTP-SSL >= 1.01
Requires:       perl-PatchReader >= 0.9.6
Requires:       perl-SOAP-Lite >= 0.712
Requires:       perl-Template-GD
Requires:       perl-Template-Toolkit >= 2.24
Requires:       perl-Test-Taint >= 1.0.6
Requires:       perl-TheSchwartz >= 1.07
Requires:       perl-TimeDate >= 2.23
Requires:       perl-URI >= 1.55
Requires:       perl-XML-Twig
Requires:       perl-XMLRPC-Lite >= 0.712
Requires:       perl-base >= 5.8.1
Requires:       perl-ldap
Requires:       perl-libwww-perl
Requires:       perl-Module-Pluggable
Requires:       perl-Object-Pluggable
Requires:       perl-Cache-Memcached
Requires:       perl-File-Copy-Recursive
Requires:       perl-File-Which
Recommends:     perl-DBD-Oracle >= 1.19
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
%if 0%{?has_systemd}
BuildRequires:  systemd
%{?systemd_requires}
%else
# FIXME: use proper Requires(pre/post/preun/...)
PreReq:         %insserv_prereq
%endif

%description
Bugzilla is server software designed to help you manage software
development.

* Optimized database structure for increased performance and
  scalability
* Excellent security to protect confidentiality
* Advanced query tool that can remember your searches
* Integrated email capabilities
* Editable user profiles and comprehensive email preferences
* Comprehensive permissions system
* Proven under fire as Mozilla's bug tracking system

%package lang-de
Summary:        German language files for bugzilla
Group:          Development/Tools/Other
Requires:       %{name} = %{version}-%{release}

%description lang-de
This package includes german language files for bugzilla

%prep
%setup -q
%patch1 -p1

%build

%install
# Ensure shebang shell scripts have executable bit set
for file in `find -type f -perm /664`; do
  if head -1 $file | grep -E '^\#!' &>/dev/null; then
    chmod a+x $file
  fi
done
# Remove the execute bit from files that don't start with #!
for file in `find -type f -perm /111`; do
  if head -1 $file | grep -E -v '^\#!' &>/dev/null; then
    chmod a-x $file
  fi
done
# Hello bugzilla devs...
find . -type d "(" -name .bzr -o -name .git ")" \
	-exec rm -Rf "{}" "+"
find . -type f "(" -name ".git*" -o -name ".bzr*" -o -name ".travis*" ")" \
    -exec rm -Rf "{}" "+"
find . -type f -print0 | xargs -0r grep -l '^#!' | xargs -r chmod a+x
find . -type f -print0 | xargs -0r grep -l '^#!' | \
	xargs -r perl -i -pe 's{^#!%{_prefix}/local/}{#!%{_prefix}/}' "{}" "+"
mkdir -p "%{buildroot}/srv/www"
cp -a . "%{buildroot}/srv/www/%{name}"
tar -xzf %{SOURCE2}  --directory "%{buildroot}/srv/www/%{name}/template"

%fdupes %{buildroot}/srv

cp "%{SOURCE3}" .
#install bugzilla.conf to apache conf.d
install -D -m0640 %{SOURCE4} %{buildroot}%{_sysconfdir}/apache2/conf.d/bugzilla.conf
# remove included .htaccess which has been moved to bugzilla.conf
rm %{buildroot}/srv/www/bugzilla/.htaccess

%post
%if 0%{?has_systemd}
%service_add_post apache2.service
%else
%restart_on_update apache2
%endif

%postun
%if 0%{?has_systemd}
%service_del_postun apache2.service
%else
%restart_on_update apache2
%endif

%files
%defattr(-,root,root)
%doc MPL-2.0.html
%defattr(-,wwwrun,root)
# exclude language de_DE
%exclude /srv/www/bugzilla/template/de
%config(noreplace) %{_sysconfdir}/apache2/conf.d/bugzilla.conf
/srv/www/bugzilla

%files lang-de
%defattr(0644,wwwrun,root,755)
/srv/www/bugzilla/template/de

%changelog
openSUSE Build Service is sponsored by