File perl-Class-Accessor.spec of Package perl-Class-Accessor

#
# spec file for package perl-Class-Accessor
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           perl-Class-Accessor
%define cpan_name Class-Accessor
Summary:        Automated accessor generation
Version:        0.34
Release:        12
License:        Artistic-1.0
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/dists/Class-Accessor
Source:         %{cpan_name}-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Sub::Name)
Requires:       perl(Carp)
Requires:       perl(Sub::Name)
Provides:       %{cpan_name}

%description
This module automatically generates accessor/mutators for your class. Most of
the time, writing accessors is an exercise in cutting and pasting. 

If you make your module a subclass of Class::Accessor and declare your accessor
fields with mk_accessors() then you'll find yourself with a set of
automatically generated accessors which can even be customized!

Authors:
--------
	Michael G Schwern <schwern@pobox.com>

%prep
%setup -q -n %{cpan_name}-%{version}

%build
%{__perl} Makefile.PL OPTIMIZE="$RPM_OPT_FLAGS -Wall"
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf $RPM_BUILD_ROOT

%files -f %{name}.files
%defattr(-,root,root)
%doc Changes README examples

%changelog
openSUSE Build Service is sponsored by