File python-jupyter_notebook-doc.spec of Package python-jupyter_notebook

#
# spec file for package python-jupyter_notebook-doc
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# Building docs needs root access
%bcond_with pdf
%bcond_with html

%if 0%{?suse_version} && 0%{?suse_version} > 1320
%bcond_without tests
%else
%bcond_with tests
%endif

%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-jupyter_notebook-doc
Version:        5.4.0
Release:        0
Summary:        Documentation for python-jupyter_notebook
License:        BSD-3-Clause
Group:          Development/Languages/Python
Url:            https://github.com/jupyter/notebook
Source:         https://files.pythonhosted.org/packages/source/n/notebook/notebook-%{version}.tar.gz
BuildRequires:  %{python_module jupyter_notebook = %{version}}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
%if %{with tests}
# Test Requirements
BuildRequires:  %{python_module nose_warnings_filters}
BuildRequires:  %{python_module nose}
BuildRequires:  %{python_module requests}
# Python 2.7 test requirements
BuildRequires:  python-mock
%endif
# Documentation requirements
%if %{with pdf} || %{with html}
BuildRequires:  graphviz
BuildRequires:  graphviz-gnome
BuildRequires:  python3-Sphinx
BuildRequires:  python3-jupyter_nbsphinx
BuildRequires:  python3-matplotlib
BuildRequires:  python3-numpydoc
BuildRequires:  python3-requests
%endif
%if %{with pdf}
BuildRequires:  pandoc
BuildRequires:  python3-Sphinx-latex
%endif
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
Provides:       %{name}-html = %{version}
Provides:       %{name}-pdf = %{version}
Obsoletes:      %{name}-html < %{version}
Obsoletes:      %{name}-pdf < %{version}
Provides:       %{python_module jupyter_notebook-doc = %{version}}

%description
Documentation and help files for python-jupyter_notebook.

%prep
%setup -q -n notebook-%{version}

%build
# Build the documentation
pushd docs
%if %{with html}
make html
rm -rf build/html/.buildinfo
%endif
%if %{with pdf}
make latexpdf
%endif
popd

%install
mkdir -p %{buildroot}%{_docdir}/python-jupyter_notebook

%if %{with pdf}
cp docs/build/latex/jupyter_core.pdf %{buildroot}%{_docdir}/python-jupyter_notebook/
%endif

%if %{with html}
cp -r docs/build/html %{buildroot}%{_docdir}/python-jupyter_notebook/
%endif

cp -r docs/source/examples %{buildroot}%{_docdir}/python-jupyter_notebook/

%fdupes %{buildroot}%{_docdir}/python-jupyter_notebook/

%if %{with tests}
%check
export LANG=en_US.UTF-8
%python_expand nosetests-%{$python_bin_suffix}
%endif

%files
%defattr(-,root,root,-)
%doc COPYING.md
%{_docdir}/python-jupyter_notebook/

%changelog
openSUSE Build Service is sponsored by