File python-jupyter_notebook.spec of Package python-jupyter_notebook

#
# spec file for package python-jupyter_notebook
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-jupyter_notebook
Version:        5.2.2
Release:        0
Summary:        Jupyter Notebook
License:        BSD-3-Clause
Group:          Development/Languages/Python
Url:            http://jupyter.org
Source:         https://files.pythonhosted.org/packages/source/n/notebook/notebook-%{version}.tar.gz
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module jupyter_core}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  hicolor-icon-theme
BuildRequires:  python-rpm-macros
Requires:       python-Jinja2
Requires:       python-ipython_genutils
Requires:       python-jupyter_client
Requires:       python-jupyter_core
Requires:       python-jupyter_ipykernel
Requires:       python-jupyter_nbconvert
Requires:       python-jupyter_nbformat
Requires:       python-terminado >= 0.3.3
Requires:       python-tornado >= 4
Requires:       python-traitlets >= 4.2.1
Recommends:     python-jupyter_ipywidgets
Suggests:       %{name}-latex
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
%python_subpackages

%description
The Jupyter HTML notebook is a web-based notebook environment for interactive computing.

%package        latex
Summary:        LaTeX support for the Jupyter Notebook
Group:          Development/Languages/Python
Requires:       python-jupyter_nbconvert-latex

%description    latex
The Jupyter HTML notebook is a web-based notebook environment for interactive computing.

This package pulls in the LaTeX dependencies for the Jupyter Notebook.

%prep
%setup -q -n notebook-%{version}

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

# These directories are used for extensions
mkdir -p %{buildroot}%{_datadir}/jupyter/nbextensions
mkdir -p %{buildroot}%{_sysconfdir}/jupyter/nbextensions

# Install icons
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
cp docs/resources/icon_512x512.svg %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/JupyterNotebook.svg

for x in 16 24 32 48 64 128 256 512 ; do
    mkdir -p %{buildroot}%{_datadir}/icons/hicolor/${x}x${x}/apps/
    cp docs/resources/ipynb.iconset/icon_${x}x${x}.png %{buildroot}%{_datadir}/icons/hicolor/${x}x${x}/apps/JupyterNotebook.png
done

%post -n %{python3_prefix}-jupyter_notebook
%icon_theme_cache_post

%postun -n %{python3_prefix}-jupyter_notebook
%icon_theme_cache_postun

%files %{python_files}
%defattr(-,root,root,-)
%doc COPYING.md README.md
%python3_only %{_bindir}/jupyter-bundlerextension
%python3_only %{_bindir}/jupyter-nbextension
%python3_only %{_bindir}/jupyter-notebook
%python3_only %{_bindir}/jupyter-serverextension
%python3_only %{_datadir}/icons/hicolor/*/apps/JupyterNotebook.*
%dir %{_datadir}/jupyter/nbextensions
%dir %{_sysconfdir}/jupyter/nbextensions
%{python_sitelib}/*

%files %{python_files latex}
%defattr(-,root,root,-)
%doc COPYING.md README.md

%changelog
openSUSE Build Service is sponsored by