File python-distributed.spec of Package python-distributed

#
# spec file for package python-distributed
#
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
# Test requires network connection
%bcond_with     test
Name:           python-distributed
Version:        1.25.3
Release:        0
Summary:        Library for distributed computing with Python
License:        BSD-3-Clause
Group:          Development/Languages/Python
URL:            https://distributed.readthedocs.io/en/latest/
Source:         https://files.pythonhosted.org/packages/source/d/distributed/distributed-%{version}.tar.gz
Source99:       python-distributed-rpmlintrc
BuildRequires:  %{python_module joblib >= 0.10.2}
BuildRequires:  %{python_module scikit-learn >= 0.17.1}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
BuildRequires:  python2-futures
Requires:       python-PyYAML
Requires:       python-certifi
Requires:       python-click >= 6.6
Requires:       python-cloudpickle >= 0.2.2
Requires:       python-dask >= 0.18.0
Requires:       python-joblib >= 0.10.2
Requires:       python-msgpack
Requires:       python-psutil
Requires:       python-scikit-learn >= 0.17.1
Requires:       python-six
Requires:       python-sortedcontainers
Requires:       python-tblib
Requires:       python-toolz >= 0.7.4
Requires:       python-tornado >= 4.5.1
Requires:       python-zict >= 0.1.3
BuildArch:      noarch
%if %{with test}
BuildRequires:  %{python_module PyYAML}
BuildRequires:  %{python_module certifi}
BuildRequires:  %{python_module click >= 6.6}
BuildRequires:  %{python_module cloudpickle >= 0.2.2}
BuildRequires:  %{python_module dask >= 0.18.0}
BuildRequires:  %{python_module msgpack}
BuildRequires:  %{python_module psutil}
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module six}
BuildRequires:  %{python_module sortedcontainers}
BuildRequires:  %{python_module tblib}
BuildRequires:  %{python_module toolz >= 0.7.4}
BuildRequires:  %{python_module tornado >= 4.5.1}
BuildRequires:  %{python_module zict >= 0.1.3}
BuildRequires:  python2-mock
%endif
%ifpython2
Requires:       python-futures
Requires:       python-singledispatch
%endif
%python_subpackages

%description
Dask.distributed is a library for distributed computing in Python. It
extends both the concurrent.futures and dask APIs to moderate sized
clusters.

%prep
%setup -q -n distributed-%{version}

%build
%python_build

%install
%python_install
%{python_expand rm -rf %{buildroot}%{$python_sitelib}/distributed/tests/
# Deduplicating files can generate a RPMLINT warning for pyc mtime
%fdupes %{buildroot}%{$python_sitelib}
}

%if %{with test}
%check
%python_expand PYTHONPATH=%{buildroot}%{$python_sitelib} py.test-%{$python_bin_suffix} distributed/tests/
%endif

%files %{python_files}
%doc README.rst
%license LICENSE.txt
%python3_only %{_bindir}/dask-ssh
%python3_only %{_bindir}/dask-submit
%python3_only %{_bindir}/dask-remote
%python3_only %{_bindir}/dask-scheduler
%python3_only %{_bindir}/dask-worker
%python3_only %{_bindir}/dask-mpi
%{python_sitelib}/distributed*

%changelog
openSUSE Build Service is sponsored by