File python-nose_warnings_filters.spec of Package python-nose_warnings_filters

#
# spec file for package python-nose_warnings_filters
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%bcond_without test
Name:           python-nose_warnings_filters
Version:        0.1.5
Release:        0
Summary:        Allow to inject warning filters during nosetest
License:        MIT
Group:          Development/Languages/Python
Url:            https://github.com/Carreau/nose_warnings_filters
Source:         https://files.pythonhosted.org/packages/source/n/nose_warnings_filters/nose_warnings_filters-%{version}.tar.gz
Source1:        https://raw.githubusercontent.com/Carreau/nose_warnings_filters/0.1.1/LICENSE
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module nose}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
Requires:       python-nose
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch

%python_subpackages

%description
Put the same arguments as ``warnings.filterwarnings`` in ``setup.cfg``
at the root of your project. Separated each argument by pipes ``|``, one
filter per line. Whitespace are stripped.

If you prefer another name for the configuration file, you can tell nose
to load the configuration using the ``-c`` flag: run the tests with
``nosetests -c nose.cfg``.


%prep
%setup -q -n nose_warnings_filters-%{version}
cp %SOURCE1 .

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%if %{with test}
%check
%python_exec setup.py test
%endif

%files %{python_files}
%defattr(-,root,root,-)
%doc LICENSE
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by