File attr.spec of Package attr

#
# spec file for package attr
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           attr
%define lname	libattr1
Group:          System/Filesystems
AutoReqProv:    on
Summary:        Commands for Manipulating Extended Attributes
Version:        2.4.46
Release:        1
Source:         %{name}-%{version}.src.tar.gz
Source1:        xattr.conf
Source2:        baselibs.conf
Patch0:         builddefs.in.diff
Url:            http://download.savannah.gnu.org/releases-noredirect/attr/
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
License:        GPLv2+ ; LGPLv2.1+
Conflicts:      xfsdump < 2.0.0

%description
A set of tools for manipulating extended attributes on file system
objects, in particular getfattr(1) and setfattr(1). An attr(1) command
is also provided, which is largely compatible with the SGI IRIX tool of
the same name.

%package -n %lname
License:        GPLv2+ ; LGPLv2.1+
Summary:        A dynamic library for filesystem extended attribute support
AutoReqProv:    on
# bug437293
%ifarch ppc64
Obsoletes:      libattr-64bit
%endif
#
Group:          System/Libraries
Obsoletes:      libattr < %version-%release
Provides:       libattr = %version-%release

%description -n %lname
This package contains the libattr.so dynamic library, which contains
the extended attribute library functions.

%package -n libattr-devel
License:        GPLv2+ ; LGPLv2.1+
Summary:        Include Files and Libraries mandatory for Development
AutoReqProv:    on
Group:          Development/Libraries/C and C++
Provides:       attr-devel
Obsoletes:      attr-devel
# bug437293
%ifarch ppc64
Obsoletes:      libattr-devel-64bit
%endif
#
Requires:       %lname = %version, glibc-devel

%description -n libattr-devel
This package contains the libraries and header files needed to develop
programs which make use of extended attributes. For Linux programs, the
documented system call API is the recommended interface, but an SGI
IRIX compatibility interface is also provided.

%package -n libattr-devel-static
License:        GPLv2+ ; LGPLv2.1+
Summary:        Include Files and Libraries mandatory for Development
AutoReqProv:    on
Group:          Development/Libraries/C and C++
Provides:       libattr-devel:%{_libdir}/libattr.a
Requires:       libattr-devel = %version

%description -n libattr-devel-static
This package contains the static library of libattr which is needed to develop
statically linked programs which make use of extended attributes.

%prep
%setup -q
%patch0 -p1

%build
export OPTIMIZER="$RPM_OPT_FLAGS -fPIC"
export DEBUG=-DNDEBUG
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
%configure \
	--prefix=/ \
	--exec-prefix=/ \
	--sbindir=/bin \
	--libdir=/%{_lib} \
	--libexecdir=/%{_libdir} \
	--with-pic
%{__make} %{?_smp_mflags}

%install
DIST_ROOT="$RPM_BUILD_ROOT"
DIST_INSTALL=`pwd`/install.manifest
DIST_INSTALL_DEV=`pwd`/install-dev.manifest
DIST_INSTALL_LIB=`pwd`/install-lib.manifest
export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
/usr/bin/make install DIST_MANIFEST="$DIST_INSTALL"
/usr/bin/make install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
/usr/bin/make install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
ln -sf /%{_lib}/$(readlink $RPM_BUILD_ROOT/%{_lib}/libattr.so) \
	$RPM_BUILD_ROOT/%{_libdir}/libattr.so
rm -f $RPM_BUILD_ROOT/%{_lib}/libattr.{a,la,so}
rm -f $RPM_BUILD_ROOT%{_mandir}/man2/*xattr.2*
rm -f $RPM_BUILD_ROOT/%{_libdir}/libattr.la
install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}
install -m 644 %_sourcedir/xattr.conf $RPM_BUILD_ROOT/%{_sysconfdir}
chmod 755 $RPM_BUILD_ROOT/%{_lib}/libattr.so.1*
%find_lang %name

%post -n %lname -p /sbin/ldconfig

%postun -n %lname -p /sbin/ldconfig

%files -f %{name}.lang
%defattr (-,root,root)
%dir %attr(755,root,root) /usr/share/doc/packages/attr
%doc %attr(644,root,root) /usr/share/doc/packages/attr/README
%doc %attr(644,root,root) /usr/share/doc/packages/attr/CHANGES.gz
%doc %attr(644,root,root) /usr/share/doc/packages/attr/COPYING
%doc %attr(644,root,root) /usr/share/doc/packages/attr/PORTING
%doc %attr(644,root,root) %{_mandir}/man1/attr.1.gz
%doc %attr(644,root,root) %{_mandir}/man1/getfattr.1.gz
%doc %attr(644,root,root) %{_mandir}/man1/setfattr.1.gz
%doc %attr(644,root,root) %{_mandir}/man5/attr.5.gz
%attr(755,root,root) %{_bindir}/attr
%attr(755,root,root) %{_bindir}/getfattr
%attr(755,root,root) %{_bindir}/setfattr

%files -n libattr-devel
%defattr(-,root,root)
%dir %attr(755,root,root) %{_includedir}/attr
%attr(644,root,root) %{_includedir}/attr/attributes.h
%attr(644,root,root) %{_includedir}/attr/error_context.h
%attr(644,root,root) %{_includedir}/attr/libattr.h
%attr(644,root,root) %{_includedir}/attr/xattr.h
%attr(755,root,root) %{_libdir}/libattr.so
%doc %attr(644,root,root) %{_mandir}/man3/attr_get.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_list.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_multi.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_remove.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_set.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_getf.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_listf.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_multif.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_removef.3.gz*
%doc %attr(644,root,root) %{_mandir}/man3/attr_setf.3.gz*

%files -n libattr-devel-static
%defattr(-,root,root)
%{_libdir}/libattr.a

%files -n %lname
%defattr (-,root,root)
/%{_lib}/libattr.so.1*
%config %{_sysconfdir}/xattr.conf

%changelog
openSUSE Build Service is sponsored by