File libinfinity.spec of Package libinfinity

#
# spec file for package libinfinity (Version 0.3.0)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           libinfinity
BuildRequires:  fdupes
BuildRequires:  gettext-devel
BuildRequires:  glib2-devel
BuildRequires:  gnutls-devel
BuildRequires:  gtk-doc
BuildRequires:  gtk2-devel
BuildRequires:  libavahi-devel
BuildRequires:  libgsasl-devel
BuildRequires:  libxml2-devel
License:        LGPL v2.1 or later
Group:          Development/Libraries/GNOME
Version:        0.3.0
Release:        2
%define _version 0.3
Summary:        Implementation of the Infinote collaborative editing protocol
Source0:        %{name}-%{version}.tar.bz2
Source1:        infinoted.init
Source2:        infinoted.sysconfig
Source3:        infinoted.conf
Patch0:         infinoted-add-conf-subdir.patch
Url:            http://gobby.0x539.de/
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       %{name}-lang = %{version}

%description
libinfinity is an implementation of the Infinote protocol written in
GObject-based C. Infinote is a protocol for collaborative editing
multiple documents and is portable to both Windows and Unix-like
platforms.



Authors:
--------
    Armin Burgmeier <armin@arbur.net>

%package -n libinfinity-1_0-0
License:        LGPL v2.1 or later
Summary:        Implementation of the Infinote collaborative editing protocol
Group:          Development/Libraries/GNOME

%description -n libinfinity-1_0-0
libinfinity is an implementation of the Infinote protocol written in
GObject-based C. Infinote is a protocol for collaborative editing
multiple documents and is portable to both Windows and Unix-like
platforms.



Authors:
--------
    Armin Burgmeier <armin@arbur.net>

%package devel
License:        LGPL v2.1 or later
Summary:        Implementation of the Infinote collaborative editing protocol
Group:          Development/Libraries/GNOME
Requires:       libinfinity-1_0-0 = %{version}
Requires:       glib2-devel
Requires:       gtk2-devel
Requires:       libgnutls-devel
Requires:       libgsasl-devel
Requires:       libxml2-devel

%description devel
libinfinity is an implementation of the Infinote protocol written in
GObject-based C. Infinote is a protocol for collaborative editing
multiple documents and is portable to both Windows and Unix-like
platforms.



Authors:
--------
    Armin Burgmeier <armin@arbur.net>

%package -n infinoted
License:        LGPL v2.1 or later
Summary:        Server for Collaborative Document Edition
Group:          Development/Libraries/GNOME
Requires:       libinfinity-1_0-0 = %{version}

%description -n infinoted
Infinoted is a server for collaborative edition of documents via the
Infinote protocol. It is typically used with Gobby as a client.



Authors:
--------
    Armin Burgmeier <armin@arbur.net>

%lang_package
%prep
%setup -q
%patch -p1

%build
# -fno-strict-aliasing added 2009-05-07. Need for 0.3.0 -- vuntz
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
%configure --disable-static --with-pic
make %{?jobs:-j%jobs}

%install
%makeinstall
%find_lang %{name}-%{_version}
find %{buildroot} -type f -name "*.la" -exec %{__rm} -fv {} +
# Create init.d files
install -D -m 0755 %{S:1} %{buildroot}%{_sysconfdir}/init.d/infinoted
install -d -m 0755 %{buildroot}%{_sbindir}
ln -s %{_sysconfdir}/init.d/infinoted %{buildroot}%{_sbindir}/rcinfinoted
# Create sysconfig data
install -D -m 0644 %{S:2} %{buildroot}/var/adm/fillup-templates/sysconfig.infinoted  
install -d -m 0755 %{buildroot}/srv/infinoted
# Create infinoted default configuration
install -d -m 0755 %{buildroot}%{_sysconfdir}/xdg/infinoted
install -D -m 0644 %{S:3} %{buildroot}%{_sysconfdir}/xdg/infinoted/infinoted.conf
# Note: the infinoted binary is versioned, and we could use update-alternatives
# to provide it also non-versioned. However, the init.d, sysconfig and xdg
# config files are not versioned, and it will actually be bad for the user to
# have them versioned (potential loss of configuration, for example). So let's
# just unversion the binary.
mv %{buildroot}%{_bindir}/infinoted-%{_version} %{buildroot}%{_bindir}/infinoted
%fdupes $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%post -n libinfinity-1_0-0 -p /sbin/ldconfig

%post -n infinoted
%{fillup_only -n infinoted}

%preun -n infinoted
%stop_on_removal infinoted

%postun -n libinfinity-1_0-0 -p /sbin/ldconfig

%postun -n infinoted
%restart_on_update infinoted
%insserv_cleanup

%files -n libinfinity-1_0-0
%defattr (-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README TODO
%{_libdir}/libinf*.so.*
# Only needed for the test applications, it seems
%exclude %{_datadir}/icons/hicolor/*/apps/infinote.*

%files devel
%defattr (-, root, root)
%{_includedir}/libinf*
%{_libdir}/libinf*.so
%{_libdir}/pkgconfig/libinf*.pc
%{_datadir}/gtk-doc/html/*

%files -n infinoted
%defattr (-, root, root)
%{_bindir}/infinoted
%{_libdir}/infinoted-%{_version}
# default configuration
%dir %{_sysconfdir}/xdg/infinoted
%config(noreplace) %{_sysconfdir}/xdg/infinoted/infinoted.conf
# init.d files
%{_sysconfdir}/init.d/infinoted
%{_sbindir}/rcinfinoted
# sysconfig data
%{_localstatedir}/adm/fillup-templates/sysconfig.infinoted
%dir /srv/infinoted

%files lang -f %{name}-%{_version}.lang

%changelog
* Thu May 07 2009 vuntz@novell.com
- Review packages.
- Remove unneeded BuildRequires: gcc-c++, libsigc++2-devel,
  pkg-config, gmp-devel, cairo-devel, libxml++-devel,
  libuuid-devel.
- Remove AutoReqProv: it's default now.
- Update the Requires of the devel package.
- Merge doc package with devel package.
- Build with -fno-strict-aliasing: there's a warning requiring it.
- Do not keep the versioned binary.
- Do not ship the icons: they don't appear to be needed.
* Thu Apr 30 2009 opensuse@sukimashita.com
- Update to 0.3.0:
  * infinoted: Added the --certificate-chain command line option.
  * Support rejecting a subscription on the client side, for example
  when the client does not support the communication method.
  * Made libinfinity parallel-installable with future versions.
* Sat Jan 10 2009 opensuse@sukimashita.com
- Update to 0.2.0:
  * infinoted records sessions to ~/.infinoted-records
  * Added proper modification tracking, and an autosave feature for
  infinoted.
  * Implemented InfStandaloneIo on Windows, making infinoted run on
  Windows
  * Refactored connection manager, introducing InfCommunication API for
  high-level network handling. This breaks protocol compatibility with
  libinfinity 0.1.x.
- Since 0.1.2:
  * Fixed required dependencies in pkg-config files
  * Improved error message when the remote host does not send XMPP
  * Fixed a crash when compiling with -O2 or above
  * Fixed a few memory leaks
  * Fixed build with cairo 1.4 (#393)
* Thu Dec 04 2008 opensuse@sukimashita.com
- Update to git version 20081204
  * Implemented auto-saver feature for infinoted
  * Install conf file to /etc/xdg to correctly recognize global configuration
* Sun Nov 09 2008 opensuse@sukimashita.com
- Update to 0.1.1:
  * Made libinfinity properly relocatable on Windows
  * Fixed the documentation build when avahi is disabled
  * Fixed a segfault when showing the file list
  * Fixed pasting a lot amount of text
  * Fixed connection to server with much history
* Thu Oct 23 2008 opensuse@sukimashita.com
- Initial package created
openSUSE Build Service is sponsored by