File kemoticons.spec of Package kemoticons
#
# spec file for package kemoticons
#
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define lname libKF5Emoticons5
%define _tar_path 5.55
# Full KF5 version (e.g. 5.33.0)
%{!?_kf5_version: %global _kf5_version %{version}}
# Last major and minor KF5 version (e.g. 5.33)
%{!?_kf5_bugfix_version: %define _kf5_bugfix_version %(echo %{_kf5_version} | awk -F. '{print $1"."$2}')}
Name: kemoticons
Version: 5.55.0
Release: 0
Summary: Emoticon to graphical emoticon text converter
License: LGPL-2.1-or-later
Group: System/GUI/KDE
URL: https://www.kde.org
Source: http://download.kde.org/stable/frameworks/%{_tar_path}/%{name}-%{version}.tar.xz
Source1: baselibs.conf
BuildRequires: cmake >= 3.0
BuildRequires: extra-cmake-modules >= %{_kf5_bugfix_version}
BuildRequires: fdupes
BuildRequires: karchive-devel >= %{_kf5_bugfix_version}
BuildRequires: kconfig-devel >= %{_kf5_bugfix_version}
BuildRequires: kf5-filesystem
BuildRequires: kservice-devel >= %{_kf5_bugfix_version}
BuildRequires: cmake(Qt5DBus) >= 5.6.0
BuildRequires: cmake(Qt5Gui) >= 5.6.0
BuildRequires: cmake(Qt5Test) >= 5.6.0
BuildRequires: cmake(Qt5Widgets) >= 5.6.0
%description
KEmoticons converts emoticons from text to a graphical representation with
images in HTML. It supports setting different themes for emoticons coming
from different providers.
%package -n %{lname}
Summary: Emoticon to graphical emoticon text converter
Group: System/GUI/KDE
Obsoletes: libKF5Emoticons4
%description -n %{lname}
KEmoticons converts emoticons from text to a graphical representation with
images in HTML. It supports setting different themes for emoticons coming
from different providers.
%package devel
Summary: Build environment for kemoticons, an emoticon text converter
Group: Development/Libraries/KDE
Requires: %{lname} = %{version}
Requires: extra-cmake-modules
Requires: karchive-devel >= %{_kf5_bugfix_version}
Requires: kservice-devel >= %{_kf5_bugfix_version}
Requires: cmake(Qt5Gui) >= 5.6.0
%description devel
KEmoticons converts emoticons from text to a graphical representation with
images in HTML. It supports setting different themes for emoticons coming
from different providers. Development files.
%prep
%setup -q
%if 0%{?suse_version} == 1500
sed -i -e "s/^set *(REQUIRED_QT_VERSION 5.10.0)$/set(REQUIRED_QT_VERSION 5.9.0)/" CMakeLists.txt
%endif
%build
%cmake_kf5 -d build
%make_jobs
%install
%kf5_makeinstall -C build
%fdupes %{buildroot}
%post -n %{lname} -p /sbin/ldconfig
%postun -n %{lname} -p /sbin/ldconfig
%files -n %{lname}
%license COPYING*
%doc README*
%{_kf5_libdir}/libKF5Emoticons.so.*
%{_kf5_plugindir}/
%{_kf5_servicesdir}/
%{_kf5_servicetypesdir}/
%{_kf5_sharedir}/emoticons/
%{_kf5_debugdir}/kemoticons.categories
%files devel
%{_kf5_libdir}/libKF5Emoticons.so
%{_kf5_libdir}/cmake/KF5Emoticons/
%{_kf5_includedir}/*.h
%dir %{_kf5_includedir}/*/
%{_kf5_includedir}/*/
%{_kf5_mkspecsdir}/qt_KEmoticons.pri
%changelog