File python-heatclient.spec of Package python-heatclient

#
# spec file for package python-heatclient
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python-heatclient
Version:        1.14.0
Release:        0
Summary:        Python API and CLI for OpenStack Heat
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://launchpad.net/python-heatclient
Source0:        https://files.pythonhosted.org/packages/source/p/python-heatclient/python-heatclient-1.14.0.tar.gz
BuildRequires:  openstack-macros
BuildRequires:  python-devel
BuildRequires:  python2-PyYAML >= 3.10
BuildRequires:  python2-cliff >= 2.8.0
BuildRequires:  python2-fixtures >= 3.0.0
BuildRequires:  python2-mock >= 2.0.0
BuildRequires:  python2-mox3 >= 0.20.0
BuildRequires:  python2-osc-lib >= 1.8.0
BuildRequires:  python2-oslo.serialization >= 2.18.0
BuildRequires:  python2-pbr >= 2.0.0
BuildRequires:  python2-requests-mock >= 1.1.0
BuildRequires:  python2-swiftclient >= 3.2.0
BuildRequires:  python2-testrepository >= 0.0.18
BuildRequires:  python2-testscenarios >= 0.4
BuildRequires:  python2-testtools >= 2.2.0
BuildRequires:  python3-PyYAML >= 3.10
BuildRequires:  python3-cliff >= 2.8.0
BuildRequires:  python3-devel
BuildRequires:  python3-fixtures >= 3.0.0
BuildRequires:  python3-mock >= 2.0.0
BuildRequires:  python3-mox3 >= 0.20.0
BuildRequires:  python3-osc-lib >= 1.8.0
BuildRequires:  python3-oslo.serialization >= 2.18.0
BuildRequires:  python3-pbr >= 2.0.0
BuildRequires:  python3-requests-mock >= 1.1.0
BuildRequires:  python3-swiftclient >= 3.2.0
BuildRequires:  python3-testrepository >= 0.0.18
BuildRequires:  python3-testscenarios >= 0.4
BuildRequires:  python3-testtools >= 2.2.0
Requires:       python-Babel >= 2.3.4
Requires:       python-PrettyTable >= 0.7.1
Requires:       python-PyYAML >= 3.10
Requires:       python-cliff >= 2.8.0
Requires:       python-iso8601 >= 0.1.11
Requires:       python-keystoneauth1 >= 3.3.0
Requires:       python-osc-lib >= 1.8.0
Requires:       python-oslo.i18n >= 3.15.3
Requires:       python-oslo.serialization >= 2.18.0
Requires:       python-oslo.utils >= 3.33.0
Requires:       python-requests >= 2.14.2
Requires:       python-six >= 1.10.0
Requires:       python-swiftclient >= 3.2.0
BuildArch:      noarch
%if 0%{?suse_version}
Requires(post): update-alternatives
Requires(postun): update-alternatives
%else
# on RDO, update-alternatives is in chkconfig
Requires(post): chkconfig
Requires(postun): chkconfig
%endif
%python_subpackages

%description
This is a client for the OpenStack Heat API. There's a Python API (the
heatclient module), and a command-line script (heat). Each implements 100% of
the OpenStack Heat API.

%package -n python-heatclient-doc
Summary:        Documentation for OpenStack Heat API Client
Group:          Documentation/HTML
BuildRequires:  python-Sphinx
BuildRequires:  python-openstackdocstheme >= 1.18.1

%description -n python-heatclient-doc
This is a client for the OpenStack Heat API. There's a Python API (the
heatclient module), and a command-line script (heat). Each implements 100% of
the OpenStack Heat API.
This package contains auto-generated documentation.

%prep
%autosetup -p1 -n python-heatclient-1.14.0
%py_req_cleanup
sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg

%build
%{python_build}

%{__python2} setup.py build_sphinx --builder=html,man
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}

%install
%{python_install}
# man page
install -p -D -m 644 doc/build/man/heat.1 %{buildroot}%{_mandir}/man1/heat.1
# bash completion
install -p -D -m 644 tools/heat.bash_completion %{buildroot}%{_sysconfdir}/bash_completion.d/heat.bash_completion
%python_clone -a %{buildroot}%{_bindir}/heat
%python_clone -a %{buildroot}%{_mandir}/man1/heat.1
%python_clone -a %{buildroot}%{_sysconfdir}/bash_completion.d/heat.bash_completion

%post
%{python_install_alternative heat heat.1 %{_sysconfdir}/bash_completion.d/heat.bash_completion}

%postun
%python_uninstall_alternative heat

%check
%{python_expand rm -rf .testrepository
$python setup.py testr
}

%files %{python_files}
%license LICENSE
%{python_sitelib}/heatclient
%{python_sitelib}/*.egg-info
%python_alternative %{_bindir}/heat
%python_alternative %{_mandir}/man1/heat.1
%python_alternative %{_sysconfdir}/bash_completion.d/heat.bash_completion

%files -n python-heatclient-doc
%license LICENSE
%doc doc/build/html README.rst

%changelog
openSUSE Build Service is sponsored by