File ghc-bootstrap.spec of Package ghc-bootstrap

#
# spec file for package ghc-bootstrap
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%ifarch %{ix86}
%define longarch i386
%define os_release -centos65
%endif
%ifarch ppc
%define longarch powerpc
%endif
%ifarch ppc64
%define longarch powerpc64
%endif
%ifarch ppc64le
%define longarch powerpc64le
%endif
%ifarch s390
%define longarch s390
%endif
%ifarch s390x
%define longarch s390x
%endif
%ifarch aarch64
%define longarch aarch64
%endif
%ifarch x86_64
%define longarch x86_64
%define os_release -centos65
%endif
%ifarch aarch64 s390 s390x
%define xversion 7.8.4
%else
%define xversion 7.8.3
%endif
%ifarch s390 s390x
%define sysname ibm
%else
%define sysname unknown
%endif

%global without_hscolour 1

%global debug_package %{nil}

Name:           ghc-bootstrap
Version:        7.8.3
Release:        0
Url:            https://build.opensuse.org/package/view_file/devel:languages:haskell:bootstrap
Summary:        Binary distributions of The Glorious Glasgow Haskell Compiler
License:        BSD-3-Clause
Group:          Development/Languages/Other
Source:         %{name}-%{version}.tar
Source1:        README.openSUSE
Source2:        LICENSE
Source10:       ghc-7.8.3-i386-unknown-linux-centos65.tar.bz2
Source11:       ghc-7.8.3-powerpc-unknown-linux.tar.bz2
Source12:       ghc-7.8.3-powerpc64-unknown-linux.tar.bz2
Source13:       ghc-7.8.3-powerpc64le-unknown-linux.tar.bz2
Source14:       ghc-7.8.3-x86_64-unknown-linux-centos65.tar.bz2
Source15:       ghc-7.8.4-s390-ibm-linux.tar.bz2
Source16:       ghc-7.8.4-s390x-ibm-linux.tar.bz2
Source17:       ghc-7.8.4-aarch64-unknown-linux.tar.bz2
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  fdupes
BuildRequires:  gmp-devel
BuildRequires:  libncurses5
Requires:       libncurses5
Requires:       gmp-devel

ExclusiveArch:  %{ix86} ppc ppc64 ppc64le x86_64 s390 s390x aarch64
Provides:       ghc-bootstrap-devel

Conflicts:      ghc
Conflicts:      ghc-compiler
Conflicts:      ghc-Cabal-devel
Conflicts:      ghc-array-devel
Conflicts:      ghc-base-devel
Conflicts:      ghc-binary-devel
Conflicts:      ghc-bytestring-devel
Conflicts:      ghc-containers-devel
Conflicts:      ghc-deepseq-devel
Conflicts:      ghc-directory-devel
Conflicts:      ghc-filepath-devel
Conflicts:      ghc-ghc-devel
Conflicts:      ghc-haskeline-devel
Conflicts:      ghc-haskell2010-devel
Conflicts:      ghc-haskell98-devel
Conflicts:      ghc-hoopl-devel
Conflicts:      ghc-hpc-devel
Conflicts:      ghc-old-locale-devel
Conflicts:      ghc-old-time-devel
Conflicts:      ghc-pretty-devel
Conflicts:      ghc-process-devel
Conflicts:      ghc-template-haskell-devel
Conflicts:      ghc-terminfo-devel
Conflicts:      ghc-time-devel
Conflicts:      ghc-transformers-devel
Conflicts:      ghc-unix-devel
Conflicts:      ghc-xhtml-devel

AutoReq:        off

%description
This package contains a binary distribution of "The Glorious Glasgow
Haskell Compilation System". See README.openSUSE on how the tarballs
were produced.

Do not install this package! Install 'ghc' or 'haskell-platform' instead. 

Haskell is the standard purely functional programming language; the
current language version is Haskell 98, agreed in December 1998.

GHC is a state-of-the-art programming suite for Haskell.  Included is
an optimising compiler generating good code for a variety of
platforms, together with an interactive system for convenient, quick
development.  The distribution includes space and time profiling
facilities, a large collection of libraries, and support for various
language extensions, including concurrency, exceptions, and foreign
language interfaces (C, C++, etc).

A wide variety of Haskell related resources (tutorials, libraries,
specifications, documentation, compilers, interpreters, references,
contact information, links to research groups) are available from the
Haskell home page at <http://www.haskell.org/>.


%prep
%setup -q
cp %SOURCE1 .
cp %SOURCE2 .
cp %SOURCE10 .
cp %SOURCE11 .
cp %SOURCE12 .
cp %SOURCE13 .
cp %SOURCE14 .
cp %SOURCE15 .
cp %SOURCE16 .
cp %SOURCE17 .

%build
%if 0%{suse_version} > 1130
ln -s %{_libdir}/libgmp.so.10 libgmp.so.3
export LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
%endif
tar jxf ghc-%{xversion}-%{longarch}-%{sysname}-linux%{?os_release}.tar.bz2
cd ghc-%{xversion}
./configure --prefix=%{_prefix}

%install
%if 0%{suse_version} > 1130
export LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
%endif
cd ghc-%{xversion}
%makeinstall
%if 0%{suse_version} > 1130
install -dm 0755 %{buildroot}%{_libdir}
ln -s %{_libdir}/libgmp.so.10 %{buildroot}%{_libdir}/libgmp.so.3
%endif
%fdupes -s %{buildroot}

%post
ghc-pkg recache

%files
%defattr(-,root,root,-)
%doc README.openSUSE
%doc LICENSE
%{_bindir}/*
%{_prefix}/lib/ghc-%{xversion}
%{_datadir}/doc/*
%if 0%{suse_version} > 1130
%{_libdir}/libgmp.so.3
%endif
# for some reason there is no manpage for ghc in the x86_64 tarball
%ifarch %{ix86}
%{_mandir}/man1/ghc.1*
%endif

%changelog
openSUSE Build Service is sponsored by