File python-cinderclient.spec of Package python-cinderclient
#
# spec file for package python-cinderclient
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-cinderclient
Version: 3.5.0
Release: 0
Summary: Python API and CLI for OpenStack Cinder
License: Apache-2.0
Group: Development/Languages/Python
Url: https://launchpad.net/python-cinderclient
Source0: https://files.pythonhosted.org/packages/source/p/python-cinderclient/python-cinderclient-3.5.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python-devel
BuildRequires: python2-PrettyTable >= 0.7.1
BuildRequires: python2-ddt >= 1.0.1
BuildRequires: python2-fixtures >= 3.0.0
BuildRequires: python2-keystoneauth1 >= 3.3.0
BuildRequires: python2-mock >= 2.0.0
BuildRequires: python2-os-testr >= 1.0.0
BuildRequires: python2-oslo.serialization >= 2.18.0
BuildRequires: python2-oslo.utils >= 3.33.0
BuildRequires: python2-pbr >= 2.0.0
BuildRequires: python2-python-subunit >= 1.0.0
BuildRequires: python2-requests >= 2.14.2
BuildRequires: python2-requests-mock >= 1.1.0
BuildRequires: python2-testrepository >= 0.0.18
BuildRequires: python2-testscenarios >= 0.4
BuildRequires: python2-testtools >= 2.2.0
BuildRequires: python3-PrettyTable >= 0.7.1
BuildRequires: python3-ddt >= 1.0.1
BuildRequires: python3-devel
BuildRequires: python3-fixtures >= 3.0.0
BuildRequires: python3-keystoneauth1 >= 3.3.0
BuildRequires: python3-mock >= 2.0.0
BuildRequires: python3-os-testr >= 1.0.0
BuildRequires: python3-oslo.serialization >= 2.18.0
BuildRequires: python3-oslo.utils >= 3.33.0
BuildRequires: python3-pbr >= 2.0.0
BuildRequires: python3-python-subunit >= 1.0.0
BuildRequires: python3-requests >= 2.14.2
BuildRequires: python3-requests-mock >= 1.1.0
BuildRequires: python3-testrepository >= 0.0.18
BuildRequires: python3-testscenarios >= 0.4
BuildRequires: python3-testtools >= 2.2.0
Requires: python-Babel >= 2.3.4
Requires: python-PrettyTable >= 0.7.1
Requires: python-keystoneauth1 >= 3.3.0
Requires: python-oslo.i18n >= 3.15.3
Requires: python-oslo.utils >= 3.33.0
Requires: python-requests >= 2.14.2
Requires: python-simplejson >= 3.5.1
Requires: python-six >= 1.10.0
BuildArch: noarch
%if 0%{?suse_version}
Requires(post): update-alternatives
Requires(postun): update-alternatives
%else
# on RDO, update-alternatives is in chkconfig
Requires(post): chkconfig
Requires(postun): chkconfig
%endif
%python_subpackages
%description
This is a client for the OpenStack Cinder API (Block Storage. There's a
Python API (the cinderclient module), and a command-line script (cinder).
Each implements 100% of the OpenStack Cinder API.
%package -n python-cinderclient-doc
Summary: Documentation for OpenStack Cinder API Client
Group: Documentation/HTML
BuildRequires: python-Sphinx
BuildRequires: python-openstackdocstheme >= 1.18.1
BuildRequires: python-reno >= 2.5.0
%description -n python-cinderclient-doc
This is a client for the OpenStack Cinder API (Block Storage. There's a
Python API (the cinderclient module), and a command-line script (cinder).
Each implements 100% of the OpenStack Cinder API.
This package contains auto-generated documentation.
%prep
%autosetup -p1 -n python-cinderclient-3.5.0
%py_req_cleanup
sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
%build
%{python_build}
%{__python2} setup.py build_sphinx --builder=html,man
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{python_install}
# man page
install -p -D -m 644 doc/build/man/cinder.1 %{buildroot}%{_mandir}/man1/cinder.1
# bash completion
install -p -D -m 644 tools/cinder.bash_completion %{buildroot}%{_sysconfdir}/bash_completion.d/cinder.bash_completion
%python_clone -a %{buildroot}%{_bindir}/cinder
%python_clone -a %{buildroot}%{_mandir}/man1/cinder.1
%python_clone -a %{buildroot}%{_sysconfdir}/bash_completion.d/cinder.bash_completion
%post
%{python_install_alternative cinder cinder.1 %{_sysconfdir}/bash_completion.d/cinder.bash_completion}
%postun
%python_uninstall_alternative cinder
%check
rm cinderclient/tests/unit/test_shell.py
%{python_expand rm -rf .testrepository
ostestr
}
%files %{python_files}
%license LICENSE
%doc README.rst ChangeLog
%{python_sitelib}/cinderclient
%{python_sitelib}/*.egg-info
%python_alternative %{_bindir}/cinder
%python_alternative %{_mandir}/man1/cinder.1
%python_alternative %{_sysconfdir}/bash_completion.d/cinder.bash_completion
%files -n python-cinderclient-doc
%license LICENSE
%doc doc/build/html
%changelog