File python-requests.spec of Package python-requests

#
# spec file for package python-requests
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-requests
Version:        2.18.2
Release:        0
Summary:        Awesome Python HTTP Library That's Actually Usable
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            http://python-requests.org/
Source:         https://files.pythonhosted.org/packages/source/r/requests/requests-%{version}.tar.gz
BuildRequires:  %{python_module certifi}
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module py}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module urllib3 >= 1.21.1}
BuildRequires:  ca-certificates
BuildRequires:  python
BuildRequires:  python-rpm-macros
# SECTION test requirements
BuildRequires:  %{python_module PySocks >= 1.5.6}
BuildRequires:  %{python_module chardet >= 3.0.2}
BuildRequires:  %{python_module idna >= 2.5}
BuildRequires:  %{python_module pytest-httpbin}
BuildRequires:  %{python_module pytest-mock}
BuildRequires:  %{python_module pytest}
# /SECTION
Requires:       ca-certificates
Requires:       python
# for good measure, at least recommend an actual set of certificates
Recommends:     ca-certificates-mozilla
Recommends:     python-pyOpenSSL >= 0.14
Recommends:     python-cryptography >= 1.3.4
Recommends:     python-PySocks >= 1.5.6
Requires:       python-certifi >= 2017.4.17
Requires:       python-chardet >= 3.0.2
Requires:       python-idna >= 2.5
Requires:       python-py
Requires:       python-urllib3 >= 1.21.1
BuildArch:      noarch

%python_subpackages

%description
Requests is an HTTP library, written in Python, as an alternative
to Python's builtin urllib2 which requires a work (even
method overrides) to perform basic tasks.

Features of Requests:
 - GET, HEAD, POST, PUT, DELETE Requests:
   + HTTP Header Request Attachment.
   + Data/Params Request Attachment.
   + Multipart File Uploads.
   + CookieJar Support.
   + Redirection History.
   + Redirection Recursion Urllib Fix.
   + Automatic Decompression of GZipped Content.
   + Unicode URL Support.
 - Authentication:
   + URL + HTTP Auth Registry.

%prep
%setup -q -n requests-%{version}

# drop shebang from certs.py
sed -i '1s/^#!.*$//' requests/certs.py

%build
%python_build

%install
%python_install
# check that urllib3 is not installed
test ! -e %{buildroot}%{python3_sitelib}/requests/packages/urllib3

%check
touch requirements.txt
# exclude tests connecting to TARPIT
%python_exec -m pytest tests -k "not (TestTimeout and connect)"

%files %{python_files}
%defattr(-,root,root)
%doc HISTORY.rst LICENSE README.rst
%{python_sitelib}/requests/
%{python_sitelib}/requests-*

%changelog
openSUSE Build Service is sponsored by