File xterm.spec of Package xterm

#
# spec file for package xterm
#
# Copyright (c) 2016 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define vttest_version 20140305
%define splitbin 0%{?suse_version} >= 1300
Name:           xterm
Version:        327
Release:        0
Summary:        The basic X terminal program
License:        MIT
Group:          System/X11/Utilities
Url:            http://invisible-island.net/xterm/
Source:         ftp://invisible-island.net/xterm/%{name}-%{version}.tgz
Source1:        ftp://invisible-island.net/xterm/%{name}-%{version}.tgz.asc
Source2:        luitx
Source3:        Backarrow2Delete
Source4:        Backarrow2BackSpace
Source5:        README.SUSE
Source6:        terminal.png
Source8:        20x20ja.bdf.bz2
Source9:        20x20ko.bdf.bz2
Source11:       xterm.keyring
# Snoop for the escape sequence assignment of the keypad
Source20:       snooper.tar.bz2
Source100:      ftp://invisible-island.net/vttest/vttest-%{vttest_version}.tgz
Source101:      ftp://invisible-island.net/vttest/vttest-%{vttest_version}.tgz.asc
Patch1:         xterm-settings.patch
Patch2:         xterm-sigwinch.patch
Patch3:         xterm-double_width_fonts.patch
Patch4:         xterm-desktop_file_icon.patch
Patch5:         xterm-forbid_window_and_font_ops.patch
Patch6:         xterm-enable_libtinfo.patch
Patch7:         xterm-allow_iso-utf_fonts_in_menu.patch
Patch8:         xterm-decomposed_bitmaps.patch
Patch9:         xterm-desktop-item-in-gnome-utilities-appfolder.patch
BuildRequires:  freetype2-devel
BuildRequires:  ncurses-devel
BuildRequires:  update-desktop-files
%if %{splitbin}
Requires:       %{name}-bin
%endif
Provides:       XFree86:%{_prefix}/X11R6/bin/xterm
Provides:       xorg-x11:%{_prefix}/X11R6/bin/xterm
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  groff
BuildRequires:  pkgconfig
%if 0%{?suse_version} > 1220
BuildRequires:  fontpackages-devel
%endif
%if 0%{?suse_version} > 1130
BuildRequires:  utempter-devel
%else
BuildRequires:  utempter
%endif
%if 0%{?suse_version} > 1210
# separate package now
BuildRequires:  bdftopcf
# post xorg libs split
BuildRequires:  libX11-devel
BuildRequires:  libXaw-devel
BuildRequires:  libXft-devel
BuildRequires:  libXrender-devel
%else
# case for SLE10 and SLE 11
BuildRequires:  xorg-x11
BuildRequires:  xorg-x11-devel
%endif
# post xorg apps split
%if 0%{?suse_version} > 1210
Requires:       luit
%endif
%if 0%{?suse_version} > 1220
%{reconfigure_fonts_prereq}
%endif

%description
%if %{splitbin}
This package contains the basic X.Org terminal program desktop launcher.

%package bin
Summary:        The basic X terminal program
Group:          System/X11/Utilities

%description bin
%endif
This package contains the basic X.Org terminal program.

%prep
%setup -q -b100
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
cp -t . %{SOURCE8} %{SOURCE9}
bunzip2 %{basename:%{SOURCE8}} %{basename:%{SOURCE9}}
cd ../vttest-%{vttest_version}

%build
# suse 10.x uses older X11 directory structure
%if 0%{?suse_version} < 1100
%define xappdefs   %{_prefix}/X11R6/lib/X11/app-defaults
%define xfontsd    %{_prefix}/X11R6/lib/X11/fonts
%define xterminfo  %{_prefix}/X11R6/lib/X11/etc
%else
%define xappdefs   %{_datadir}/X11/app-defaults
%define xfontsd    %{_datadir}/fonts
%define xterminfo  %{_libexecdir}/X11/etc
%endif

%configure \
    --enable-256-color \
    --enable-dec-locator \
    --enable-hp-fkeys \
    --enable-luit \
    --enable-mini-luit \
    --enable-sco-fkeys \
    --enable-wide-chars \
    --with-utempter \
    --with-tty-group=tty \
    --with-app-defaults=%{xappdefs} \
%if 0%{?suse_version} < 1000
    --x-includes=%{_prefix}/X11R6/include \
    --x-libraries=%{_prefix}/X11R6/%{_lib} \
%endif
    --enable-backarrow-is-erase \
    --enable-sixel-graphics \

#ensure we do not lose FreeType support (boo#911683)
grep "#define XRENDERFONT 1" xtermcfg.h
make %{?_smp_mflags}

pushd "../vttest-%{vttest_version}"
%configure
make %{?_smp_mflags}
popd

if ! which bdftopcf &> /dev/null; then exit 1; fi
for i in *.bdf
do
    bdftopcf "$i" | gzip -n -9 >"${i%.bdf}.pcf.gz"
done

%install
make DESTDIR=%{buildroot} install %{?_smp_mflags}

mkdir -p %{buildroot}%{xterminfo}
install -m 644 terminfo %{buildroot}%{xterminfo}/xterm.terminfo
install -m 644 termcap  %{buildroot}%{xterminfo}/xterm.termcap

pushd "../vttest-%{vttest_version}"
make DESTDIR=%{buildroot} install %{?_smp_mflags}
popd
install -m 755 $RPM_SOURCE_DIR/luitx %{buildroot}%{_prefix}/bin
install -m 755 $RPM_SOURCE_DIR/Backarrow2Delete %{buildroot}%{_prefix}/bin
install -m 755 $RPM_SOURCE_DIR/Backarrow2BackSpace %{buildroot}%{_prefix}/bin
install -m 644 $RPM_SOURCE_DIR/README.SUSE .

mkdir -p %{buildroot}%{_datadir}/pixmaps
install -m 644 $RPM_SOURCE_DIR/terminal.png \
    %{buildroot}%{_datadir}/pixmaps

mkdir -p %{buildroot}%{xfontsd}/misc/
install -m 644 *.pcf.gz %{buildroot}%{xfontsd}/misc/
%suse_update_desktop_file -i xterm TerminalEmulator

%if 0%{?suse_version} > 1220
%{reconfigure_fonts_scriptlets}
%endif

%files
%defattr(-,root,root)
%{_datadir}/applications/xterm.desktop
%{_datadir}/pixmaps/*

%if %{splitbin}
%files bin
%defattr(-,root,root)
%endif
%doc README README.i18n README.SUSE
%{_bindir}/vttest
%{_bindir}/luitx
%attr(755,root,root) %{_bindir}/xterm
%{_bindir}/resize
%{_bindir}/uxterm
%{_bindir}/koi8rxterm
%{_bindir}/Backarrow2Delete
%{_bindir}/Backarrow2BackSpace
%{_mandir}/man1/xterm.1.gz
%{_mandir}/man1/resize.1.gz
%{_mandir}/man1/vttest.1.gz
%{_mandir}/man1/koi8rxterm.1.gz
%{_mandir}/man1/uxterm.1.gz
%dir %{xterminfo}
%{xterminfo}/xterm.termcap
%{xterminfo}/xterm.terminfo
%dir %{xfontsd}/misc
%{xfontsd}/misc/20x20ja.pcf.gz
%{xfontsd}/misc/20x20ko.pcf.gz
%if 0%{?suse_version} > 1050
%dir %{xappdefs}
%endif
%{xappdefs}/KOI8RXTerm
%{xappdefs}/KOI8RXTerm-color
%{xappdefs}/UXTerm
%{xappdefs}/UXTerm-color
%{xappdefs}/XTerm
%{xappdefs}/XTerm-color

%changelog
openSUSE Build Service is sponsored by