File cogl.spec of Package cogl

#
# spec file for package cogl
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           cogl
Version:        1.12.2
Release:        0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer
License:        LGPL-2.1+
Group:          System/Libraries
Url:            http://clutter-project.org/
Source0:        http://download.gnome.org/sources/cogl/1.12/%{name}-%{version}.tar.xz
Source99:       baselibs.conf
BuildRequires:  fdupes
BuildRequires:  gtk-doc >= 1.13
BuildRequires:  pkgconfig(cairo) >= 1.10
BuildRequires:  pkgconfig(gdk-pixbuf-2.0) >= 2.0
BuildRequires:  pkgconfig(gl)
BuildRequires:  pkgconfig(glesv2)
BuildRequires:  pkgconfig(glib-2.0) >= 2.28.0
BuildRequires:  pkgconfig(gobject-introspection-1.0) >= 0.9.5
BuildRequires:  pkgconfig(libdrm)
BuildRequires:  pkgconfig(pangocairo) >= 1.20
BuildRequires:  pkgconfig(x11)
BuildRequires:  pkgconfig(xcomposite) >= 0.4
BuildRequires:  pkgconfig(xdamage)
BuildRequires:  pkgconfig(xext)
BuildRequires:  pkgconfig(xfixes) >= 3
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

%package -n libcogl11
Summary:        An object oriented GL/GLES Abstraction/Utility Layer
Group:          System/Libraries
Requires:       Mesa
Recommends:     %{name}-lang = %{version}
# To make the lang package installable
Provides:       %{name} = %{version}

%description  -n libcogl11
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

%package -n libcogl-gles2-11
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- OpenGL ES 2.0 Frontend API
Group:          System/Libraries

%description -n libcogl-gles2-11
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures

%package -n typelib-1_0-Cogl-1_0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-Cogl-1_0
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

This package provides the GObject Introspection bindings for Cogl.

%package -n libcogl-pango0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Pango Integration
Group:          System/Libraries

%description  -n libcogl-pango0
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

%package -n typelib-1_0-CoglPango-1_0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Pango Integration, Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-CoglPango-1_0
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

This package provides the GObject Introspection bindings for the Pango
integration in Cogl.

%package devel
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Development Files
Group:          Development/Libraries/GNOME
# cogl-defines.h includes GL/gl.h
Requires:       Mesa-devel
Requires:       libcogl-gles2-11 = %{version}
Requires:       libcogl-pango0 = %{version}
Requires:       libcogl11 = %{version}
Requires:       typelib-1_0-Cogl-1_0 = %{version}
Requires:       typelib-1_0-CoglPango-1_0 = %{version}

%description  devel
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

%lang_package
%prep
%setup -q

%build
%configure \
        --disable-static \
        --with-pic \
        --enable-gtk-doc \
        --enable-gles2 --enable-cogl-gles2
make %{?_smp_mflags} V=1

%install
%makeinstall
%{__rm} %{buildroot}%{_libdir}/*.la
%find_lang cogl
%fdupes %{buildroot}%{_libdir}/pkgconfig/

%post -n libcogl11 -p /sbin/ldconfig

%postun -n libcogl11 -p /sbin/ldconfig

%post -n libcogl-gles2-11 -p /sbin/ldconfig

%postun -n libcogl-gles2-11 -p /sbin/ldconfig

%post -n libcogl-pango0 -p /sbin/ldconfig

%postun -n libcogl-pango0 -p /sbin/ldconfig

%files -n libcogl11
%defattr(-,root,root)
%doc COPYING NEWS README ChangeLog
%{_libdir}/libcogl.so.*

%files -n libcogl-gles2-11
%defattr(-,root,root)
%{_libdir}/libcogl-gles2.so.*

%files -n typelib-1_0-Cogl-1_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/Cogl-1.0.typelib

%files -n libcogl-pango0
%defattr(-,root,root)
%doc COPYING NEWS README ChangeLog
%{_libdir}/libcogl-pango.so.*

%files -n typelib-1_0-CoglPango-1_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/CoglPango-1.0.typelib

%files devel
%defattr(-,root,root)
%{_libdir}/*.so
%{_includedir}/cogl/
%dir %{_datadir}/cogl/
%{_datadir}/cogl/examples-data/
%{_libdir}/pkgconfig/cogl-1.0.pc
%{_libdir}/pkgconfig/cogl-2.0-experimental.pc
%{_libdir}/pkgconfig/cogl-gles2-experimental.pc
%{_libdir}/pkgconfig/cogl-gl-1.0.pc
%{_libdir}/pkgconfig/cogl-pango-1.0.pc
%{_libdir}/pkgconfig/cogl-pango-2.0-experimental.pc
%{_datadir}/gir-1.0/*.gir
%doc %{_datadir}/gtk-doc/html/cogl/
%doc %{_datadir}/gtk-doc/html/cogl-2.0-experimental/

%files lang -f cogl.lang

%changelog
openSUSE Build Service is sponsored by