File fvwm2.spec of Package fvwm2

#
# spec file for package fvwm2
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

Name:           fvwm2
BuildRequires:  automake
BuildRequires:  freetype2-devel
BuildRequires:  fribidi-devel
BuildRequires:  gcc-c++
BuildRequires:  libpng-devel
BuildRequires:  libstroke-devel
BuildRequires:  pkgconfig
BuildRequires:  readline-devel
BuildRequires:  update-desktop-files
BuildRequires:  xorg-x11-devel
License:        GPL-2.0+
Group:          System/GUI/Other
Provides:       fvwm fvwmicns windowmanager xpmroot
Obsoletes:      fvwm xpmroot
Version:        2.5.26
Release:        0
Summary:        Improved Version of FVWM Window Manager
Url:            http://www.fvwm.org
Source0:        fvwm-%{version}.tar.bz2
Source1:        fvwm_icons.tar.bz2
Source3:        %name.desktop
Source4:        system.fvwm2rc
Source5:        _system.fvwm2rc
Source6:        openSuSE.xpm
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       xdg-menu, desktop-data, mktemp, xli
Patch0:         fvwm-configure.patch
Patch1:         fvwm-%{version}-gcc-warnings.patch
Patch2:         fvwm-%{version}-ia64.patch
Patch3:         fvwm-%{version}-sv_SE.patch
Patch5:         fvwm-%{version}-charset_in_title.patch
Patch6:         fvwm-2.5.26-libpng.patch
Patch7:         fvwm-%{version}-no-copy-dt-needed-entries.patch

%description
FVWM is a virtual desktop window manager for the X Window System.

FVWM is intended to have a small memory footprint but a rich feature
set, to be extremely customizable and extendible, and to be very
compatible with the Motif MWM.

%define _xorg7libs %_lib
%define _xorg7bin bin
%define _xorg7libs32 lib
%define _xorg7libshare share
%define _xorg7prefix /usr
%define _xorg7mandir %_mandir

%prep
%setup -q -n fvwm-%{version}
%patch0
%patch1
%patch2
%patch3
%patch5
%patch6
%patch7 -p1
find . -name *sv_SE* |xargs rename sv_SE sv  
mkdir icons
tar -C icons -j -x -v -f $RPM_SOURCE_DIR/fvwm_icons.tar.bz2
cp %{S:6} icons
#
# build 

%build
%{?suse_update_config:%{suse_update_config -f}}
autoreconf -fi
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing" \
LDFLAGS="-L/usr/%_lib" \
./configure \
		--prefix=%{_xorg7prefix} \
		--bindir=%{_prefix}/%{_xorg7bin} \
		--sysconfdir=/etc/X11/fvwm2 \
		--libexecdir=%{_xorg7prefix}/lib/X11/fvwm2 \
		--mandir=%{_xorg7mandir} \
		--x-includes=%{_xorg7prefix}/include \
		--x-libraries=%{_xorg7prefix}/%_lib \
		--with-imagepath=%{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps:%{_prefix}/%{_xorg7libshare}/X11/fvwm2/bitmaps:/usr/share/wallpapers \
		--disable-gtk
make %{?jobs:-j%jobs}

%install
make DESTDIR=$RPM_BUILD_ROOT install
#make prefix=$RPM_BUILD_ROOT%{_xorg7prefix} \
#     sysconfdir=$RPM_BUILD_ROOT/etc/X11/fvwm2 \
#     install
#
# default config
install -d -m 755 $RPM_BUILD_ROOT/etc/X11/fvwm2
install -m 644 %SOURCE4 $RPM_BUILD_ROOT/etc/X11/fvwm2/system.fvwm2rc
#
# some extra utils
install -d -m 755 $RPM_BUILD_ROOT%{_prefix}/%{_xorg7libshare}/X11/fvwm2/utils
install utils/quantize_pixmaps $RPM_BUILD_ROOT%{_prefix}/%{_xorg7libshare}/X11/fvwm2/utils
#
# documentation for modules
rm sample.fvwmrc/Makefile* sample.fvwmrc/system.fvwm2rc-sample-95
rm docs/Makefile*
install -d -m 755 docu-module
for i in `find -name "README*" ! -name "*,v" ! -name "*.orig"`
do
	TMPDIR=`dirname ${i#./}`
	if [ "x$TMPDIR" = "x." ]; then
		install -m 644 $i docu-module/${i#./}
	else
		install -m 644 $i docu-module/README.`basename "$TMPDIR"`
	fi
done
#
# icons
install -d -m 755 $RPM_BUILD_ROOT%{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps
install -m 644 icons/* $RPM_BUILD_ROOT%{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps
#
# install kdm/gdm entry
install -m 0755 -d $RPM_BUILD_ROOT/usr/share/xsessions/
install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/usr/share/xsessions/
# removing the useless README.vms file 
rm -f  $RPM_BUILD_ROOT/%{_prefix}/share/doc/packages/fvwm2/README.vms
%suse_update_desktop_file $RPM_BUILD_ROOT/usr/share/xsessions/%name.desktop
%find_lang fvwm %{name}.lang
%find_lang FvwmScript %{name}.lang
%find_lang FvwmTaskBar %{name}.lang

%clean
rm -rf $RPM_BUILD_ROOT

%files -f %{name}.lang
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS docs sample.fvwmrc docu-module/*
%dir /etc/X11/fvwm2
%config /etc/X11/fvwm2/system.fvwm2rc
%{_prefix}/%{_xorg7bin}/*
%{_prefix}/%{_xorg7libs32}/X11/fvwm2/*
%{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps/*
#%{_xorg7prefix}/share/locale/*/*/*
%{_prefix}/%{_xorg7libshare}/X11/fvwm2/utils/quantize_pixmaps
%dir %{_xorg7prefix}/lib/X11/fvwm2
%{_xorg7prefix}/share/fvwm
%dir %{_prefix}/%{_xorg7libshare}/X11/fvwm2
%dir %{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps
%dir %{_prefix}/%{_xorg7libshare}/X11/fvwm2/utils
%{_xorg7mandir}/man1/*
%{_datadir}/xsessions/*desktop

%changelog
openSUSE Build Service is sponsored by