File fvwm2.spec of Package fvwm2
#
# spec file for package fvwm2
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: fvwm2
Version: 2.6.7
Release: 0
Summary: The F Virtual Window Manager
License: GPL-2.0-or-later
Group: System/GUI/Other
Url: http://www.fvwm.org
Source0: fvwm-%{version}.tar.bz2
Source1: fvwm_icons.tar.bz2
Source3: %{name}.desktop
Source4: system.fvwm2rc
Source6: openSuSE.xpm
#SOURCE-FIX-OPENSUSE for snapshot 2012/10/11
Source7: fvwm-menu-desktop-config.fpl
Patch0: fvwm-configure.patch
Patch1: fvwm-2.5.26-gcc-warnings.patch
Patch2: fvwm-2.5.26-ia64.patch
Patch3: fvwm-2.5.26-sv_SE.patch
Patch5: fvwm-2.5.26-charset_in_title.patch
Patch7: fvwm-2.5.26-no-copy-dt-needed-entries.patch
#PATCH-FIX-OPENSUSE Avoid including internal rsvg-cairo.h
Patch8: fvwm-rsvg.patch
Patch10: fvwm-no-date-time.patch
BuildRequires: automake
BuildRequires: gcc-c++
BuildRequires: libpng-devel
BuildRequires: libstroke-devel
BuildRequires: libxslt-tools
BuildRequires: pkgconfig
BuildRequires: readline-devel
BuildRequires: update-desktop-files
BuildRequires: pkgconfig(cairo)
BuildRequires: pkgconfig(fontconfig)
BuildRequires: pkgconfig(fribidi)
BuildRequires: pkgconfig(gobject-2.0)
BuildRequires: pkgconfig(ice)
BuildRequires: pkgconfig(librsvg-2.0)
BuildRequires: pkgconfig(sm)
BuildRequires: pkgconfig(x11)
BuildRequires: pkgconfig(xcursor)
BuildRequires: pkgconfig(xext)
BuildRequires: pkgconfig(xft)
BuildRequires: pkgconfig(xinerama)
BuildRequires: pkgconfig(xpm)
BuildRequires: pkgconfig(xrender)
#not actually used but includes its headers anyway..
BuildRequires: pkgconfig(xt)
Requires: desktop-data
Requires: mktemp
Requires: wallpaper-branding
Requires: xdg-menu
Requires: xli
Requires(post): update-alternatives
Requires(postun): update-alternatives
Provides: fvwm
Provides: fvwmicns
Provides: windowmanager
Provides: xpmroot
Obsoletes: fvwm
Obsoletes: xpmroot
%description
FVWM is a virtual desktop window manager for the X Window System.
FVWM is intended to have a small memory footprint but a rich feature
set, to be extremely customizable and extendible, and to be very
compatible with the Motif Window Manager (mwm).
%define _xorg7libs %{_lib}
%define _xorg7bin bin
%define _xorg7libs32 lib
%define _xorg7libshare share
%define _xorg7prefix %{_prefix}
%define _xorg7mandir %{_mandir}
%prep
%setup -q -n fvwm-%{version}
%patch0 -b .p0
%patch1 -b .p1
%patch2 -b .p2
%patch3 -b .p3
%patch5 -b .p5
%patch7 -p1 -b .p7
%patch8 -b .p8
%patch10 -b .p10
find . -name *sv_SE* -exec rename --verbose sv_SE sv '{}' \+
mkdir icons
tar -C icons -j -x -v -f $RPM_SOURCE_DIR/fvwm_icons.tar.bz2
cp %{SOURCE6} icons
cp %{SOURCE7} bin/
#
# build
%build
autoreconf -fi
CFLAGS="%{optflags} -fno-strict-aliasing" \
LDFLAGS="-L/usr/%{_lib}" \
%configure \
--prefix=%{_xorg7prefix} \
--bindir=%{_prefix}/%{_xorg7bin} \
--sysconfdir=%{_sysconfdir}/X11/fvwm2 \
--libexecdir=%{_xorg7prefix}/lib/X11/fvwm2 \
--mandir=%{_xorg7mandir} \
--x-includes=%{_xorg7prefix}/include \
--x-libraries=%{_xorg7prefix}/%{_lib} \
--with-imagepath=%{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps:%{_prefix}/%{_xorg7libshare}/X11/fvwm2/bitmaps:%{_datadir}/pixmaps:%{_datadir}/wallpapers \
--disable-gtk
make %{?_smp_mflags}
%install
%make_install
#make prefix=$RPM_BUILD_ROOT%{_xorg7prefix} \
# sysconfdir=$RPM_BUILD_ROOT/etc/X11/fvwm2 \
# install
#
# default config
install -d -m 755 %{buildroot}%{_sysconfdir}/X11/fvwm2
install -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/X11/fvwm2/system.fvwm2rc
#
# documentation for modules
rm -vf sample.fvwmrc/Makefile* sample.fvwmrc/system.fvwm2rc-sample-95
rm -vf docs/Makefile*
install -d -m 755 docu-module
for i in $(find -name "README*" -not -name "*,v" -and -not -name "*.orig")
do
TMPDIR=$(dirname ${i#./})
if [ "x$TMPDIR" = "x." ]; then
install -m 644 $i docu-module/${i#./}
else
install -m 644 $i docu-module/README.$(basename "$TMPDIR")
fi
done
#
# forbidden links
pushd %{buildroot}/
find . -type l -printf '%%P %%l\n' | while read dst src
do
case "$src" in
%{buildroot}/*)
src=${src#%{buildroot}/}
rm -vf $dst
ln -frsv $src $dst
;;
*)
;;
esac
done
popd
#
# icons
install -d -m 755 %{buildroot}%{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps
install -m 644 icons/* %{buildroot}%{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps
#
# install kdm/gdm entry
install -m 0755 -d %{buildroot}%{_datadir}/xsessions/
install -m 0644 %{SOURCE3} %{buildroot}%{_datadir}/xsessions/
# removing the useless README.vms file
rm -f %{buildroot}/%{_docdir}/fvwm2/README.vms
%suse_update_desktop_file %{buildroot}%{_datadir}/xsessions/%{name}.desktop
%find_lang fvwm %{name}.lang
%find_lang FvwmScript %{name}.lang
%post
%{_sbindir}/update-alternatives --install %{_datadir}/xsessions/default.desktop \
default-xsession.desktop %{_datadir}/xsessions/fvwm2.desktop 20
%postun
[ -f %{_datadir}/xsessions/lxqt.desktop ] || %{_sbindir}/update-alternatives \
--remove default-xsession.desktop %{_datadir}/xsessions/fvwm2.desktop
%files -f %{name}.lang
%license COPYING
%doc NEWS docs docu-module/*
%dir %{_sysconfdir}/X11/fvwm2
%config %{_sysconfdir}/X11/fvwm2/system.fvwm2rc
%{_prefix}/%{_xorg7bin}/*
%{_prefix}/%{_xorg7libs32}/X11/fvwm2/*
%{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps/*
#%{_xorg7prefix}/share/locale/*/*/*
%dir %{_xorg7prefix}/lib/X11/fvwm2
%{_xorg7prefix}/share/fvwm
%dir %{_prefix}/%{_xorg7libshare}/X11/fvwm2
%dir %{_prefix}/%{_xorg7libshare}/X11/fvwm2/pixmaps
%{_xorg7mandir}/man1/*
%{_datadir}/xsessions/*desktop
%changelog