File python-django-dbtemplates.spec of Package python-django-dbtemplates
#
# spec file for package python-django-dbtemplates
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
Name: python-django-dbtemplates
Version: 1.3
Release: 0
Url: http://django-dbtemplates.readthedocs.org/
Summary: Template loader for templates stored in the database
License: BSD-3-Clause
Group: Development/Languages/Python
Source: django-dbtemplates-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-devel
BuildRequires: python-versiontools
Requires: python-django
%if 0%{?suse_version}
%py_requires
%if 0%{?suse_version} > 1110
BuildArch: noarch
%endif
%endif
%description
dbtemplates is a Django app that consists of two parts:
1. It allows you to store templates in your database
2. It provides `template loader`_ that enables Django to load the
templates from the database
It also features optional support for versioned storage and django-admin
command, integrates with Django's caching system and the admin actions.
%prep
%setup -q -n django-dbtemplates-%{version}
%build
python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
%files
%defattr(-,root,root,-)
%{python_sitelib}/*
%changelog