File python-oslo.concurrency.spec of Package python-oslo.concurrency
#
# spec file for package python-oslo.concurrency
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-oslo.concurrency
Version: 3.25.0
Release: 0
Summary: OpenStack oslo.concurrency library
License: Apache-2.0
Group: Development/Languages/Python
Url: https://launchpad.net/oslo.concurrency
Source0: https://files.pythonhosted.org/packages/source/o/oslo.concurrency/oslo.concurrency-3.25.0.tar.gz
BuildRequires: openstack-macros
BuildRequires: python-devel
BuildRequires: python2-enum34 >= 1.0.4
BuildRequires: python2-eventlet >= 0.18.2
BuildRequires: python2-fasteners >= 0.7.0
BuildRequires: python2-fixtures >= 3.0.0
BuildRequires: python2-futures >= 3.0.0
BuildRequires: python2-mock >= 2.0.0
BuildRequires: python2-oslo.config >= 5.1.0
BuildRequires: python2-oslo.i18n >= 3.15.3
BuildRequires: python2-oslo.utils >= 3.33.0
BuildRequires: python2-oslotest >= 3.2.0
BuildRequires: python2-pbr >= 2.0.0
BuildRequires: python2-testrepository >= 0.0.18
BuildRequires: python2-testscenarios >= 0.4
BuildRequires: python2-testtools >= 2.2.0
BuildRequires: python3-eventlet >= 0.18.2
BuildRequires: python3-fasteners >= 0.7.0
BuildRequires: python3-fixtures >= 3.0.0
BuildRequires: python3-mock >= 2.0.0
BuildRequires: python3-oslo.config >= 5.1.0
BuildRequires: python3-oslo.i18n >= 3.15.3
BuildRequires: python3-oslo.utils >= 3.33.0
BuildRequires: python3-oslotest >= 3.2.0
BuildRequires: python3-pbr >= 2.0.0
BuildRequires: python3-testrepository >= 0.0.18
BuildRequires: python3-testscenarios >= 0.4
BuildRequires: python3-testtools >= 2.2.0
Requires: python-fasteners >= 0.7.0
Requires: python-iso8601 >= 0.1.11
Requires: python-oslo.config >= 5.1.0
Requires: python-oslo.i18n >= 3.15.3
Requires: python-oslo.utils >= 3.33.0
Requires: python-retrying >= 1.2.3
Requires: python-six >= 1.10.0
BuildArch: noarch
%ifpython2
Requires: python-enum34 >= 1.0.4
%endif
%if 0%{?suse_version}
Requires(post): update-alternatives
Requires(postun): update-alternatives
%else
# on RDO, update-alternatives is in chkconfig
Requires(post): chkconfig
Requires(postun): chkconfig
%endif
%python_subpackages
%description
The oslo.concurrency library has utilities for safely running multi-thread,
multi-process applications using locking mechanisms and for running
external processes.
%package -n python-oslo.concurrency-doc
Summary: Documentation for OpenStack concurrency library
Group: Development/Languages/Python
BuildRequires: python-Sphinx
BuildRequires: python-openstackdocstheme >= 1.18.1
%description -n python-oslo.concurrency-doc
The oslo.concurrency library has utilities for safely running multi-thread,
multi-process applications using locking mechanisms and for running
external processes.
This package contains the documentation.
%prep
%autosetup -p1 -n oslo.concurrency-3.25.0
%py_req_cleanup
sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
%build
%{python_build}
# generate html docs
%{__python2} setup.py build_sphinx
# remove the sphinx-build leftovers
rm -rf doc/build/html/.{doctrees,buildinfo}
%install
%{python_install}
%python_clone -a %{buildroot}%{_bindir}/lockutils-wrapper
%post
%python_install_alternative lockutils-wrapper
%postun
%python_uninstall_alternative lockutils-wrapper
%check
%{python_expand rm -rf .testrepository
# Test suite fails on 32 bit platforms
# ifarch/ifnarch can not be used in noarch packages
if [ "%_lib" = "lib64" ]; then
$python setup.py testr
fi
}
%files %{python_files}
%license LICENSE
%doc README.rst ChangeLog
%python_alternative %{_bindir}/lockutils-wrapper
%{python_sitelib}/oslo_concurrency
%{python_sitelib}/*.egg-info
%files -n python-oslo.concurrency-doc
%license LICENSE
%doc doc/build/html
%changelog