File redland-bindings.spec of Package redland-bindings
#
# spec file for package redland-bindings
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define redland_version 1.0.17
Name: redland-bindings
Version: 1.0.17.1
Release: 0
Summary: Bindings for the Redland Libraries (RDF)
License: LGPL-2.1+ AND Apache-2.0
Group: System/Libraries
Url: http://www.librdf.org
Source0: http://download.librdf.org/source/%{name}-%{version}.tar.gz
BuildRequires: libredland-devel = %{redland_version}
BuildRequires: perl-base
BuildRequires: pkgconfig
BuildRequires: python-devel
BuildRequires: ruby-devel
BuildRequires: swig
%description
Bindings for the Redland RDF Libraries
%prep
%setup -q
%build
export PYTHON_LIB="%{python_sitearch}"
%configure \
--with-ruby --with-ruby-arch-install-dir-variable=vendorarchdir --with-ruby-install-dir=%{rb_vendorarchdir} \
--without-perl \
--with-python \
--without-php
make %{?_smp_mflags} RUBY_SO_SUFFIX=so
%install
%make_install RUBY_SO_SUFFIX=so
%package -n python-redland
Summary: Python bindings for programs that use Redland
Group: Development/Languages/Python
Requires: python-base = %{py_ver}
%requires_eq libredland0
%description -n python-redland
Redland librdf Language bindings provide high-level interfaces for
RDF (Resource Description Framework) implemented on top of the
Redland librdf library which provides an object-based RDF API,
supports for syntaxes and triple stores.
Python language bindings for the Redland RDF library.
%files -n python-redland
%{python_sitearch}/RDF.py
%{python_sitearch}/Redland.py
%{python_sitearch}/_Redland.so
%package -n ruby-redland
Summary: Ruby bindings for programs that use Redland
Group: Development/Languages/Ruby
%requires_eq libredland0
%description -n ruby-redland
Redland librdf Language bindings provide high-level interfaces for
RDF (Resource Description Framework) implemented on top of the
Redland librdf library which provides an object-based RDF API,
supports for syntaxes and triple stores.
Ruby language bindings for the Redland RDF library.
%files -n ruby-redland
%{rb_vendorarchdir}/redland.so
%{rb_vendorarchdir}/rdf
%changelog