File python-six-doc.spec of Package python-six

#
# spec file for package python-six-doc
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-six-doc
Version:        1.11.0
Release:        0
Url:            http://pypi.python.org/pypi/six/
Summary:        Python 2 and 3 compatibility utilities
License:        MIT
Group:          Development/Libraries/Python
Source:         https://files.pythonhosted.org/packages/source/s/six/six-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  %{python_module six}
# require old python 2 explicitly to get the ssl module
BuildRequires:  python
# require only one version of Sphinx for now
BuildRequires:  python3-Sphinx
# Test requirements:
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module py}
BuildRequires:  python-rpm-macros
BuildArch:      noarch
Provides:       %{python_module six-doc = %{version}}

%description
Six is a Python 2 and 3 compatibility library. It provides utility
functions for smoothing over the differences between the Python
versions with the goal of writing Python code that is compatible on
both Python versions. See the documentation for more information on
what is provided.

%prep
%setup -q -n six-%{version}

%build
# due to cyclic requirements between Sphinx and six,
# documentation is build in its own package <hpj@urpla.net>
cd documentation && make html && rm _build/html/.buildinfo

%install
# only build documentation

# Run tests here to avoid dependency loop
%check
mkdir test
cp test_six.py test
pushd test
%python_exec %{_bindir}/py.test test_six.py
popd
rm -rf test

%files
%defattr(-,root,root)
%doc LICENSE README.rst CHANGES documentation/_build/html

%changelog
openSUSE Build Service is sponsored by