File python-Chameleon.spec of Package python-Chameleon

#
# spec file for package python-Chameleon
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-Chameleon
Version:        3.1
Release:        0
Url:            http://www.pagetemplates.org/
Summary:        Fast HTML/XML Template Compiler
License:        BSD-3-Clause and BSD-4-Clause and Python-2.0 and ZPL-2.1
Group:          Development/Languages/Python
Source:         https://files.pythonhosted.org/packages/source/C/Chameleon/Chameleon-%{version}.tar.gz
BuildRequires:  %{python_module Sphinx}
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
# seems like Chamelon needs pkg_resources on runtime
# it invalidates its template cache based on your combined package versions
Requires:       python-setuptools
BuildArch:      noarch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%python_subpackages

%description
Chameleon is an HTML/XML template engine for Python. It uses the 
*page templates* language.

You can use it in any Python web application with just about any
version of Python (2.5 and up, including 3.x and pypy).

%prep
%setup -q -n Chameleon-%{version}

%build
%python_build
%python_exec setup.py build_sphinx && rm build/sphinx/html/.buildinfo

%install
%python_install
# Don't ship testsuite
%python_expand rm -rvf %{buildroot}%{python_sitelib}/chameleon/tests 
%python_expand %fdupes -s %{buildroot}%{$python_sitelib}

%check
%python_exec setup.py test
# Delete again any output produced here
%python_expand rm -rvf %{buildroot}%{python_sitelib}/chameleon/tests 

%files %python_files
%defattr(-,root,root,-)
%if 0%{?leap_version} >= 420200 || 0%{?suse_version} > 1320
%license LICENSE.txt
%else
%doc LICENSE.txt
%endif
%doc COPYRIGHT.txt README.rst
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by