File classmate.spec of Package classmate.30167
#
# spec file for package classmate
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global upstream_name java-classmate-classmate
Name: classmate
Version: 1.5.1
Release: 0
License: Apache-2.0
Summary: Library for introspecting types in Java
URL: http://github.com/FasterXML/java-classmate
Group: Development/Libraries/Java
Source0: https://github.com/FasterXML/java-classmate/archive/%{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: fdupes
BuildRequires: java-devel
BuildRequires: maven-local
BuildRequires: xz
BuildRequires: mvn(com.fasterxml:oss-parent:pom:)
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
BuildRequires: mvn(org.apache.maven.plugins:maven-source-plugin)
BuildArch: noarch
Requires: java
%description
ClassMate is a zero-dependency Java library for accurately introspecting type information, including reliable resolution of generic type declarations for both classes ("types") and members (fields, methods and constructors).
%package javadoc
Summary: Javadoc for %{name}
%description javadoc
This package contains javadoc for %{name}
%prep
%setup -q -n "%{upstream_name}-%{version}"
%pom_remove_plugin :nexus-staging-maven-plugin
%pom_remove_plugin :moditect-maven-plugin
%build
%mvn_build -f -- \
%if %{?pkg_vcmp:%pkg_vcmp java-devel >= 9}%{!?pkg_vcmp:0}
-Dmaven.compiler.release=8 \
%endif
-Dsource=8
%install
%mvn_install
%fdupes -s %{buildroot}%{_javadocdir}
%files -f .mfiles
%license LICENSE
%files javadoc -f .mfiles-javadoc
%license LICENSE
%changelog