File libmatroska.spec of Package libmatroska
#
# spec file for package libmatroska
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define soname 6
Name: libmatroska
Version: 1.4.2
Release: 0
Summary: Library to Deal with Matroska Files
License: LGPL-2.1+
Group: Development/Libraries/C and C++
Url: http://www.matroska.org/
#Git-Clone: git://github.com/Matroska-Org/libmatroska
#Git-Web: https://github.com/Matroska-Org/libmatroska
Source0: http://dl.matroska.org/downloads/libmatroska/%{name}-%{version}.tar.bz2
Source1: baselibs.conf
Source99: %name.changes
BuildRequires: gcc-c++
BuildRequires: pkg-config
BuildRequires: pkgconfig(libebml) >= 1.3.1
%description
Libmatroska is a C++ library to parse Matroska files (.mkv and .mka).
It depends on libebml to work. You only need this package to compile
your own applications.
%package -n libmatroska%{soname}
Summary: Library to Deal with Matroska Files
Group: System/Libraries
%description -n libmatroska%{soname}
Libmatroska is a C++ library to parse Matroska files (.mkv and .mka).
It depends on libebml to work. You only need this package to compile
your own applications.
%package devel
Summary: Library to Deal with Matroska Files
Group: Development/Libraries/C and C++
Requires: libebml-devel >= 1.0.0
Requires: libmatroska%{soname} = %{version}
%description devel
Libmatroska is a C++ library to parse Matroska files (.mkv and .mka).
It depends on libebml to work. You only need this package to compile
your own applications.
%prep
%setup -q
%build
FAKE_BUILDTIMESTAMP=$(LC_ALL=C date -r %{S:99} '+%a %b %e %H:%M:%S %Y')
sed -i "s/__TIMESTAMP__/\"$FAKE_BUILDTIMESTAMP\"/" matroska/KaxVersion.h
%configure --disable-static
# mkvmerge-7.1.0 built against libmatroska-1.4.1 running against
# libmatroska-1.4.0: symbol lookup error: mkvmerge: undefined symbol:
# _ZN11libmatroska14KaxSeekPreRoll10ClassInfosE.
# Force some additional versioning, since upstream did not track the ABI
# changes. Tag with the version of the most recent incompatible change.
echo "V_1.4.1 { global: *; };" >libmatroska.sym
make %{?_smp_mflags} \
LDFLAGS="-Wl,--version-script=$PWD/libmatroska.sym"
%install
%make_install
rm -f "%buildroot/%_libdir"/*.la
%post -n libmatroska%{soname} -p /sbin/ldconfig
%postun -n libmatroska%{soname} -p /sbin/ldconfig
%files -n libmatroska%{soname}
%defattr(-,root,root)
%{_libdir}/libmatroska.so.%{soname}*
%files devel
%defattr(-,root,root)
%{_libdir}/libmatroska.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/matroska
%changelog