File alex.spec of Package alex

#
# spec file for package alex
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2012 Peter Trommler peter.trommler@ohm-hochschule.de
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%bcond_without tests

Name:           alex
Version:        3.1.4
Release:        0
Summary:        Tool for generating lexical analysers in Haskell
License:        BSD-3-Clause
Group:          Development/Languages/Other

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Url:            http://hackage.haskell.org/package/%{name}
Source0:        http://hackage.haskell.org/packages/archive/%{name}/%{version}/%{name}-%{version}.tar.gz
# PATCH-FIX-UPSTREAM alex-3.1.4-ghc-7.10.patch -- fix for new prelude in ghc-7.10 -- Sergei Trofimovich
Patch0:         alex-3.1.4-ghc-7.10.patch

BuildRequires:  autoconf
BuildRequires:  ghc-Cabal-devel
BuildRequires:  ghc-QuickCheck-devel
BuildRequires:  ghc-array-devel
BuildRequires:  ghc-containers-devel
BuildRequires:  ghc-directory-devel
BuildRequires:  ghc-rpm-macros

%description
Alex is a tool for generating lexical analysers in Haskell. It takes a
description of tokens based on regular expressions and generates a Haskell
module containing code for scanning text efficiently. It is similar to the tool
lex or flex for C/C++.

%prep
%setup -q
%patch0 -p1

%build
%ghc_bin_build
cd doc
test -f configure || autoreconf
./configure

%install
%ghc_bin_install
mkdir -p %{buildroot}/%{_mandir}/man1
cp doc/alex.1 %{buildroot}/%{_mandir}/man1

%files
%defattr(-,root,root,-)
%doc LICENSE ANNOUNCE README TODO
%doc examples
%attr(755,root,root) %{_bindir}/%{name}
%{_datadir}/%{name}-%{version}
%{_mandir}/man1/*

%changelog
openSUSE Build Service is sponsored by