File python-Shed_Skin.spec of Package python-Shed_Skin
#
# spec file for package python-Shed_Skin
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: python-Shed_Skin
Version: 0.9.4
Release: 0
Url: http://shedskin.googlecode.com
Summary: An Optimizing (restricted) Python-to-C++ Compiler
License: GPL-3.0+
Group: Development/Languages/Python
Source: http://shedskin.googlecode.com/files/shedskin-%{version}.tgz
Source1: http://shedskin.googlecode.com/files/shedskin-examples-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
#BuildRequires: gc-devel
#BuildRequires: gcc-c++
#BuildRequires: pcre-devel
BuildRequires: python-devel
Requires: gc-devel
Requires: gcc-c++
Requires: pcre-devel
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
Shed Skin is an experimental (restricted) Python-to-C++ compiler. It accepts
pure but implicitly statically typed Python programs and generates optimized
C++ code. The result can be further compiled to stand-alone programs or
extension modules. For a set of 57 non-trivial test programs, at more than
16,000 lines in total (sloccount), measurements show a typical speedup of
2-200 times compared to CPython. Not all Python features are supported, and
only a subset of about 20 library modules, such as re and random. See the
home page for more details.
%package doc
Summary: An Optimizing (restricted) Python-to-C++ Compiler - Documentation
Group: Development/Libraries/Python
Requires: %{name} = %{version}
%description doc
Shed Skin is an experimental (restricted) Python-to-C++ compiler. It accepts
pure but implicitly statically typed Python programs and generates optimized
C++ code. The result can be further compiled to stand-alone programs or
extension modules. For a set of 57 non-trivial test programs, at more than
16,000 lines in total (sloccount), measurements show a typical speedup of
2-200 times compared to CPython. Not all Python features are supported, and
only a subset of about 20 library modules, such as re and random. See the
home page for more details.
This package contains the documentation of %{name}.
%prep
%setup -q -n shedskin-%{version}
tar xxf %{SOURCE1} && mv shedskin-examples-%{version} examples # Unpack seperate examples
sed -i 's/\r$//' examples/{*.py,scene.txt,ml/*.{py,txt},testdata/*} # Fix wrong EOL encoding
%build
CFLAGS="%{optflags}" python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
# Disable testsuite, it takes far too long. Feel free to test after version updates:
#%%check
#python setup.py test
%files
%defattr(-,root,root,-)
%doc LICENSE README
%{_bindir}/shedskin
%{python_sitelib}/*
%files doc
%defattr(-,root,root,-)
%doc examples
%changelog