File qwt.spec of Package qwt
#
# spec file for package qwt
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: qwt
%define lname libqwt5
Summary: Qt Widgets for Technical Applications
License: SUSE-QWT-1.0
Group: Development/Libraries/C and C++
Version: 5.2.3
Release: 0
Url: http://qwt.sourceforge.net/
Source: http://switch.dl.sourceforge.net/sourceforge/qwt/qwt-%{version}.tar.bz2
Source2: qwt-rpmlintrc
Source3: %{name}-%{version}.pdf
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: fdupes
BuildRequires: freetype2-devel
BuildRequires: gcc-c++
BuildRequires: libpng-devel
BuildRequires: libqt4-devel
%description
The Qwt library contains GUI Components and utility classes which are
primarily useful for programs with a technical background. Beside a 2D
plot widget it provides scales, sliders, dials, compasses, thermometers,
wheels and knobs to control or display values, arrays, or ranges of type
double.
%package -n %{lname}
Summary: Shared library for Qt Widgets
Group: Development/Libraries/C and C++
%description -n %{lname}
This package contains the shared library to run Technical Applications
developed with/for qwt.
%package devel
Summary: Include headers and Qt Designer plugin for Qwt
Group: Development/Libraries/C and C++
Requires: %{lname} = %{version}
Requires: freetype2-devel
Requires: gcc-c++
Requires: libpng-devel
Requires: libqt4-devel
Recommends: %{name}-devel-doc
Recommends: %{name}-examples
Obsoletes: libqwt5-devel < %{version}
Provides: libqwt5-devel = %{version}
Provides: qwt = %{version}
%description devel
This package contains the header files of Qwt and its Qt designer plugin
in order to create Qt applications using the Qwt widgets.
%package examples
Summary: Example programs using Qwt
Group: Development/Libraries/C and C++
Requires: %{name}-devel = %{version}
Obsoletes: libqwt5-examples < %{version}
Provides: libqwt5-examples = %{version}
%description examples
This package contains example programs demonstrating the Qwt widgets.
%package designer
Summary: Plugin for the Qt Interface designer
Group: Development/Tools/IDE
Requires: %{name}-devel = %{version}
Requires: libqt4-devel
%description designer
The %{name}-designer package contains the plugin for the Qt User Interface
designer tool.
%package devel-doc
Summary: Development documentation for Qwt
Group: Development/Libraries/C and C++
Requires: %{name}-devel = %{version}
Obsoletes: libqwt5-devel-doc < %{version}
Provides: libqwt5-devel-doc = %{version}
# Both provide deprecated(3) man page
Conflicts: libftdi1-devel
%description devel-doc
This package contains the development documentation of the Qwt widgets
as is it created by doxygen.
%prep
%setup -q
%build
# Now build the qwt5 library
qmake \
INSTALLBASE=%{_prefix} \
CONFIG+=QwtExamples CONFIG+=QwtSVGItem -after \
QMAKE_CXXFLAGS="%{optflags}" \
target.path=%{_libdir} \
headers.path=%{_includedir}/%{name}5 \
doc.path=%{_docdir}/%{name}-devel-doc
make %{?_smp_mflags}
%install
make DESTDIR=%{buildroot} install INSTALL_ROOT=%{buildroot}
# man
mkdir -p %{buildroot}/%{_mandir}
mv -v %{buildroot}/%{_docdir}/%{name}-devel-doc/man/man3 %{buildroot}/%{_mandir}/
# docu
install -m0644 %{SOURCE3} %{buildroot}%{_docdir}/%{name}-devel-doc/%{name}.pdf
# designer plugin
mkdir -p %{buildroot}/%{_libdir}/qt4/plugins/designer
mv -v %{buildroot}/%{_libdir}/libqwt_designer_plugin.so %{buildroot}/%{_libdir}/qt4/plugins/designer/
%fdupes -s %{buildroot}
%post -n %{lname} -p /sbin/ldconfig
%postun -n %{lname} -p /sbin/ldconfig
%clean
rm -rf %{buildroot}
%files -n %{lname}
%defattr(-,root,root)
%doc CHANGES COPYING README
%{_libdir}/libqwt*.so.*
%files designer
%defattr(-,root,root)
%{_libdir}/qt4/plugins/designer/libqwt_designer_plugin.so
%files devel
%defattr(-,root,root)
%{_libdir}/libqwt*.so
%dir %{_includedir}/%{name}5
%{_includedir}/%{name}5/*.h
%files examples
%defattr(-,root,root)
%doc examples
%files devel-doc
%defattr(-,root,root)
%doc %{_docdir}/%{name}-devel-doc
%{_mandir}/man3/*
%changelog