File hscolour.spec of Package hscolour

#
# spec file for package hscolour
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%global pkg_name hscolour

# link statically to Haskell libs for easier ghc bootstrapping
%global ghc_without_dynamic 1

Name:           hscolour
Version:        1.24
Release:        0
Summary:        Colorise Haskell code
License:        GPL-2.0
Group:          Development/Languages/Other

BuildRoot:      %{_tmppath}/%{name}-%{version}-build
# BEGIN cabal2spec
Url:            http://hackage.haskell.org/package/%{name}
Source0:        http://hackage.haskell.org/packages/archive/%{name}/%{version}/%{name}-%{version}.tar.gz
Source1:        hscolour-rpmlintrc
BuildRequires:  ghc-Cabal-devel
BuildRequires:  ghc-containers-devel
BuildRequires:  ghc-rpm-macros
# END cabal2spec

%description 
A small Haskell script to colorise Haskell code. It currently has
six output formats: ANSI terminal codes (optionally XTerm-256colour codes),
HTML 3.2 with font tags, HTML 4.01 with CSS, HTML 4.01 with CSS and mouseover
annotations, XHTML 1.0 with inline CSS styling, LaTeX, and mIRC chat codes.

%package -n ghc-%{pkg_name}
Summary:        Haskell %{pkg_name} library
Group:          Development/Languages/Other

%description -n ghc-%{pkg_name}
Haskell library to colorise Haskell code.

%package -n ghc-%{pkg_name}-devel
Summary:        Haskell %{pkg_name} library development files
Group:          Development/Languages/Other
Requires:       ghc-compiler
Requires(post): ghc-compiler
Requires(postun): ghc-compiler
Requires:       ghc-%{pkg_name} = %{version}-%{release}

%description -n ghc-%{pkg_name}-devel
Development files for Haskell library tocolorise Haskell code.

%prep
%setup -q

%build
%ghc_lib_build

%install
%ghc_lib_install

%post -n ghc-%{pkg_name}-devel
%ghc_pkg_recache

%postun -n ghc-%{pkg_name}-devel
%ghc_pkg_recache

%files
%defattr(-,root,root,-)
%doc LICENCE-GPL
%attr(755,root,root) %{_bindir}/HsColour
%{_datadir}/%{name}-%{version}

%files -n ghc-%{pkg_name} -f ghc-%{pkg_name}.files
%defattr(-,root,root,-)

%files -n ghc-%{pkg_name}-devel -f ghc-%{pkg_name}-devel.files
%defattr(-,root,root,-)

%changelog
openSUSE Build Service is sponsored by