File spyder.spec of Package spyder
#
# spec file for package spyder
#
# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: spyder
Version: 2.3.5.2
Release: 0
Url: http://spyderlib.googlecode.com
Summary: Scientific PYthon Development EnviRonment
License: MIT
Group: Development/Languages/Python
Source: https://pypi.python.org/packages/source/s/spyder/spyder-%{version}.zip
Source1: spyder-rpmlintrc
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: IPython
BuildRequires: fdupes
BuildRequires: python-Sphinx >= 0.6.0
BuildRequires: python-devel >= 2.5
BuildRequires: python-matplotlib
BuildRequires: python-numpy
BuildRequires: python-pep8
BuildRequires: python-psutil
BuildRequires: python-pyflakes >= 0.5.0
BuildRequires: python-qt4 >= 4.6
BuildRequires: python-rope => 0.9.2
BuildRequires: python-scipy
BuildRequires: unzip
BuildRequires: update-desktop-files
Requires: python-spyderlib = %{version}
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch: noarch
%endif
%description
A Scientific Python development environment, an alternative to IDLE
with powerful interactive features such as variable explorer (with
GUI-based editors for dictionaries, lists, NumPy arrays, etc.), object
inspector, online help, and a lot more.
%package -n python-spyderlib
Summary: Python GUI components
Group: Development/Languages/Python
Requires: python-Sphinx >= 0.6.0
Requires: python-qt4 >= 4.6
Recommends: IPython
Recommends: python-matplotlib
Recommends: python-numpy
Recommends: python-pep8
Recommends: python-psutil
Recommends: python-pyflakes >= 0.5.0
Recommends: python-pylint
Recommends: python-rope >= 0.9.2
Recommends: python-scipy
%description -n python-spyderlib
The spyderlib module provides powerful console and
editor related widgets to your PyQt4 application.
%package doc
Summary: Documentation for %{name} and python-spyderlib
Group: Development/Languages/Python
Requires: %{name} = %{version}
%description doc
Documentation and help files for both %{name} and python-spyderlib
%lang_package
%prep
%setup -q
# Fix wrong-file-end-of-line-encoding RPMLint warning
sed -i 's/\r$//' doc/*.rst
sed -i 's/\r$//' spyderlib/userconfig.py
sed -i 's/\r$//' LICENSE
%build
python setup.py build && rm build/lib/spyderlib/doc/.buildinfo
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
# remove windows stuff
rm %{buildroot}%{_bindir}/spyder_win_post_install.py
# create missing directories
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
# install the icon
pushd %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/
ln -s %{python_sitelib}/spyderlib/images/spyder.svg %{name}.svg
popd
%find_lang spyderlib %{name}.lang
%find_lang p_breakpoints %{name}.lang
%find_lang p_profiler %{name}.lang
%find_lang p_pylint %{name}.lang
%suse_update_desktop_file %{name}
%fdupes %{buildroot}%{python_sitelib}
# Documentation belongs into _docdir:
rm -r %{buildroot}%{python_sitelib}/spyderlib/doc
rm -f build/lib/spyderlib/doc/.buildinfo
%files
%defattr(-,root,root,-)
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
%dir %{_datadir}/icons/hicolor/scalable
%dir %{_datadir}/icons/hicolor/scalable/apps
%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
%{_datadir}/pixmaps/%{name}.png
%files -n python-spyderlib
%defattr(-,root,root,-)
%doc LICENSE README.md
%{python_sitelib}/spyderlib/
%{python_sitelib}/spyderplugins/
%{python_sitelib}/spyder-%{version}-py*.egg-info
%exclude %{python_sitelib}/spyderlib/locale/
%exclude %{python_sitelib}/spyderplugins/locale/
%files doc
%defattr(-,root,root,-)
%doc build/lib/spyderlib/doc/
%files lang -f %{name}.lang
%defattr(-,root,root)
%{python_sitelib}/spyderlib/locale
%{python_sitelib}/spyderplugins/locale/
%changelog