File vinagre.spec of Package vinagre
#
# spec file for package vinagre
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_without rdp
Name: vinagre
Version: 3.20.2
Release: 0
Summary: VNC client for GNOME
License: GPL-2.0+
Group: Productivity/Networking/Other
Url: http://www.gnome.org/projects/vinagre/
Source0: http://download.gnome.org/sources/vinagre/3.20/%{name}-%{version}.tar.xz
# PATCH-FIX-UPSTREAM vinagre-freerdp2.patch bgo#765444.patch mgorse@suse.com -- handle new "freerdp2" package name.
Patch1: vinagre-freerdp2.patch
# The icon we rely on is from adwaita-icon-theme
BuildRequires: adwaita-icon-theme
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: gdbm-devel
BuildRequires: intltool >= 0.50.0
# We need the %%mime_database_* macros
BuildRequires: shared-mime-info
BuildRequires: translation-update-upstream
BuildRequires: update-desktop-files
BuildRequires: vala
BuildRequires: yelp-tools
BuildRequires: pkgconfig(avahi-gobject)
BuildRequires: pkgconfig(avahi-ui-gtk3)
%if %{with rdp}
BuildRequires: pkgconfig(freerdp2)
%endif
BuildRequires: pkgconfig(gtk+-3.0) >= 3.9.6
BuildRequires: pkgconfig(gtk-vnc-2.0) >= 0.4.3
BuildRequires: pkgconfig(libsecret-1)
BuildRequires: pkgconfig(libxml-2.0) >= 2.6.31
BuildRequires: pkgconfig(spice-client-gtk-3.0) >= 0.5
BuildRequires: pkgconfig(telepathy-glib)
BuildRequires: pkgconfig(vte-2.91)
BuildRequires: pkgconfig(x11)
# Next two lines needed for Patch1
BuildRequires: gnome-common
BuildRequires: pkgconfig(appstream-glib)
Recommends: %{name}-lang
Obsoletes: %{name}-devel < %{version}
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%{glib2_gsettings_schema_requires}
%description
Vinagre is a VNC client for GNOME that supports connecting to multiple
machines, browsing for VNC servers via avahi and password storage in
gnome-keyring.
%lang_package
%prep
%setup -q
%patch1 -p1
translation-update-upstream
%build
# Needed for Patch1
autoreconf
%configure --disable-static \
--disable-scrollkeeper \
%if %{with rdp}
--enable-rdp \
%endif
--enable-spice \
--enable-ssh
make V=1 %{?_smp_mflags}
%install
make DESTDIR=%{buildroot} install %{?_smp_mflags}
find %{buildroot} -type f -name "*.la" -delete -print
%suse_update_desktop_file -G "Remote Desktop Viewer" vinagre
%suse_update_desktop_file vinagre-file
%find_lang %{name} %{?no_lang_C}
for size in 8x8 16x16 22x22 24x24 32x32 48x48 256x256; do
if test -f %{_datadir}/icons/gnome/$size/apps/preferences-desktop-remote-desktop.png; then
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/$size/apps
cp -a %{_datadir}/icons/gnome/$size/apps/preferences-desktop-remote-desktop.png %{buildroot}%{_datadir}/icons/hicolor/$size/apps/preferences-desktop-remote-desktop.png
fi
done
%fdupes %{buildroot}
%post
%{glib2_gsettings_schema_post}
%desktop_database_post
%icon_theme_cache_post
%mime_database_post
%postun
%{glib2_gsettings_schema_postun}
%desktop_database_postun
%icon_theme_cache_postun
%mime_database_postun
%files
%defattr(-, root, root)
%doc %{_datadir}/help/C/%{name}/
%{_bindir}/vinagre
%dir %{_datadir}/appdata
%{_datadir}/appdata/vinagre.appdata.xml
%{_datadir}/applications/vinagre.desktop
%{_datadir}/applications/vinagre-file.desktop
%{_datadir}/dbus-1/services/org.freedesktop.Telepathy.Client.Vinagre.service
%dir %{_datadir}/GConf
%dir %{_datadir}/GConf/gsettings
%{_datadir}/GConf/gsettings/org.gnome.Vinagre.convert
%{_datadir}/glib-2.0/schemas/org.gnome.Vinagre.gschema.xml
%{_datadir}/icons/hicolor/*/*/*
%{_datadir}/mime/packages/vinagre-mime.xml
%{_datadir}/telepathy/clients/Vinagre.client
%dir %{_datadir}/vinagre
%{_datadir}/vinagre/vinagre*
%{_mandir}/man1/*.1.gz
# Own directories that are not owned by anything else
%dir %{_datadir}/telepathy
%dir %{_datadir}/telepathy/clients
%files lang -f %{name}.lang
%defattr(-,root,root)
%changelog