File ElectricFence.spec of Package ElectricFence

#
# spec file for package ElectricFence
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           ElectricFence
License:        LGPL-2.1+
Group:          Development/Tools/Debuggers
Provides:       efence
Obsoletes:      efence
Version:        2.2.2
Release:        667
Summary:        Malloc Debugger
Url:            http://perens.com/FreeSoftware
Source:         %{name}-%{version}.tar.bz2
Patch0:         %{name}-%{version}.diff
Patch1:         %{name}-%{version}-alignment.diff
Patch2:         %{name}-%{version}-pthread.diff
Patch3:         %{name}-%{version}-mmap.diff
Patch4:         %{name}-strerror.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Tool for debugging your C programs (malloc debugger).

%prep
%setup -q
%patch0
%patch1
%patch2
%patch3
%patch4 -p1

%build
echo -e "#!/bin/bash\n`which %__cc` \"\$@\"" >gcc
chmod 755 gcc
export PATH=`pwd`:$PATH
make CC="%__cc" CFLAGS="$RPM_OPT_FLAGS -g -DUSE_SEMAPHORE -fPIC" %{?_smp_mflags}

%install
install -D -d -m755 $RPM_BUILD_ROOT%{_bindir}
install -D -d -m755 $RPM_BUILD_ROOT%{_libdir}
install -D -d -m755 $RPM_BUILD_ROOT%{_mandir}/man3
make	BIN_INSTALL_DIR=$RPM_BUILD_ROOT%{_bindir} \
	LIB_INSTALL_DIR=$RPM_BUILD_ROOT%{_libdir} \
	MAN_INSTALL_DIR=$RPM_BUILD_ROOT%{_mandir}/man3 \
	install

%post
%{run_ldconfig}

%postun
%{run_ldconfig}

%files
%defattr(-,root,root)
%doc README CHANGES COPYING
%doc %{_mandir}/man?/*
%{_libdir}/lib*
%{_bindir}/*

%changelog
openSUSE Build Service is sponsored by