File libsmdev.spec of Package libsmdev
#
# spec file for package libsmdev
#
# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define lname libsmdev1
%define timestamp 20150105
Name: libsmdev
Version: 0~%{timestamp}
Release: 0
Summary: Library to access storage media devices
License: LGPL-3.0+
Group: Productivity/File utilities
Url: https://github.com/libyal/libsmdev/wiki
Source: https://github.com/libyal/libsmdev/releases/download/%timestamp/%{name}-alpha-%{timestamp}.tar.gz
BuildRequires: pkg-config
BuildRequires: python-devel
BuildRequires: pkgconfig(libcdata) >= 20120425
BuildRequires: pkgconfig(libcfile) >= 20130609
BuildRequires: pkgconfig(libclocale) >= 20130609
BuildRequires: pkgconfig(libcnotify) >= 20130609
BuildRequires: pkgconfig(libcsystem) >= 20120425
BuildRequires: pkgconfig(libcthreads) >= 20130723
BuildRequires: pkgconfig(libuna) >= 20120425
#Use internal packages for these. The factory version fails if used here. Tested 1-8-2015
#BuildRequires: pkgconfig(libcerror) >= 20120425
#BuildRequires: pkgconfig(libcstring) >= 20120425
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
libsmdev is a library to access and read storage media devices.
%package -n %{lname}
Summary: Library to access storage media devices
Group: System/Libraries
%description -n %{lname}
libsmdev is a library to access and read storage media devices.
%package devel
Summary: Development files for libsmdev, a storage media access library
Group: Development/Libraries/C and C++
Requires: %{lname} = %{version}
%description devel
libsmdev is a library to access and read storage media devices.
This subpackage contains libraries and header files for developing
applications that want to make use of libsmdev.
%package tools
Summary: Utilities for reading storage media devices through libsmdev
Group: Productivity/File utilities
%description tools
This subpackage contains the utility programs from libsmdev, which
can access and read storage media devices and will determine
information about such.
%package -n python-%{name}
Summary: Python bindings for libsmdev
Group: Development/Libraries/Python
Requires: %{lname} = %{version}
Requires: python
Provides: pysmdev = %{version}
%description -n python-%{name}
Python bindings for libsmdev, which is a library to access and read storage media devices.
%prep
%setup -q -n libsmdev-%{timestamp}
%build
%configure --disable-static --enable-wide-character-type --enable-python
make %{?_smp_mflags}
%install
make DESTDIR=%{buildroot} install %{?_smp_mflags}
find %{buildroot} -type f -name "*.la" -delete -print
%post -n %{lname} -p /sbin/ldconfig
%postun -n %{lname} -p /sbin/ldconfig
%files -n %{lname}
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog
%{_libdir}/libsmdev.so.1*
%files devel
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog
%{_includedir}/libsmdev*
%{_libdir}/libsmdev.so
%{_libdir}/pkgconfig/libsmdev.pc
%{_mandir}/man3/libsmdev.3*
%files tools
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog
%{_bindir}/smdevinfo
%{_mandir}/man1/smdevinfo.1*
%files -n python-%{name}
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog
%{python_sitearch}/pysmdev.so
%changelog