File python3-pep8.spec of Package python3-pep8

#
# spec file for package python3-pep8
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python3-pep8
Version:        1.6.2
Release:        0
Url:            http://github.com/jcrocholl/pep8
Summary:        Python style guide checker
License:        MIT
Group:          Development/Languages/Python
Source:         http://pypi.python.org/packages/source/p/pep8/pep8-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  fdupes
BuildRequires:  python3
BuildRequires:  python3-2to3
BuildRequires:  python3-devel
BuildRequires:  python3-setuptools
BuildArch:      noarch

%description
Pep8 is a tool to check your Python code against some of the style
conventions in PEP 8.

%prep
%setup -q -n pep8-%{version}
sed -i "/\#\!\/usr\/bin\/env python/d" pep8.py # Remove she-bang line

%build
python3 setup.py build

%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
mv %{buildroot}%{_bindir}/pep8 %{buildroot}%{_bindir}/pep8-python%{py3_ver}
rm -rf %{buildroot}%{python3_sitelib}/__pycache__/
%fdupes %{buildroot}%{python_sitelib}

%files
%defattr(-,root,root)
%doc CHANGES.txt README.rst
%{_bindir}/pep8-python%{py3_ver}
%{python3_sitelib}/pep8.py*
%{python3_sitelib}/pep8-%{version}-py%{py3_ver}.egg-info/

%changelog
openSUSE Build Service is sponsored by