File python3-setuptools.spec of Package python3-setuptools

#
# spec file for package python3-setuptools
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python3-setuptools
Version:        18.3.2
Release:        0
Url:            http://pypi.python.org/pypi/setuptools
Summary:        Easily download, build, install, upgrade, and uninstall Python packages
License:        Python-2.0 or ZPL-2.0
Group:          Development/Languages/Python
Source:         https://pypi.python.org/packages/source/s/setuptools/setuptools-%{version}.tar.gz
Source1:        psfl.txt
Source2:        zpl.txt
Patch1:         setuptools-0.6c9-create-sitedir.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
#!BuildIgnore:  python3-pip
#NOTE(saschpe): Need 'python3' for the 'xml' module:
BuildRequires:  python3
Requires:       python3
BuildRequires:  python3-devel
Requires(post): update-alternatives
Requires(postun): update-alternatives
# NOTE(saschpe): Distribute was merged into 0.7.x, so even though distribute
# obsoletes setuptools < 0.6.45, current setuptools obsoletes distribute again
Provides:       python3-distribute = %{version}
Obsoletes:      python3-distribute < %{version}
BuildArch:      noarch

%description
setuptools is a collection of enhancements to the Python distutils that
allow you to more easily build and distribute Python packages,
especially ones that have dependencies on other packages.

%prep
%setup -q -n setuptools-%{version}
%patch1 -p0
find . -type f -name "*.orig" -delete

%build
python3 setup.py build

%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
rm %{buildroot}%{_bindir}/easy_install
mkdir -p %{buildroot}%{_sysconfdir}/alternatives
touch %{buildroot}%{_sysconfdir}/alternatives/easy_install
ln -sf %{_sysconfdir}/alternatives/easy_install %{buildroot}/%{_bindir}/easy_install

%post
update-alternatives \
    --install %{_bindir}/easy_install easy_install %{_bindir}/easy_install-%{py3_ver} 30

%postun
if [ $1 -eq 0 ] ; then
    update-alternatives --remove easy_install %{_bindir}/easy_install-%{py3_ver}
fi

%files
%defattr(-,root,root,-)
%doc CHANGES.txt README.txt
%{_bindir}/easy_install
%{_bindir}/easy_install-%{py3_ver}
%ghost %{_sysconfdir}/alternatives/easy_install
%{python3_sitelib}/_markerlib
%{python3_sitelib}/setuptools
%{python3_sitelib}/setuptools-%{version}-py%{py3_ver}.egg-info
%{python3_sitelib}/easy_install.py*
%dir %{python3_sitelib}/pkg_resources
%{python3_sitelib}/pkg_resources/*
%{python3_sitelib}/__pycache__

%changelog
openSUSE Build Service is sponsored by