File bash-completion.spec of Package bash-completion

#
# spec file for package bash-completion
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%bcond_with htmldoc

Name:           bash-completion
Version:        2.1
Release:        13
Summary:        Programmable Completion for Bash
License:        GPL-2.0+
Group:          System/Shells
Url:            http://bash-completion.alioth.debian.org/
Source0:        http://bash-completion.alioth.debian.org/files/%{name}-%{version}.tar.bz2
Source1:        bash-completion-rpmlintrc
# PATCH-FIX-UPSTREAM bnc#717151 -- Terminal tab autocompletion error
Patch0:         %{name}-%{version}.patch
# PATCH-PATCH-EXTEND-OPENSUSE bnc#818365 -- bash completion for builtin command "pushd" is missing
Patch1:         pushd-completion-bnc818365.patch
# PATCH-FIX-SUSE bnc#903362 -- tab completion for file names prints error
Patch2:         PS1-completion-boo903362.patch
# PATCH-FIX-SUSE boo#905348 -- tab completion with shell variable changes command line with backslash
Patch3:         FOO-dir-completion-boo905348.patch
# PATCH-FIX-SUSE boo#922758 -- avoid negative cword position counter
Patch4:         init-completion-boo922758.patch
# PATCH-FIX-SUSE boo#889319
Patch5:         ls-completion-boo889319.patch
# PATCH-FIX-SUSE boo#940835
Patch6:         backtick-completion-boo940835.patch
# PATCH-FIX-SUSE bsc#946875
Patch7:         LVM-completion-bsc946875.patch
# PATCH-FIX-SUSE boo#940837, bsc#959299
Patch8:         respect-variables-boo940837.patch
# PATCH-FIX-SUSE boo#958462
Patch9:         rm-completion-smart-boo958462.patch
# PATCH-FIX-SUSE boo#963140
Patch10:        backticks-bsc963140.patch
# PATCH-FIX-SUSE boo#977336
Patch11:        sh-script-completion-boo977336.patch
# PATCH-FIX-SUSE boo#1012212
Patch12:        tar-completion.patch
%if %{with htmldoc}
BuildRequires:  asciidoc
BuildRequires:  libxslt-tools
%endif
BuildRequires:  pkg-config
Requires:       bash
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch

%description
bash-completion is a collection of shell functions that take advantage
of the programmable completion feature of Bash 2.04 and later.

%prep
%setup -q
%patch0 -b .p0
%patch1 -b .p1
%patch2 -b .p2
%patch3 -b .p3
%patch4 -b .p4
%patch5 -b .p5
%patch6 -b .p6
%patch7 -b .p7 -p1
%patch8 -b .p8
%patch9 -b .p9
%patch10 -b .p10 -p1
%patch11 -b .p11 -p0
%patch12 -b .p12

%build
%configure
make %{?_smp_mflags}
%if %{with htmldoc}
pushd doc
    mkdir html
    a2x -D html -d book -f xhtml --asciidoc-opts="--unsafe" main.txt
popd
%endif

%install
%make_install
%if %{with htmldoc}
pushd doc
    mkdir -p  %{buildroot}%{_defaultdocdir}/%{name}/html
    install -m 0644 html/* %{buildroot}%{_defaultdocdir}/%{name}/html/
popd
%endif

# shipping in latest systemd now
rm -f %{buildroot}%{_datadir}/bash-completion/completions/udevadm
rm -f %{buildroot}%{_datadir}/bash-completion/completions/nmcli
# shipping in latest util-linux now
rm -f %{buildroot}%{_datadir}/bash-completion/completions/cal
rm -f %{buildroot}%{_datadir}/bash-completion/completions/chsh
rm -f %{buildroot}%{_datadir}/bash-completion/completions/dmesg
rm -f %{buildroot}%{_datadir}/bash-completion/completions/eject
rm -f %{buildroot}%{_datadir}/bash-completion/completions/hexdump
rm -f %{buildroot}%{_datadir}/bash-completion/completions/hwclock
rm -f %{buildroot}%{_datadir}/bash-completion/completions/ionice
rm -f %{buildroot}%{_datadir}/bash-completion/completions/look
if test -e %{_datadir}/bash-completion/completions/mount
then
    rm -vf %{buildroot}%{_datadir}/bash-completion/completions/mount
fi
rm -f %{buildroot}%{_datadir}/bash-completion/completions/newgrp
rm -f %{buildroot}%{_datadir}/bash-completion/completions/renice
rm -f %{buildroot}%{_datadir}/bash-completion/completions/rtcwake
rm -f %{buildroot}%{_datadir}/bash-completion/completions/su
if test -e %{_datadir}/bash-completion/completions/umount
then
    rm -vf %{buildroot}%{_datadir}/bash-completion/completions/umount
fi

%files
%defattr(-,root,root)
%doc AUTHORS COPYING README
%{_datadir}/bash-completion
%config %{_sysconfdir}/profile.d/bash_completion.sh
%{_datadir}/pkgconfig/bash-completion.pc

%changelog
openSUSE Build Service is sponsored by