File cogl.spec of Package cogl

#
# spec file for package cogl
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%if 0%{?suse_version} == 1315
%define build_wayland_backend 0
%else
%define build_wayland_backend 1
%endif
%define with_GLES2 1

Name:           cogl
Version:        1.22.2
Release:        0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer
License:        MIT
Group:          System/Libraries
Url:            http://clutter-project.org/
Source0:        http://download.gnome.org/sources/cogl/1.22/%{name}-%{version}.tar.xz
Source99:       baselibs.conf
# PATCH-FIX-UPSTREAM 0001-fix-build-failure-with-Werror-undef.patch bgo#770533 fezhang@suse.com -- Fix build failure for SLE.
Patch0:         0001-fix-build-failure-with-Werror-undef.patch
BuildRequires:  fdupes
BuildRequires:  gtk-doc >= 1.13
BuildRequires:  pkgconfig(cairo) >= 1.10
BuildRequires:  pkgconfig(gdk-pixbuf-2.0) >= 2.0
BuildRequires:  pkgconfig(gl)
BuildRequires:  pkgconfig(glesv2)
BuildRequires:  pkgconfig(glib-2.0) >= 2.32.0
BuildRequires:  pkgconfig(gobject-introspection-1.0) >= 0.9.5
BuildRequires:  pkgconfig(gstreamer-audio-1.0)
BuildRequires:  pkgconfig(gstreamer-base-1.0)
BuildRequires:  pkgconfig(gstreamer-controller-1.0)
BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0)
BuildRequires:  pkgconfig(gstreamer-tag-1.0)
BuildRequires:  pkgconfig(gstreamer-video-1.0)
BuildRequires:  pkgconfig(libdrm)
BuildRequires:  pkgconfig(pangocairo) >= 1.20
BuildRequires:  pkgconfig(x11)
BuildRequires:  pkgconfig(xcomposite) >= 0.4
BuildRequires:  pkgconfig(xdamage)
BuildRequires:  pkgconfig(xext)
BuildRequires:  pkgconfig(xfixes) >= 3
BuildRequires:  pkgconfig(xrandr) >= 1.2
%if %{build_wayland_backend}
BuildRequires:  pkgconfig(gbm)
BuildRequires:  pkgconfig(wayland-client)
BuildRequires:  pkgconfig(wayland-cursor)
BuildRequires:  pkgconfig(wayland-egl)
BuildRequires:  pkgconfig(xkbcommon)
%endif
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

%package -n libcogl20
Summary:        An object oriented GL/GLES Abstraction/Utility Layer
Group:          System/Libraries
Requires:       Mesa
Recommends:     %{name}-lang = %{version}
# To make the lang package installable
Provides:       %{name} = %{version}

%description  -n libcogl20
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

%if %{with_GLES2}
%package -n libcogl-gles2-20
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- OpenGL ES 2
Group:          System/Libraries

%description -n libcogl-gles2-20
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures
%endif

%package -n typelib-1_0-Cogl-1_0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-Cogl-1_0
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

This package provides the GObject Introspection bindings for Cogl.

%package -n typelib-1_0-Cogl-2_0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-Cogl-2_0
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

This package provides the GObject Introspection bindings for Cogl.

%package -n typelib-1_0-CoglGst-2_0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-CoglGst-2_0
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

This package provides the GObject Introspection bindings for CoglGst.

%package -n libcogl-pango20
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Pango Integration
Group:          System/Libraries

%description  -n libcogl-pango20
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

%package -n typelib-1_0-CoglPango-1_0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Pango Integration, Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-CoglPango-1_0
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

This package provides the GObject Introspection bindings for the Pango
integration in Cogl.

%package -n typelib-1_0-CoglPango-2_0
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Pango Integration, Introspection bindings
Group:          System/Libraries

%description -n typelib-1_0-CoglPango-2_0
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

This package provides the GObject Introspection bindings for the Pango
integration in Cogl.

%package -n gstreamer-plugins-cogl
Summary:        Gstreamer cogl plugins
Group:          System/Libraries
Supplements:    packageand(libcogl20:gstreamer)

%description -n gstreamer-plugins-cogl
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

This package provides the Gstreamer plugings for Cogl.

%package devel
Summary:        An object oriented GL/GLES Abstraction/Utility Layer -- Development Files
Group:          Development/Libraries/GNOME
# cogl-defines.h includes GL/gl.h
Requires:       Mesa-devel
%if %{with_GLES2}
Requires:       libcogl-gles2-20 = %{version}
%endif
Requires:       gstreamer-plugins-cogl = %{version}
Requires:       libcogl-pango20 = %{version}
Requires:       libcogl20 = %{version}
Requires:       typelib-1_0-Cogl-1_0 = %{version}
Requires:       typelib-1_0-Cogl-2_0 = %{version}
Requires:       typelib-1_0-CoglGst-2_0 = %{version}
Requires:       typelib-1_0-CoglPango-1_0 = %{version}
Requires:       typelib-1_0-CoglPango-2_0 = %{version}

%description  devel
Cogl is a small open source library for using 3D graphics hardware to draw
pretty pictures.

%lang_package
%prep
%setup -q
%patch0 -p1

%build
%configure \
        --disable-static \
        --with-pic \
        --enable-gtk-doc \
        --enable-cogl-gst \
%if %{build_wayland_backend}
         --enable-kms-egl-platform \
         --enable-wayland-egl-platform \
         --enable-wayland-egl-server \
%endif
%if %{with_GLES2}
        --enable-gles2 --enable-cogl-gles2 \
%endif
        %{nil}

make V=1 # %{?_smp_mflags} disabled, as it randomly fails for now

%install
%make_install
rm %{buildroot}%{_libdir}/*.la
rm %{buildroot}%{_libdir}/gstreamer-1.0/*.la

%find_lang cogl
%fdupes %{buildroot}%{_libdir}/pkgconfig/
%fdupes -s %{buildroot}%{_datadir}/gtk-doc/html
%fdupes -s %{buildroot}%{_includedir}/cogl/cogl/

%post -n libcogl20 -p /sbin/ldconfig

%postun -n libcogl20 -p /sbin/ldconfig

%if %{with_GLES2}
%post -n libcogl-gles2-20 -p /sbin/ldconfig

%postun -n libcogl-gles2-20 -p /sbin/ldconfig
%endif

%post -n libcogl-pango20 -p /sbin/ldconfig

%postun -n libcogl-pango20 -p /sbin/ldconfig

%files -n libcogl20
%defattr(-,root,root)
%doc COPYING NEWS README ChangeLog
%{_libdir}/libcogl.so.*
%{_libdir}/libcogl-path.so.*
%{_libdir}/libcogl-gst.so.*

%files -n gstreamer-plugins-cogl
%defattr(-,root,root)
%{_libdir}/gstreamer-1.0/*.so

%if %{with_GLES2}
%files -n libcogl-gles2-20
%defattr(-,root,root)
%{_libdir}/libcogl-gles2.so.*
%endif

%files -n typelib-1_0-Cogl-1_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/Cogl-1.0.typelib

%files -n typelib-1_0-Cogl-2_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/Cogl-2.0.typelib

%files -n typelib-1_0-CoglGst-2_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/CoglGst-2.0.typelib

%files -n libcogl-pango20
%defattr(-,root,root)
%doc COPYING NEWS README ChangeLog
%{_libdir}/libcogl-pango.so.*

%files -n typelib-1_0-CoglPango-1_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/CoglPango-1.0.typelib

%files -n typelib-1_0-CoglPango-2_0
%defattr(-,root,root)
%{_libdir}/girepository-1.0/CoglPango-2.0.typelib

%files devel
%defattr(-,root,root)
%{_libdir}/*.so
%{_includedir}/cogl/
%dir %{_datadir}/cogl/
%{_datadir}/cogl/examples-data/
%{_libdir}/pkgconfig/cogl-1.0.pc
%{_libdir}/pkgconfig/cogl-2.0-experimental.pc
%if %{with_GLES2}
%{_libdir}/pkgconfig/cogl-gles2-1.0.pc
%{_libdir}/pkgconfig/cogl-gles2-2.0-experimental.pc
%endif
%{_libdir}/pkgconfig/cogl-gl-1.0.pc
%{_libdir}/pkgconfig/cogl-gst-1.0.pc
%{_libdir}/pkgconfig/cogl-gst-2.0-experimental.pc
%{_libdir}/pkgconfig/cogl-pango-1.0.pc
%{_libdir}/pkgconfig/cogl-pango-2.0-experimental.pc
%{_libdir}/pkgconfig/cogl-path-1.0.pc
%{_libdir}/pkgconfig/cogl-path-2.0-experimental.pc
%{_datadir}/gir-1.0/*.gir
%doc %{_datadir}/gtk-doc/html/cogl/
%doc %{_datadir}/gtk-doc/html/cogl-gst/
%doc %{_datadir}/gtk-doc/html/cogl-2.0-experimental/

%files lang -f cogl.lang

%changelog
openSUSE Build Service is sponsored by