File ffmpeg.spec of Package ffmpeg
#
# spec file for package ffmpeg
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_with fdk_aac
%bcond_with lame
%bcond_with librtmp
%bcond_with twolame
%bcond_with vo_aacenc
%bcond_with x264
%bcond_with x265
%bcond_with xvid
%bcond_with opencore
%bcond_without celt
%bcond_without libass
%bcond_without libva
%bcond_without netcdf
%bcond_without openjpeg
%bcond_without vdpau
%bcond_without webp
Name: ffmpeg
Version: 3.3.1
Release: 0
Summary: Library for working with various multimedia formats
License: LGPL-2.1+ and GPL-2.0+
Group: Productivity/Multimedia/Video/Editors and Convertors
Url: https://ffmpeg.org/
#Freshcode-URL: http://freshcode.club/projects/ffmpeg
#Git-Clone: git://source.ffmpeg.org/ffmpeg
Source: https://www.ffmpeg.org/releases/%name-%version.tar.xz
Source2: https://www.ffmpeg.org/releases/%name-%version.tar.xz.asc
Source3: ffmpeg-rpmlintrc
Source4: enable_decoders
Source5: enable_encoders
Source99: baselibs.conf
Patch1: ffmpeg-libcdio_cdda-pkgconfig.patch
Patch2: ffmpeg-arm6l.diff
Patch3: ffmpeg-pkgconfig-version.patch
Patch4: ffmpeg-new-coder-errors.diff
Patch5: ffmpeg-codec-choice.diff
BuildRequires: ladspa-devel
BuildRequires: libgsm-devel
BuildRequires: pkg-config
BuildRequires: yasm
BuildRequires: pkgconfig(alsa)
BuildRequires: pkgconfig(bzip2)
%if %{with celt}
BuildRequires: pkgconfig(celt) >= 0.11.0
%endif
BuildRequires: pkgconfig(enca)
BuildRequires: pkgconfig(fontconfig) >= 2.4.2
BuildRequires: pkgconfig(freetype2)
BuildRequires: pkgconfig(fribidi) >= 0.19.0
BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(jack)
%if %{with libass}
BuildRequires: pkgconfig(libass)
%endif
BuildRequires: pkgconfig(libbluray)
BuildRequires: pkgconfig(libcdio)
BuildRequires: pkgconfig(libcdio_paranoia)
BuildRequires: pkgconfig(libdc1394-2)
BuildRequires: pkgconfig(liboil-0.3) >= 0.3.15
%if %{with openjpeg}
BuildRequires: pkgconfig(libopenjpeg)
%endif
BuildRequires: pkgconfig(libpulse)
BuildRequires: pkgconfig(libraw1394)
%if %{with libva}
BuildRequires: pkgconfig(libva) >= 0.35.0
%endif
%if %{with webp}
BuildRequires: pkgconfig(libwebp) >= 0.4
%endif
%if %{with netcdf}
BuildRequires: pkgconfig(netcdf)
%endif
BuildRequires: pkgconfig(ogg)
BuildRequires: pkgconfig(opus)
BuildRequires: pkgconfig(schroedinger-1.0)
BuildRequires: pkgconfig(sdl2)
BuildRequires: pkgconfig(speex)
BuildRequires: pkgconfig(theora) >= 1.1
%if %{with vdpau}
BuildRequires: pkgconfig(vdpau)
%endif
BuildRequires: pkgconfig(vorbis)
BuildRequires: pkgconfig(vpx) >= 1.3.0
BuildRequires: pkgconfig(x11)
BuildRequires: pkgconfig(xcb)
BuildRequires: pkgconfig(xcb-render)
BuildRequires: pkgconfig(xcb-shape)
BuildRequires: pkgconfig(xcb-shm)
BuildRequires: pkgconfig(xcb-xfixes)
BuildRequires: pkgconfig(xext)
BuildRequires: pkgconfig(xfixes)
BuildRequires: pkgconfig(zlib)
%if 0%{?BUILD_ORIG}
%if %{with fdk_aac}
BuildRequires: pkgconfig(fdk-aac)
%endif
%if %{with librtmp}
BuildRequires: pkgconfig(librtmp)
%endif
%if %{with lame}
BuildRequires: libmp3lame-devel
%endif
%if %{with xvid}
BuildRequires: libxvidcore-devel
%endif
%if %{with opencore}
BuildRequires: pkgconfig(opencore-amrnb)
%endif
%if %{with twolame}
BuildRequires: pkgconfig(twolame)
%endif
%if %{with x264}
BuildRequires: pkgconfig(x264)
%endif
%if %{with x265}
BuildRequires: pkgconfig(x265)
%endif
%endif
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Provides: ffmpeg-tools = %{version}
Obsoletes: ffmpeg-tools < %{version}
Requires: libavcodec57 = %version-%release
Requires: libavdevice57 = %version-%release
Requires: libavfilter6 = %version-%release
Requires: libavformat57 = %version-%release
Requires: libavresample3 = %version-%release
Requires: libavutil55 = %version-%release
Requires: libpostproc54 = %version-%release
Requires: libswresample2 = %version-%release
Requires: libswscale4 = %version-%release
%description
FFmpeg is a multimedia framework, able to decode, encode,
transcode, mux, demux, stream, filter and play several formats
that humans and machines have created.
%if !0%{?BUILD_ORIG}
This build of ffmpeg is limited in the number of codecs supported.
%endif
%package -n libavcodec57
Summary: FFmpeg codec library
# For mozillas
Group: System/Libraries
Requires: libavutil55 = %version-%release
Requires: libswresample2 = %version-%release
Provides: libavcodec = %version-%release
%if 0%{?BUILD_ORIG}
Provides: libavcodec-full = %version-%release
# This can be required by packages likes vlc-codecs - following the shlib name to not get random lib providers
Provides: libavcodec57(unrestricted)
%endif
%description -n libavcodec57
The libavcodec library provides a generic encoding/decoding framework
and contains multiple decoders and encoders for audio, video and
subtitle streams, and several bitstream filters.
%if !0%{?BUILD_ORIG}
This build of ffmpeg is limited in the number of codecs supported.
%endif
%package -n libavcodec-devel
Summary: Development files for FFmpeg's codec library
Group: Development/Libraries/C and C++
Requires: libavcodec57 = %version-%release
Requires: libavresample-devel = %version-%release
Requires: libavutil-devel = %version-%release
%description -n libavcodec-devel
The libavcodec library provides a generic encoding/decoding framework
and contains multiple decoders and encoders for audio, video and
subtitle streams, and several bitstream filters.
This subpackage contains the headers for FFmpeg libavcodec.
%package -n libavdevice57
Summary: FFmpeg device library
Group: System/Libraries
Requires: libavcodec57 = %version-%release
Requires: libavfilter6 = %version-%release
Requires: libavformat57 = %version-%release
Requires: libavutil55 = %version-%release
%description -n libavdevice57
The libavdevice library provides a generic framework for grabbing from
and rendering to many common multimedia input/output devices, and
supports several input and output devices, including Video4Linux2, VfW,
DShow, and ALSA.
%package -n libavdevice-devel
Summary: Development files for FFmpeg's device library
Group: Development/Libraries/C and C++
Provides: ffmpeg-devel = %version
Obsoletes: ffmpeg-devel < %version
Requires: libavcodec-devel = %version-%release
Requires: libavdevice57 = %version-%release
Requires: libavfilter-devel = %version-%release
Requires: libavformat-devel = %version-%release
Requires: libavresample-devel = %version-%release
Requires: libavutil-devel = %version-%release
Requires: libpostproc-devel = %version-%release
Requires: libswresample-devel = %version-%release
Requires: libswscale-devel = %version-%release
%description -n libavdevice-devel
The libavdevice library provides a generic framework for grabbing from
and rendering to many common multimedia input/output devices, and
supports several input and output devices, including Video4Linux2, VfW,
DShow, and ALSA.
This subpackage contains the headers for FFmpeg libavcodec.
%package -n libavfilter6
Summary: FFmpeg audio and video filtering library
Group: System/Libraries
Requires: libavcodec57 = %version-%release
Requires: libavformat57 = %version-%release
Requires: libavresample3 = %version-%release
Requires: libavutil55 = %version-%release
Requires: libpostproc54 = %version-%release
Requires: libswresample2 = %version-%release
Requires: libswscale4 = %version-%release
%description -n libavfilter6
The libavfilter library provides a generic audio/video filtering
framework containing several filters, sources and sinks.
%package -n libavfilter-devel
Summary: Development files for FFmpeg's audio/video filter library
Group: Development/Libraries/C and C++
Requires: libavcodec-devel = %version-%release
Requires: libavfilter6 = %version-%release
Requires: libavformat-devel = %version-%release
Requires: libavresample-devel = %version-%release
Requires: libavutil-devel = %version-%release
Requires: libpostproc-devel = %version-%release
Requires: libswresample-devel = %version-%release
Requires: libswscale-devel = %version-%release
%description -n libavfilter-devel
The libavfilter library provides a generic audio/video filtering
framework containing several filters, sources and sinks.
This subpackage contains the headers for FFmpeg libavcodec.
%package -n libavformat57
Summary: FFmpeg's stream format library
Group: System/Libraries
Requires: libavcodec57 = %version-%release
Requires: libavutil55 = %version-%release
%description -n libavformat57
The libavformat library provides a generic framework for multiplexing
and demultiplexing (muxing and demuxing) audio, video and subtitle
streams. It encompasses multiple muxers and demuxers for multimedia
container formats.
%if !0%{?BUILD_ORIG}
This build of ffmpeg is limited in the number of codecs supported.
%endif
%package -n libavformat-devel
Summary: Development files for FFmpeg's stream format library
Group: Development/Libraries/C and C++
Requires: libavcodec-devel = %version-%release
Requires: libavformat57 = %version-%release
Requires: libavutil-devel = %version-%release
Requires: libswresample-devel = %version-%release
%description -n libavformat-devel
The libavformat library provides a generic framework for multiplexing
and demultiplexing (muxing and demuxing) audio, video and subtitle
streams. It encompasses multiple muxers and demuxers for multimedia
container formats.
This subpackage contains the headers for FFmpeg libavcodec.
%package -n libavresample3
Summary: FFmpeg alternate audio resampling library
Group: System/Libraries
Requires: libavutil55 = %version-%release
%description -n libavresample3
An audio resampling library that is being provided for drop-in
compatibility with libav.
It is advised to use libswresample for new code.
%package -n libavresample-devel
Summary: Development files for libavresample as present in FFmpeg
Group: Development/Libraries/C and C++
Requires: libavresample3 = %version-%release
Requires: libavutil-devel = %version-%release
%description -n libavresample-devel
An audio resampling library that is being provided for drop-in
compatibility with libav.
It is advised to use libswresample for new code.
This subpackage contains the headers for FFmpeg's copy of libavresample.
%package -n libavutil55
Summary: FFmpeg's utility library
Group: System/Libraries
%description -n libavutil55
The libavutil library is a utility library to aid portable multimedia
programming. It contains safe portable string functions, random
number generators, data structures, additional mathematics functions,
cryptography and multimedia related functionality (like enumerations
for pixel and sample formats).
%package -n libavutil-devel
Summary: Development files for FFmpeg's utility library
Group: Development/Libraries/C and C++
Requires: libavutil55 = %version-%release
%description -n libavutil-devel
The libavutil library is a utility library to aid portable multimedia
programming. It contains safe portable string functions, random
number generators, data structures, additional mathematics functions,
cryptography and multimedia related functionality (like enumerations
for pixel and sample formats).
This subpackage contains the headers for FFmpeg libavcodec.
%package -n libpostproc54
Summary: FFmpeg post-processing library
Group: System/Libraries
Requires: libavutil55 = %version-%release
%description -n libpostproc54
A library with video postprocessing filters, such as deblocking and
deringing filters, noise reduction, automatic contrast and brightness
correction, linear/cubic interpolating deinterlacing.
%package -n libpostproc-devel
Summary: Development files for the FFmpeg post-processing library
Group: Development/Libraries/C and C++
Requires: libavutil-devel = %version-%release
Requires: libpostproc54 = %version-%release
%description -n libpostproc-devel
A library with video postprocessing filters, such as deblocking and
deringing filters, noise reduction, automatic contrast and brightness
correction, linear/cubic interpolating deinterlacing.
This subpackage contains the headers for FFmpeg libavcodec.
%package -n libswresample2
Summary: FFmpeg software resampling library
Group: System/Libraries
Requires: libavutil55 = %version-%release
%description -n libswresample2
The libswresample library performs audio conversion between different
sample rates, channel layout and channel formats.
%package -n libswresample-devel
Summary: Development files for the FFmpeg software resampling library
Group: Development/Libraries/C and C++
Requires: libavutil-devel = %version-%release
Requires: libswresample2 = %version-%release
%description -n libswresample-devel
The libswresample library performs audio conversion between different
sample rates, channel layout and channel formats.
This subpackage contains the headers for FFmpeg libswresample.
%package -n libswscale4
Summary: FFmpeg image scaling and colorspace/pixel conversion library
Group: System/Libraries
Requires: libavutil55 = %version-%release
%description -n libswscale4
The libswscale library performs image scaling and colorspace and
pixel format conversion operations.
%package -n libswscale-devel
Summary: Development files for FFmpeg's image scaling and colorspace library
Group: Development/Libraries/C and C++
Requires: libavutil-devel = %version-%release
Requires: libswscale4 = %version-%release
%description -n libswscale-devel
The libswscale library performs image scaling and colorspace and
pixel format conversion operations.
This subpackage contains the headers for FFmpeg libswscale.
%prep
%setup -q
%patch -P 1 -P 2 -P 3 -P 4 -P 5 -p1
%build
perl -i -pe 's{__TIME__|__DATE__}{"$&"}g' *.c
CFLAGS="%optflags" \
./configure \
--prefix="%_prefix" --libdir="%_libdir" --shlibdir="%_libdir" \
--incdir="%_includedir/ffmpeg" \
--extra-cflags="%optflags" --optflags="%optflags" \
--disable-htmlpages \
--enable-pic --disable-stripping \
--enable-shared --disable-static \
--enable-gpl \
--disable-openssl \
--enable-avresample \
--enable-libcdio \
--enable-gnutls \
--enable-ladspa \
%if %{with libass}
--enable-libass \
%endif
--enable-libbluray \
%if %{with celt}
--enable-libcelt \
%endif
--enable-libcdio \
--enable-libdc1394 \
--enable-libfreetype \
--enable-libgsm \
%if %{with openjpeg}
--enable-libopenjpeg \
%endif
--enable-libopus \
--enable-libpulse \
--enable-libschroedinger \
--enable-libspeex \
--enable-libtheora \
--enable-libvorbis \
--enable-libvpx \
%if %{with webp}
--enable-libwebp \
%endif
%if %{with netcdf}
--enable-netcdf \
%endif
%if %{with libva}
--enable-vaapi \
%endif
%if %{with vdpau}
--enable-vdpau \
%endif
%if 0%{?BUILD_ORIG}
%if %{with fdk_aac}
--enable-libfdk_aac --enable-nonfree \
%endif
%if %{with lame}
--enable-libmp3lame \
%endif
%if %{with opencore}
--enable-libopencore-amrnb \
--enable-libopencore-amrwb \
--enable-version3 \
%endif
%if %{with twolame}
--enable-libtwolame \
%endif
%if %{with x264}
--enable-libx264 \
%endif
%if %{with x265}
--enable-libx265 \
%endif
%if %{with xvid}
--enable-libxvid \
%endif
%else
--disable-encoders \
--disable-decoders \
--enable-muxers \
--enable-demuxers \
--disable-decoder=mpeg1video,mpeg2video,mpeg4,h264,vc1 \
--enable-encoder="$(perl -pe 's{^(\w*).*}{$1,}gs' <%_sourcedir/enable_encoders)" \
--enable-decoder="$(perl -pe 's{^(\w*).*}{$1,}gs' <%_sourcedir/enable_decoders)" \
%endif
cat config.h
make %{?_smp_mflags} V=1
%global extratools aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper probetest qt-faststart seek_print trasher
for i in %extratools; do
make "tools/$i"
done
%install
b="%buildroot"
%make_install install-man
rm -Rf "$b/%_datadir/ffmpeg/examples"
for i in %extratools; do
cp -a "tools/$i" "$b/%_bindir/"
done
%post -n libavcodec57 -p /sbin/ldconfig
%postun -n libavcodec57 -p /sbin/ldconfig
%post -n libavdevice57 -p /sbin/ldconfig
%postun -n libavdevice57 -p /sbin/ldconfig
%post -n libavfilter6 -p /sbin/ldconfig
%postun -n libavfilter6 -p /sbin/ldconfig
%post -n libavformat57 -p /sbin/ldconfig
%postun -n libavformat57 -p /sbin/ldconfig
%post -n libavresample3 -p /sbin/ldconfig
%postun -n libavresample3 -p /sbin/ldconfig
%post -n libavutil55 -p /sbin/ldconfig
%postun -n libavutil55 -p /sbin/ldconfig
%post -n libpostproc54 -p /sbin/ldconfig
%postun -n libpostproc54 -p /sbin/ldconfig
%post -n libswresample2 -p /sbin/ldconfig
%postun -n libswresample2 -p /sbin/ldconfig
%post -n libswscale4 -p /sbin/ldconfig
%postun -n libswscale4 -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc Changelog COPYING.GPLv2 CREDITS LICENSE.md README.md
%_bindir/*
%_mandir/man1/ff*.1*
%_datadir/ffmpeg/
%files -n libavcodec57
%defattr(-,root,root)
%_libdir/libavcodec.so.*
%files -n libavdevice57
%defattr(-,root,root)
%_libdir/libavdevice.so.*
%files -n libavfilter6
%defattr(-,root,root)
%_libdir/libavfilter.so.*
%files -n libavformat57
%defattr(-,root,root)
%_libdir/libavformat.so.*
%files -n libavresample3
%defattr(-,root,root)
%_libdir/libavresample.so.*
%files -n libavutil55
%defattr(-,root,root)
%_libdir/libavutil.so.*
%files -n libpostproc54
%defattr(-,root,root)
%_libdir/libpostproc.so.*
%files -n libswresample2
%defattr(-,root,root)
%_libdir/libswresample.so.*
%files -n libswscale4
%defattr(-,root,root)
%_libdir/libswscale.so.*
%files -n libavcodec-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libavcodec/
%_libdir/libavcodec.so
%_libdir/pkgconfig/libavcodec.pc
%_mandir/man3/libavcodec.3*
%files -n libavdevice-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libavdevice/
%_libdir/libavdevice.so
%_libdir/pkgconfig/libavdevice.pc
%_mandir/man3/libavdevice.3*
%files -n libavfilter-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libavfilter/
%_libdir/libavfilter.so
%_libdir/pkgconfig/libavfilter.pc
%_mandir/man3/libavfilter.3*
%files -n libavformat-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libavformat/
%_libdir/libavformat.so
%_libdir/pkgconfig/libavformat.pc
%_mandir/man3/libavformat.3*
%files -n libavresample-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libavresample/
%_libdir/libavresample.so
%_libdir/pkgconfig/libavresample.pc
%files -n libavutil-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libavutil/
%_libdir/libavutil.so
%_libdir/pkgconfig/libavutil.pc
%_mandir/man3/libavutil.3*
%files -n libpostproc-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libpostproc/
%_libdir/libpostproc.so
%_libdir/pkgconfig/libpostproc.pc
%files -n libswresample-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libswresample/
%_libdir/libswresample.so
%_libdir/pkgconfig/libswresample.pc
%_mandir/man3/libswresample.3*
%files -n libswscale-devel
%defattr(-,root,root)
%dir %_includedir/ffmpeg/
%_includedir/ffmpeg/libswscale/
%_libdir/libswscale.so
%_libdir/pkgconfig/libswscale.pc
%_mandir/man3/libswscale.3*
%changelog