File kaddressbook.spec of Package kaddressbook
#
# spec file for package kaddressbook
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%bcond_without lang
Name: kaddressbook
Version: 17.04.2
Release: 0
%define kf5_version 5.26.0
# Latest stable Applications (e.g. 16.08 in KA, but 16.11.80 in KUA)
%{!?_kapp_version: %global _kapp_version %(echo %{version}| awk -F. '{print $1"."$2}')}
# It can only build on the same platforms as Qt Webengine
ExclusiveArch: %ix86 x86_64 %arm aarch64 mips mips64
Summary: Address Manager
License: LGPL-2.1+ and GPL-2.0+
Group: Productivity/Networking/Email/Utilities
Url: http://www.kde.org
Source0: %{name}-%{version}.tar.xz
BuildRequires: akonadi-search-devel
BuildRequires: akonadi-server-devel >= %{_kapp_version}
BuildRequires: fdupes
BuildRequires: gettext-devel
BuildRequires: grantleetheme-devel
BuildRequires: kcmutils-devel
BuildRequires: kcrash-devel
BuildRequires: kdbusaddons-devel
BuildRequires: kdoctools-devel
BuildRequires: kontactinterface-devel
BuildRequires: kpimtextedit-devel
BuildRequires: libkdepim-devel >= %{_kapp_version}
BuildRequires: prison-qt5-devel
BuildRequires: python-devel
BuildRequires: update-desktop-files
BuildRequires: cmake(KF5KdepimDBusInterfaces)
BuildRequires: cmake(KF5Libkleo)
BuildRequires: cmake(KF5PimCommon)
BuildRequires: pkgconfig(Qt5DBus) >= 5.2.0
BuildRequires: pkgconfig(Qt5Gui) >= 5.2.0
BuildRequires: pkgconfig(Qt5PrintSupport) >= 5.2.0
BuildRequires: pkgconfig(Qt5Test) >= 5.2.0
BuildRequires: pkgconfig(Qt5Widgets) >= 5.2.0
Requires: kdepim-runtime
Provides: kaddressbook5 = %{version}
Obsoletes: kaddressbook5 < %{version}
Recommends: %{name}-lang
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
The KDE Address Book
%if %{with lang}
%lang_package
%endif
%prep
%setup -q
%build
%cmake_kf5 -d build
%make_jobs
%install
%kf5_makeinstall -C build
%if %{with lang}
%find_lang %{name} --with-man --all-name
%endif
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc COPYING COPYING.LIB COPYING.DOC
%config %{_kf5_configdir}/kaddressbook_themes.knsrc
%dir %{_kf5_appstreamdir}/
%{_kf5_servicesdir}/kaddressbookpart.desktop
%{_kf5_sharedir}/kaddressbook/
%{_kf5_bindir}/kaddressbook
%{_kf5_plugindir}/kaddressbookpart.so
%{_kf5_appstreamdir}/org.kde.kaddressbook.appdata.xml
%{_kf5_applicationsdir}/org.kde.kaddressbook*.desktop
%{_kf5_applicationsdir}/kaddressbook-importer.desktop
%config %{_kf5_configdir}/kaddressbook.categories
%config %{_kf5_configdir}/kaddressbook.renamecategories
%{_libdir}/libkaddressbookprivate.so.*
%{_kf5_plugindir}/kontact_kaddressbookplugin.so
%{_kf5_iconsdir}/hicolor/*/apps/kaddressbook.png
%{_datadir}/kconf_update/
%{_datadir}/kontact/
%{_kf5_servicesdir}/kontact/
%{_kf5_plugindir}/kaddressbook_config_plugins.so
%{_kf5_servicesdir}/kaddressbook_config_plugins.desktop
%if %{with lang}
%files lang -f %{name}.lang
%doc COPYING*
%endif
%changelog