File libconfig.spec of Package libconfig

#
# spec file for package libconfig
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


#
%define docbuild 0

Name:           libconfig
Version:        1.4.9
Release:        0
%define _soversion 9
Summary:        A simple library for manipulating structured configuration files
License:        LGPL-2.1+
Group:          System/Libraries
Url:            http://www.hyperrealm.com/main.php?s=libconfig
Source0:        http://www.hyperrealm.com/libconfig/libconfig-%{version}.tar.gz
Source1:        baselibs.conf
BuildRequires:  bison
BuildRequires:  fdupes
BuildRequires:  flex
BuildRequires:  gcc-c++
BuildRequires:  pkg-config
%if 0%{?docbuild} == 1
BuildRequires:  texinfo
BuildRequires:  texlive
BuildRequires:  texlive-latex
Requires(pre):  info
%endif
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Libconfig is a simple library for manipulating structured
configuration files, like this one: test.cfg. This file format
is more compact and more readable than XML. And unlike XML, it
is type-aware, so it is not necessary to do string parsing in
application code.

Libconfig is very compact — just 38K for the stripped C shared
library (less than one-fourth the size of the expat XML parser
library) and 66K for the stripped C++ shared library. This makes
it well-suited for memory-constrained systems like handheld
devices.

The library includes bindings for both the C and C++ languages.
It works on POSIX-compliant UNIX systems (GNU/Linux, Mac OS X,
Solaris, FreeBSD) and Windows (2000, XP and later).

%package -n libconfig%{_soversion}
Summary:        Shared libraries for libconfig
Group:          System/Libraries

%description -n libconfig%{_soversion}
Libconfig is a simple library for manipulating structured
configuration files, like this one: test.cfg. This file format
is more compact and more readable than XML. And unlike XML, it
is type-aware, so it is not necessary to do string parsing in
application code.

This package contains the shared libraries for libconfig.

%package devel
Summary:        C-Bindings development files for libconfig
Group:          Development/Languages/C and C++
Requires:       libconfig%{_soversion} = %{version}
Recommends:     libconfig-doc = %{version}

%description devel
Libconfig is a simple library for manipulating structured
configuration files, like this one: test.cfg. This file format
is more compact and more readable than XML. And unlike XML, it
is type-aware, so it is not necessary to do string parsing in
application code.

This package contains the C-bindings development files.

%package -n libconfig++%{_soversion}
Summary:        Shared libraries for libconfig
Group:          System/Libraries

%description -n libconfig++%{_soversion}
Libconfig is a simple library for manipulating structured
configuration files, like this one: test.cfg. This file format
is more compact and more readable than XML. And unlike XML, it
is type-aware, so it is not necessary to do string parsing in
application code.

This package contains the shared libraries for libconfig.

%package -n libconfig++-devel

Summary:        C++-Bindings development files for libconfig
Group:          Development/Languages/C and C++
Requires:       libconfig++%{_soversion} = %{version}
Requires:       libconfig-devel = %{version}
Recommends:     libconfig-doc = %{version}

%description -n libconfig++-devel
Libconfig is a simple library for manipulating structured
configuration files, like this one: test.cfg. This file format
is more compact and more readable than XML. And unlike XML, it
is type-aware, so it is not necessary to do string parsing in
application code.

This package contains the C++-bindings development files.

%if 0%{?docbuild} == 1
%package doc
Summary:        Documentation files for libconfig
Group:          Documentation/Other

%description doc
Documentation files for package libconfig.
%endif

%prep
%setup -q

%build
%configure
make %{?_smp_flags}
%if 0%{?docbuild} == 1
make html
make pdf
%endif

%install
%make_install
# clean up
pushd examples
    make clean
    find . -name '*.vcproj' -o -name '.deps' |xargs rm -r
popd
rm %{buildroot}%{_libdir}/*.{l,}a
%fdupes -s examples %{buildroot}%{_docdir}

%post -n libconfig%{_soversion} -p /sbin/ldconfig

%postun -n libconfig%{_soversion} -p /sbin/ldconfig

%post -n libconfig++%{_soversion} -p /sbin/ldconfig

%postun -n libconfig++%{_soversion} -p /sbin/ldconfig

%if 0%{?docbuild} == 1
%files doc
%defattr(-,root,root)
%doc doc/*.html doc/*.pdf examples
%endif

%files -n libconfig%{_soversion}
%defattr(-,root,root)
%doc AUTHORS COPYING* README
%{_libdir}/libconfig.so.*

%files -n libconfig++%{_soversion}
%defattr(-,root,root)
%doc AUTHORS COPYING* README
%{_libdir}/libconfig++.so.*

%files devel
%defattr(-,root,root)
%doc ChangeLog TODO
%{_includedir}/libconfig.h
%{_libdir}/libconfig.so
%{_libdir}/pkgconfig/libconfig.pc

%post -n libconfig++-devel
%install_info --info-dir=%{_infodir} %{_infodir}/libconfig.info.gz

%postun -n libconfig++-devel
%install_info_delete --info-dir=%{_infodir} %{_infodir}/libconfig.info.gz

%files -n libconfig++-devel
%defattr(-,root,root)
%doc ChangeLog TODO
%{_includedir}/libconfig.h++
%{_libdir}/libconfig++.so
%{_libdir}/pkgconfig/libconfig++.pc
%{_infodir}/libconfig.info.gz

%changelog
openSUSE Build Service is sponsored by