File msgpack.spec of Package msgpack

#
# spec file for package msgpack
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           msgpack
Version:        0.5.9
Release:        0
Summary:        Efficient object serialization library for cross-language communication
License:        Apache-2.0
Group:          Development/Libraries/C and C++
Url:            http://msgpack.org
Source0:        https://github.com/msgpack/msgpack-c/releases/download/cpp-%{version}/%{name}-%{version}.tar.gz
BuildRequires:  gcc-c++
BuildRequires:  pkg-config
BuildRequires:  xz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
MessagePack is a binary-based efficient object serialization library. It
enables to exchange structured objects between many languages like JSON. But
unlike JSON, it is very fast and small.

%package -n libmsgpack3
Summary:        Efficient object serialization library for cross-language communication
Group:          System/Libraries

%description -n libmsgpack3
MessagePack is a binary-based efficient object serialization library. It
enables to exchange structured objects between many languages like JSON. But
unlike JSON, it is very fast and small.

%package -n libmsgpackc2
Summary:        Efficient object serialization library for cross-language communication
Group:          System/Libraries

%description -n libmsgpackc2
MessagePack is a binary-based efficient object serialization library. It
enables to exchange structured objects between many languages like JSON. But
unlike JSON, it is very fast and small.

%package -n libmsgpack-devel
Summary:        Development headers for libmsgpack C++ library
Group:          Development/Libraries/C and C++
Requires:       libmsgpack3 = %{version}

%description -n libmsgpack-devel
Provides development headers for the msgpack C++ library.

%package -n libmsgpackc-devel
Summary:        Development headers for libmsgpack C library
Group:          Development/Libraries/C and C++
Requires:       libmsgpackc2 = %{version}

%description -n libmsgpackc-devel
Provides development headers for the msgpack C library.

%prep
%setup -q

%build
%configure --disable-static
make %{?_smp_mflags}

%install
make DESTDIR=%{buildroot} install %{?_smp_mflags}
find %{buildroot} -type f -name "*.la" -delete -print

%post -n libmsgpackc2 -p /sbin/ldconfig

%postun -n libmsgpackc2 -p /sbin/ldconfig

%post -n libmsgpack3 -p /sbin/ldconfig

%postun -n libmsgpack3 -p /sbin/ldconfig

%files -n libmsgpackc2
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NOTICE README.md
%{_libdir}/libmsgpackc.so.*

%files -n libmsgpack3
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NOTICE README.md
%{_libdir}/libmsgpack.so.*

%files -n libmsgpackc-devel
%defattr(-,root,root)
%{_libdir}/libmsgpackc.so
%{_libdir}/pkgconfig/%{name}.pc
%dir %{_includedir}/%{name}
%{_includedir}/%{name}.h
%{_includedir}/%{name}/*.h

%files -n libmsgpack-devel
%defattr(-,root,root)
%{_libdir}/libmsgpack.so
%dir %{_includedir}/%{name}
%{_includedir}/%{name}.hpp
%{_includedir}/%{name}/*.hpp
%dir %{_includedir}/%{name}/type
%{_includedir}/%{name}/type/*.hpp
%dir %{_includedir}/%{name}/type/tr1
%{_includedir}/%{name}/type/tr1/*.hpp

%changelog
openSUSE Build Service is sponsored by