File rapport.spec of Package rapport

#
# spec file for package rapport
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           rapport
Version:        0.1.4
Release:        0
Summary:        Work report generator for the lazy
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            http://github.com/saschpe/rapport
Source:         http://pypi.python.org/packages/source/r/rapport/rapport-%{version}.tar.gz
# PATCH-FIX-OPENSUSE fix-import.patch -- fix importing for futures on Python 2
Patch0:         fix-import.patch
BuildRequires:  python-devel
BuildRequires:  python-setuptools
# Test requirements:
BuildRequires:  python-Jinja2
BuildRequires:  python-Trolly
BuildRequires:  python-argparse
BuildRequires:  python-bugzilla
BuildRequires:  python-coverage
BuildRequires:  python-futures
BuildRequires:  python-lxml
BuildRequires:  python-nose
BuildRequires:  python-paramiko
BuildRequires:  python-requests
BuildRequires:  python-tweepy
Requires:       python-Jinja2
Requires:       python-Trolly
Requires:       python-argparse
Requires:       python-bugzilla
Requires:       python-futures
Requires:       python-lxml
Requires:       python-paramiko
Requires:       python-requests
Requires:       python-tweepy
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?suse_version} && 0%{?suse_version} <= 1110
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%else
BuildArch:      noarch
%endif

%description
Writing work reports is tedious. Some people have custom hacks. This is meant
to be the last one. It's Apache-2.0 licensed and written in Python, not
VimScript, not Bash, not Ruby, not C, ..., you probably got it ;-)

%prep
%setup -q -n rapport-%{version}
%patch0 -p1

%build
python setup.py build

%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}

%check
nosetests

%files
%defattr(-,root,root,-)
%doc LICENSE README.rst
%{_bindir}/rapport
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by