File u-boot-cubietruck.spec of Package u-boot-nanopineoair

#
# spec file for package u-boot-cubietruck
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2010 Texas Instruments Inc by Nishanth Menon
# Copyright (c) 2007-2010 by Silvan Calarco <silvan.calarco@mambasoft.it>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define mvebu_spl 0
%define x_loader 0
%define rockchip_spl 0
%define sunxi_spl 1
%define arndale_spl 0
%define cuboxi_spl 0
%define origen_spl 0
%define udoo_spl 0
%define imx6_spl 0
%define socfpga_spl 0

%if "cubietruck" == "rpi" || "cubietruck" == "rpi2" || "cubietruck" == "rpi332b" || "cubietruck" == "rpi3"
%define is_rpi 1
%endif

# archive_version differs from version for RC version only
%define archive_version 2017.05

Name:           u-boot-cubietruck
Version:        2017.05
Release:        0
Summary:        The U-Boot firmware for the cubietruck platform
License:        GPL-2.0
Group:          System/Boot
Url:            http://www.denx.de/wiki/U-Boot
Source:         ftp://ftp.denx.de/pub/u-boot/u-boot-%{archive_version}.tar.bz2
Source1:        ftp://ftp.denx.de/pub/u-boot/u-boot-%{archive_version}.tar.bz2.sig
Source2:        arndale-bl1.img
Source3:        update_git.sh
Source300:      u-boot-rpmlintrc
Patch0001:      0001-XXX-openSUSE-XXX-Load-dtb-from-part.patch
Patch0002:      0002-Revert-Revert-omap3-Use-raw-SPL-by-.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
# Arndale board need DTC >= 1.4
BuildRequires:  bc
BuildRequires:  dtc >= 1.4.0
# u-boot-clearfog (tools/kwbimage.c) needs openssl to build
BuildRequires:  libopenssl-devel
# u-boot-firefly-rk3288 needs python to build
BuildRequires:  python
%if "%{name}" == "u-boot-qemu-ppce500"
# Owns /usr/share/qemu directory
BuildRequires:  qemu
Provides:       qemu-ppc:%{_datadir}/qemu/u-boot.e500
%endif
%if 0%{?is_rpi}
# Owns /boot/vc directory
BuildRequires:  raspberrypi-firmware
# For mountpoint
Requires(post): util-linux
%endif
Provides:       u-boot-loader
Conflicts:      otherproviders(u-boot-loader)
%if %x_loader == 1
Obsoletes:      x-loader-cubietruck
Provides:       x-loader-cubietruck
%endif
ExclusiveArch:  armv7l armv7hl

%description
Das U-Boot (or just "U-Boot" for short) is Open Source Firmware for Embedded PowerPC, ARM, MIPS and x86 processors.
This package contains the firmware for the cubietruck platform.

%package doc
Summary:        Documentation for the U-Boot Firmware
Group:          Documentation/Other

%description doc
Das U-Boot (or just "U-Boot" for short) is Open Source Firmware for Embedded PowerPC, ARM, MIPS and x86 processors.
This package contains documentation for U-Boot firmware.

%prep
%setup -q -n u-boot-%{archive_version}
%patch0001 -p1
%patch0002 -p1

%build
export SOURCE_DATE_EPOCH=$(date -d "$(head -n 2 %{_sourcedir}/%{name}.changes | tail -n 1 | cut -d- -f1 )" +%s)
make %{?_smp_mflags} CROSS_COMPILE= HOSTCFLAGS="$RPM_OPT_FLAGS" Cubietruck_defconfig
echo "Attempting to enable fdt apply command (.dtbo) support."
echo "CONFIG_OF_LIBFDT_OVERLAY=y" >> .config
make %{?_smp_mflags} CROSS_COMPILE= HOSTCFLAGS="$RPM_OPT_FLAGS" USE_PRIVATE_LIBGG=yes

%if "%{name}" == "u-boot-snow" || "%{name}" == "u-boot-spring"
# Chromebook ARM (snow) and HP Chromebook 11 (spring) need a uImage format
export TEXT_START=$(awk '$NF == "_start" { printf "0x"$1 }' System.map)
./tools/mkimage -A arm -O linux -T kernel -C none -a $TEXT_START -e $TEXT_START -n uboot -d u-boot-dtb.bin u-boot.img
%endif

%if %rockchip_spl == 1
for t in ; do
    ./tools/mkimage -n  -d spl/u-boot-spl.bin -T $t u-boot-spl.$t
done
%endif

%install
export SOURCE_DATE_EPOCH=$(date -d "$(head -n 2 %{_sourcedir}/%{name}.changes | tail -n 1 | cut -d- -f1 )" +%s)
export NO_BRP_STRIP_DEBUG=true
export NO_DEBUGINFO_STRIP_DEBUG=true
%define uboot_dir /boot
%if 0%{?is_rpi}
%define uboot_dir /boot/vc
%endif
%if "%{name}" == "u-boot-qemu-ppce500"
%define uboot_dir %{_datadir}/qemu
%endif
%if "%{name}" == "u-boot-jetson-tk1"
# tegra-uboot-flasher needs several intermediate files, under their original name.
for f in u-boot u-boot.dtb u-boot-dtb-tegra.bin u-boot-nodtb-tegra.bin spl/u-boot-spl; do
    install -D -m 0644 $f %{buildroot}/boot/$f
done
%else
# Some times u-boot needs a dtb to configure itself appended to the binary.
# In that case prefer the one with a working dtb already appended.
if [ -f u-boot-dtb-tegra.bin ]; then
    install -D -m 0644 u-boot-dtb-tegra.img %{buildroot}%{uboot_dir}/u-boot.img
elif [ -f u-boot-dtb.img ]; then
    install -D -m 0644 u-boot-dtb.img %{buildroot}%{uboot_dir}/u-boot.img
else
    install -D -m 0644 u-boot.img %{buildroot}%{uboot_dir}/u-boot.img
fi
%if "%{name}" == "u-boot-qemu-ppce500"
mv %{buildroot}%{uboot_dir}/u-boot.img %{buildroot}%{uboot_dir}/u-boot.e500
%endif
%endif
%if %x_loader == 1
install -D -m 0755 MLO %{buildroot}/boot/MLO
%endif
%if %origen_spl == 1
install -D -m 0755 spl/origen-spl.bin %{buildroot}/boot/origen-spl.bin
%endif
%if %arndale_spl == 1
install -D -m 0755 spl/arndale-spl.bin %{buildroot}/boot/arndale-spl.bin
install -D -m 0755 %{SOURCE2} %{buildroot}/boot/arndale-bl1.img
%endif
%if %mvebu_spl == 1
install -D -m 0755 u-boot-spl.kwb %{buildroot}%{uboot_dir}/u-boot-spl.kwb
%endif
%if %rockchip_spl == 1
install -D -m 0644 spl/u-boot-spl.bin %{buildroot}%{uboot_dir}/u-boot-spl.bin
for t in ; do
    install -D -m 0644 u-boot-spl.$t %{buildroot}%{uboot_dir}/u-boot-spl.$t
done
%endif
%if %sunxi_spl == 1
install -D -m 0755 spl/sunxi-spl.bin %{buildroot}/boot/sunxi-spl.bin
install -D -m 0755 u-boot-sunxi-with-spl.bin %{buildroot}/boot/u-boot-sunxi-with-spl.bin
%endif
%if %cuboxi_spl == 1
install -D -m 0755 SPL %{buildroot}/boot/cuboxi-spl.bin
%endif
%if %udoo_spl == 1
install -D -m 0755 SPL %{buildroot}/boot/udoo_spl.bin
%endif
%if %imx6_spl == 1
install -D -m 0755 SPL %{buildroot}/boot/imx6-spl.bin
%endif
%if %socfpga_spl == 1
install -D -m 0755 u-boot-with-spl.sfp %{buildroot}/boot/u-boot-with-spl.sfp
%endif

%if 0%{?is_rpi}
%post
# On the Raspberry Pi we chain-load u-boot.bin from bootcode.bin via config.txt.
# It needs to be on the first FAT partition, wherever we mounted it.
# a) Unmounted, then do nothing.
# b) Mounted as /boot/vc, then they're in the right place already.
# c) Mounted as /boot/efi, with /boot/vc as symlink, then nothing to be done.
# d) Mounted as /boot/efi, with /boot/vc a directory, then copy files over.
if mountpoint -q /boot/efi; then
  [[ "$(readlink -f /boot/efi)" -ef "$(readlink -f %{uboot_dir})" ]] || cp %{uboot_dir}/u-boot.img /boot/efi/
fi
%endif

%files
%defattr(-,root,root)
%{uboot_dir}/*
%doc Licenses/gpl-2.0.txt README

%files doc
%defattr(-,root,root)
# Generic documents
%doc doc/README.JFFS2 doc/README.JFFS2_NAND doc/README.commands
%doc doc/README.autoboot doc/README.commands doc/README.console doc/README.dns
%doc doc/README.hwconfig doc/README.nand doc/README.NetConsole doc/README.serial_multi
%doc doc/README.SNTP doc/README.standalone doc/README.update doc/README.usb
%doc doc/README.video doc/README.VLAN doc/README.silent doc/README.POST
# Copy some useful kermit scripts as well
%doc tools/kermit/dot.kermrc tools/kermit/flash_param tools/kermit/send_cmd tools/kermit/send_image
# Now any h/w dependent Documentation
%doc doc/README.ARM-memory-map

%changelog
openSUSE Build Service is sponsored by